Topic
5 replies Latest Post - ‏2012-05-28T23:43:33Z by SystemAdmin
NNA
NNA
39 Posts
ACCEPTED ANSWER

Pinned topic UA unmanaged

‏2011-05-26T09:30:12Z |
hi everybody;
i'm a bit confuse about my UA status;
in fact when i consult my agent management service attribute, i have these results concerning the universal agent:
status: Unmanaged
manager type: Not Managed in the agents' management status window
concerning the agents' runtime status window,
agent availability: Unknown
username: Not Available while it is root for the monitoring agent
curiously, for the monitoring agent the availability shows that it is running but unknown for the UA without forgetting that i've already run the itmcmd agent start um command to start the UA and i've this result display in the console: KCIIN0207E Instance None already running
KCIIN0195E Agent already started...
please is there a difference between starting an agent and running it and what should be the problem concerning the network management of my UA?
what should i do to correct this case?
need your help and thanks...
Updated on 2012-05-28T23:43:33Z at 2012-05-28T23:43:33Z by SystemAdmin
  • NNA
    NNA
    39 Posts
    ACCEPTED ANSWER

    Re: UA unmanaged

    ‏2011-05-26T16:35:45Z  in response to NNA
    ALSO to add actually my UA is dimmed in the navigator tree and when i try to start it, it is display: unable to start the agent and when i glance at the log file:
    ...(4DDE7D60.0036-1:kumamain.cpp,1025,"UA_Main") Universal Agent startup in progress
    (4DDE7D60.0037-1:kumamain.cpp,1061,"UA_Main") Globalization is enabled
    (4DDE7D60.0038-1:kbbssge.c,52,"BSS1_GetEnv") CANDLEHOME="/opt/IBM/ITM"
    (4DDE7D60.0039-1:kbbssge.c,52,"BSS1_GetEnv") ITM_BINARCH="li6263"
    (4DDE7D60.003A-1:kbbssge.c,52,"BSS1_GetEnv") KDCB0_HOSTNAME="network00"
    (4DDE7D60.003B-1:kbbssge.c,52,"BSS1_GetEnv") CTIRA_HOSTNAME="yde-itm-hub-tems"
    (4DDE7D60.003C-1:kbbssge.c,52,"BSS1_GetEnv") KUM_PREFER_IP_VERSION="4"
    (4DDE7D60.003D-1:kum0sock.c,214,"KUM0_OpenLocalSocket") *** bind failed for local TCP address network00 addrlen 16 socket 4, port=0, errno=99
    (4DDE7D60.003E-1:kum0sock.c,148,"KUM0_OpenLocalSocket") *** socket address initialization failed for <network00> errno=0 family=10 port=0 proto=6 type=1 use=0
    (4DDE7D60.003F-1:kum0sdip.c,160,"KUM0_SetDefaultSocketFamily") *INFO: IPv4 NOT Available
    (4DDE7D60.0040-1:kum0sdip.c,165,"KUM0_SetDefaultSocketFamily") *INFO: IPv6 NOT Available
    (4DDE7D60.0041-1:kum0sdip.c,168,"KUM0_SetDefaultSocketFamily") *INFO: Prefer IP use IPv4
    (4DDE7D60.0042-1:kum0sock.c,214,"KUM0_OpenLocalSocket") *** bind failed for local UDP address network00 addrlen 16 socket 4, port=0, errno=99
    (4DDE7D60.0043-1:kumdsock.cpp,2123,"ipcSock::IPCClient") Error: _sockUDP-1 errno=99
    (4DDE7D60.0044-1:kumdipc.cpp,147,"DCHipc::startup") Error: IPCClient failed
    (4DDE7D60.0045-1:kumdsock.cpp,218,"ipcSock::ipcSock") Error: startup failed. _sockError=1
    (4DDE7D60.0046-1:kumdsock.cpp,223,"ipcSock::ipcSock") Error: _sockError=1
    (4DDE7D62.0000-2:kumdsock.cpp,1510,"ipcSock::openDCHsocket") *** bind failed for DCH UDP address network00 addrlen 16 socket 4 port=1919 errno=99
    (4DDE7D62.0001-2:kumdsock.cpp,1510,"ipcSock::openDCHsocket") *** bind failed for DCH TCP address network00 addrlen 16 socket 4 port=1919 errno=99
    (4DDE7D62.0002-2:kumdsock.cpp,1180,"ipcSock::allocateDCHport") Error: Could not open TCP/UDP sockets bound to Universal Agent DCH port 1919 for IP address 67.215.65.132
    (4DDE7D62.0003-2:kumdsock.cpp,1181,"ipcSock::allocateDCHport") Verify that Universal Agent has been configured with the correct local IP address. Exiting...
    (4DDE7D62.0004-2:kumamain.cpp,454,"StopAgentProcess") Universal Agent process being stopped

    what is the meaning of this, please...
    • SystemAdmin
      SystemAdmin
      6056 Posts
      ACCEPTED ANSWER

      Re: UA unmanaged

      ‏2011-05-27T13:28:13Z  in response to NNA
      I think I saw this before.

      In my system, the hostname was not resolving to the IP address of the machine (someone changed it) and I couldn't being ping myself from the box. Once I fixed the /etc/hosts file to reflect the correct ip address, it start up correctly.
      This was my error below:

      4DD52675.003F-1:kum0sock.c,214,"KUM0_OpenLocalSocket") *** bind failed for local TCP address possrv addrlen 16 socket 4, port=0, errno=99
      (4DD52675.0040-1:kum0isad.c,244,"KUM0_InitializeSocketAddress") *INFO: unable to initialize ip address <possrv> rc=-2 errno=2 family=10 port=0 proto=06 type=01 use=0 inaddrany=0
      (4DD52675.0041-1:kum0sock.c,148,"KUM0_OpenLocalSocket") *** socket address initialization failed for <possrv> errno=2 family=10 port=0 proto=6 type=1 use=0
      (4DD52675.0042-1:kum0sdip.c,160,"KUM0_SetDefaultSocketFamily") *INFO: IPv4 NOT Available
      (4DD52675.0043-1:kum0sdip.c,165,"KUM0_SetDefaultSocketFamily") *INFO: IPv6 NOT Available
      (4DD52675.0044-1:kum0sdip.c,168,"KUM0_SetDefaultSocketFamily") *INFO: Prefer IP use IPv4
      (4DD52675.0045-1:kum0sock.c,214,"KUM0_OpenLocalSocket") *** bind failed for local UDP address possrv addrlen 16 socket 4, port=0, errno=99
      (4DD52675.0046-1:kumdsock.cpp,2123,"ipcSock::IPCClient") Error: _sockUDP-1 errno=99
      (4DD52675.0047-1:kumdipc.cpp,147,"DCHipc::startup") Error: IPCClient failed
      (4DD52675.0048-1:kumdsock.cpp,218,"ipcSock::ipcSock") Error: startup failed. _sockError=1
      (4DD52675.0049-1:kumdsock.cpp,223,"ipcSock::ipcSock") Error: _sockError=1
      (4DD52677.0000-2:kumdsock.cpp,1510,"ipcSock::openDCHsocket") *** bind failed for DCH UDP address possrv addrlen 16 socket 4 port=1919 errno=99
      (4DD52677.0001-2:kumdsock.cpp,1510,"ipcSock::openDCHsocket") *** bind failed for DCH TCP address possrv addrlen 16 socket 4 port=1919 errno=99

      Looks to be the same??

      HTH
      • SystemAdmin
        SystemAdmin
        6056 Posts
        ACCEPTED ANSWER

        Re: UA unmanaged

        ‏2011-05-27T14:40:09Z  in response to SystemAdmin
        I should of proof read that before I posted :)
        In my system, the hostname was not resolving to the IP address of the machine (someone changed it) and I couldn't ping myself from the box. Once I fixed the /etc/hosts file to reflect the correct ip address, it started up correctly.*
        • NNA
          NNA
          39 Posts
          ACCEPTED ANSWER

          Re: UA unmanaged

          ‏2011-05-30T10:54:11Z  in response to SystemAdmin
          THANKS FOR YOUR REPLY
          in my case it seem to be no problem concerning the host file configuration; there is no change in my IP address machine
          i think my real problem reside in this message:
          ...:kumdsock.cpp,1180,"ipcSock::allocateDCHport") Error: Could not open TCP/UDP sockets bound to Universal Agent DCH port 1919 for IP address 67.215.65.132
          (4DE3E49B.0002-2:kumdsock.cpp,1181,"ipcSock::allocateDCHport") Verify that Universal Agent has been configured with the correct local IP address. Exiting...
          what is the utility of this address 67.215.65.132 and how can i verify that my UA has been configured with the correct local IP address?
          am i wrong when i think that what it's called local IP address is my UA's host IP address?
  • SystemAdmin
    SystemAdmin
    6056 Posts
    ACCEPTED ANSWER

    Re: UA unmanaged

    ‏2012-05-28T23:43:33Z  in response to NNA
    El problema radica en que esta tomando una IP que no debe, para solucionar esto deben ingresar al directorio .ConfigData y en KUMENV buscar la linea aix526|PRIMARYIP|none| y colocar donde dice none la IP principal del servidor. iniciar el agente y listo.