Topic
  • 10 replies
  • Latest Post - ‏2013-02-21T18:57:02Z by SystemAdmin
|/|.|-|.
|/|.|-|.
4 Posts

Pinned topic Installations Fails \\ Informix errors...

‏2011-05-20T10:07:56Z |
Hi,

My problem is that installation process of Cognos Express 9.5 fails.
The problem stage of installation process is “Installing…Configuring Cognos Express…Initializing Content Store».
Windows service Informix IDS – cm_ids_crv_custom hangs on the Start stage too. Attempts to restart Informix service are not successful.
Advise «Installation and Configuration Issues. IBM Cognos Express stops functioning on Windows 2008 64-bit» don’t help too (http://publib.boulder.ibm.com/infocenter/cx/v9r5m0/index.jsp?topic=/com.ibm.swg.im.cognos.relnotes_exprss.9.5.0.doc/relnotes_exprss_id92EXP_multcomp_inst_issues.html).
Log files of Informix have two errors: «Error building 'sysmaster' database» и «921: System error. Illegal or wrong number of arguments to sqlexec server.»

Envinronments:
Installing software package is Cognos Express 9.5 64-bit Multilingual for Windows.
Operating system is Windows Server 2008 R2.

Can anyone help me to install Cognos Express, please?
Updated on 2013-02-21T18:57:02Z at 2013-02-21T18:57:02Z by SystemAdmin
  • |/|.|-|.
    |/|.|-|.
    4 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2011-05-31T19:19:16Z  
    Hi once again,

    There are problem log-files in the attachment.

    Can anyone help me, please?
  • |/|.|-|.
    |/|.|-|.
    4 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2011-06-01T16:38:17Z  
    Hi,

    My new attempts to solve the problem was without success:
    • disable UAC
    • run installation under build-in Windows admin account
    • run install.exe in compartible mode with 2003 Server

    Do you know what is the base trouble – the problem to create 'sysmaster’ database or the problem to run Windows service Informix IDS cm_ids_crv_custom hangs?
  • |/|.|-|.
    |/|.|-|.
    4 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2011-06-02T04:52:07Z  
    Hi,

    I place in this post new log-files regarding the problem:

    • Windows Events Logs
    • Cognos Express Logs

    Can anyone give advice to fix my problem, please?
  • SystemAdmin
    SystemAdmin
    214 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2011-06-27T14:40:20Z  
    • |/|.|-|.
    • ‏2011-06-02T04:52:07Z
    Hi,

    I place in this post new log-files regarding the problem:

    • Windows Events Logs
    • Cognos Express Logs

    Can anyone give advice to fix my problem, please?
    Hi

    I am having exactly the same issue with my install. I have tried installing 9.0 and 9.5 and they fail at exactly the same point. I have checked the log files and there was something about VM. We are running the install on a VM image. I havent had this problem before when installing on servers. So can only think it has soemthing to do with the fact that it is on a VM image. BUT i have two seperate installs on two windows 7 x64 VMWARE images.

    HELP!!!!

    Regards
    Shane
  • rbaierle
    rbaierle
    1 Post

    Re: Installations Fails \\ Informix errors...

    ‏2011-06-28T14:44:40Z  
    Hi

    I am having exactly the same issue with my install. I have tried installing 9.0 and 9.5 and they fail at exactly the same point. I have checked the log files and there was something about VM. We are running the install on a VM image. I havent had this problem before when installing on servers. So can only think it has soemthing to do with the fact that it is on a VM image. BUT i have two seperate installs on two windows 7 x64 VMWARE images.

    HELP!!!!

    Regards
    Shane
    Try changing your DEP (Data Execution Prevention) settings.

    If you are logged on as an administrator, you can manually configure DEP to switch between the OptIn and OptOut policies by using the Data Execution Prevention tab in System Properties. The following procedure describes how to manually configure DEP on the computer:

    Click Start, click Run, type sysdm.cpl, and then click OK.
    On the Advanced tab, under Performance, click Settings.
    On the Data Execution Prevention tab, use one of the following procedures:

    Click Turn on DEP for essential Windows programs and services only to select the OptIn policy.

    Click OK two times.

    You will have to reboot after making this change.
  • RSharp
    RSharp
    2 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2012-01-21T00:40:21Z  
    • rbaierle
    • ‏2011-06-28T14:44:40Z
    Try changing your DEP (Data Execution Prevention) settings.

    If you are logged on as an administrator, you can manually configure DEP to switch between the OptIn and OptOut policies by using the Data Execution Prevention tab in System Properties. The following procedure describes how to manually configure DEP on the computer:

    Click Start, click Run, type sysdm.cpl, and then click OK.
    On the Advanced tab, under Performance, click Settings.
    On the Data Execution Prevention tab, use one of the following procedures:

    Click Turn on DEP for essential Windows programs and services only to select the OptIn policy.

    Click OK two times.

    You will have to reboot after making this change.
    thanks , that DEP worked a treat
  • SystemAdmin
    SystemAdmin
    214 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2012-02-12T11:32:38Z  
    • RSharp
    • ‏2012-01-21T00:40:21Z
    thanks , that DEP worked a treat
    The same problem: "Installing ... Configuring Cognos Express ... Initializing Content Store». The Informix IDS - cm_ids_svr_custom service hung on starting. Click Turn on DEP for essential Windows programs and services only-does not help. In the log file buildsmi_out.cm_ids_svr_custom: "921: System error. Illegal or wrong number of arguments to sqlexec server.
    Error in line 28
    Near character position 1. " System: VM, OS-Windows server 2008 S2 Enterprise Service pack 1. Logged on as an" Administrator ".
  • JohnWilkinson
    JohnWilkinson
    4 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2012-03-05T19:58:35Z  
    The same problem: "Installing ... Configuring Cognos Express ... Initializing Content Store». The Informix IDS - cm_ids_svr_custom service hung on starting. Click Turn on DEP for essential Windows programs and services only-does not help. In the log file buildsmi_out.cm_ids_svr_custom: "921: System error. Illegal or wrong number of arguments to sqlexec server.
    Error in line 28
    Near character position 1. " System: VM, OS-Windows server 2008 S2 Enterprise Service pack 1. Logged on as an" Administrator ".
    I have found that the main cause of informix content store initialization errors is when your group security policy disallows the creation of local user groups.

    When CX installs, it creates a new user called icognosexpress, and also creates a new local user group called Informix Admin, and then adds the Administrator user to this group. If this local user group cannot be created, Informix will fail to start.
  • D48X_Greb_Nattol
    D48X_Greb_Nattol
    1 Post

    Re: Installations Fails \\ Informix errors...

    ‏2012-06-04T21:30:25Z  
    try this

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cm_ids_svr_custom

    DependOnService reg_multi_sz netman
  • SystemAdmin
    SystemAdmin
    214 Posts

    Re: Installations Fails \\ Informix errors...

    ‏2013-02-21T18:57:02Z  
    try this

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cm_ids_svr_custom

    DependOnService reg_multi_sz netman
    Is this to be an added DWORD in the registry?