Topic
7 replies Latest Post - ‏2011-06-29T17:26:28Z by SystemAdmin
MaheshKharvi
MaheshKharvi
43 Posts
ACCEPTED ANSWER

Pinned topic CIM target add doesn't take default agent path

‏2011-05-19T14:37:46Z |
I am trying to add multiple users to create a group.

While adding target, I am providing the install manager agent location. But CIM doesn't take this value.

Take a look at the picture.
Updated on 2011-06-29T17:26:28Z at 2011-06-29T17:26:28Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    462 Posts
    ACCEPTED ANSWER

    Re: CIM target add doesn't take default agent path

    ‏2011-05-19T15:45:27Z  in response to MaheshKharvi
    Hi Mahesh,

    Please make sure the paths entered into the "Installation Manager data location path(s)" field are valid Installation Manager data locations. The location should contain installed.xml and installRegistry.xml.

    In addition, user sctadmin must have read/write permission to the data location /fisc/middleware.

    HTH
    Felix Wong
    CIM Development Team
    • MaheshKharvi
      MaheshKharvi
      43 Posts
      ACCEPTED ANSWER

      Re: CIM target add doesn't take default agent path

      ‏2011-05-20T05:54:47Z  in response to SystemAdmin
      Felix,

      As you said it is not a valid install data location.

      I have some requirements.
      I want to install IM on 10 servers using target group option, I don't want to use default IM data location(i.e $USER_HOME).
      I would like to have data location pointing to /was/im_agent/$USER so that it is easier to manage.

      Thanks,
      Mahesh
      • SystemAdmin
        SystemAdmin
        462 Posts
        ACCEPTED ANSWER

        Re: CIM target add doesn't take default agent path

        ‏2011-05-24T14:28:54Z  in response to MaheshKharvi
        Hi Mahesh,

        The "Install IBM Installation Manager" job has options to specify the data location. Did you try that?

        Felix Wong
        CIM Development Team
        • MaheshKharvi
          MaheshKharvi
          43 Posts
          ACCEPTED ANSWER

          Re: CIM target add doesn't take default agent path

          ‏2011-05-26T10:53:43Z  in response to SystemAdmin
          I am trying to install IM for target group, so want to specify unique location for each user.
          • SystemAdmin
            SystemAdmin
            462 Posts
            ACCEPTED ANSWER

            Re: CIM target add doesn't take default agent path

            ‏2011-05-26T14:24:51Z  in response to MaheshKharvi
            Did you try specifying $USER in the data location path? If the shell of your target host can resolve it, this should be fine.
            • MaheshKharvi
              MaheshKharvi
              43 Posts
              ACCEPTED ANSWER

              Re: CIM target add doesn't take default agent path

              ‏2011-06-29T15:17:26Z  in response to SystemAdmin
              Felix,

              I know this is late to respond. But it doesn't take variables specified in ~/.profile.
              We can use only those variables defined by system.

              Thanks,
              Mahesh
              • SystemAdmin
                SystemAdmin
                462 Posts
                ACCEPTED ANSWER

                Re: CIM target add doesn't take default agent path

                ‏2011-06-29T17:26:28Z  in response to MaheshKharvi
                CIM does not run the remote commands in a shell and therefore it does not have access to the user's environment.

                Regards,
                Felix Wong