• 3 replies
  • Latest Post - ‏2017-11-03T16:04:42Z by bobrgl
308 Posts

Pinned topic passing NLSPATH through sudo

‏2011-05-18T21:44:29Z |
when I run cicsadd through sudo I get the below error. This happens even if I am performing updates/deletes. I understand sudo doesn't pass NLSPATH of the user so how can I get through this problem.
In my user profile in AIX i have the right directories being passed to NLSPATH & LANG variables.
$ sudo cicsadd -c td -r test1 DTST ProgName="test01"
ERZ057001E/0058: Cannot access message catalog for message ERZ046091I
Please check if NLSPATH or LANG variable is set
Updated on 2011-05-23T18:10:46Z at 2011-05-23T18:10:46Z by SystemAdmin
  • lakshuraghav
    7 Posts

    Re: passing NLSPATH through sudo

    You can possibly try creating a soft link of<LANG>) under /usr/lib/nls/msg/<LANG>/ and check if it works.
  • SystemAdmin
    308 Posts

    Re: passing NLSPATH through sudo

    Thanks it worked.
  • bobrgl
    1 Post

    Re: passing NLSPATH through sudo


    I just installed TXSERIES V8.2  on Ubuntu 16.04

    I set language to English

    I get error cannot find CAT msgs,  ck NLSPATH and Lang


    I saw a fix was to create  a link which  I have done  /usr/lib/nls/en_US

    lrwxrwxrwx 1 root root   32 Oct 19 18:05 -> /opt/ibm/cics/msg/en_US/


    I'm stiil getting this error.