Topic
  • 5 replies
  • Latest Post - ‏2013-03-08T12:33:01Z by nvf
igorM
igorM
302 Posts

Pinned topic How to display more then 50 members in hiearchy in Report Studio?

‏2011-05-18T12:35:18Z |
Hi,
using Cognos BI 8.4.1 Report Studio accessing TM1 9.5.0 cube. Crosstab report. When selecting members from Insertable Object window for example clicking on hierarchy: market dimension, market hierarchy, Members folder, Buyer_dim, Europe, Germany there are 50 buyers displayed. At the last position of buyer there is Search link displayed. So other users is possible to select only if Search link is clicked and typed in some text to search a buyer.

Is there any way I can do the following:
1. display all members in particular level (instead of just first 50)
2. display like it is now, but with Next button to show next 50 buyers
3. by default display more then 50 buyers like set something like 200 members

Regards
Updated on 2013-03-08T12:33:01Z at 2013-03-08T12:33:01Z by nvf
  • OpherB
    OpherB
    664 Posts

    Re: How to display more then 50 members in hiearchy in Report Studio?

    ‏2011-05-18T22:19:41Z  
    I don't work with TM1 cubes, but for PowerPlay cubes you can open the Package Properties and there is a link to "Modify the package configuration...". That page has fields to change the default and maxiumum number of values displayed.

    I should point out that this setting will need to be updated every time the Package is republished, a fact that Cognos should fix as a bug....

    Opher
  • SystemAdmin
    SystemAdmin
    15496 Posts

    Re: How to display more then 50 members in hiearchy in Report Studio?

    ‏2011-05-19T00:11:25Z  
    • OpherB
    • ‏2011-05-18T22:19:41Z
    I don't work with TM1 cubes, but for PowerPlay cubes you can open the Package Properties and there is a link to "Modify the package configuration...". That page has fields to change the default and maxiumum number of values displayed.

    I should point out that this setting will need to be updated every time the Package is republished, a fact that Cognos should fix as a bug....

    Opher
    On a side note, the PowerCube package doesn't need to be published every time you update the cube. The Transformer cube build process has separate options for deploying the cube and publishing the cube package. You can deploy the new cube file(s) without re-publishing.
  • igorM
    igorM
    302 Posts

    Re: How to display more then 50 members in hiearchy in Report Studio?

    ‏2011-05-19T07:32:25Z  
    • OpherB
    • ‏2011-05-18T22:19:41Z
    I don't work with TM1 cubes, but for PowerPlay cubes you can open the Package Properties and there is a link to "Modify the package configuration...". That page has fields to change the default and maxiumum number of values displayed.

    I should point out that this setting will need to be updated every time the Package is republished, a fact that Cognos should fix as a bug....

    Opher
    OpherB, I did the following:
    1. In Cognos Connection I have clicked on More button at package.
    2. Clicked on link "Modify the package configuration".
    3. Changed setting "Maximum member limit in a data three level" from 50 to 1000.
    4. Clicked on OK button to save setting.

    Then I have republished package with Framework Manager, just to test if the settings is overwritten and I have found out that this settings is PRESERVED in my case.

    So just wondering which version of Cognos BI are you using? In my case it is Cognos BI v8.4.1 and in yours?

    Thanks for help.
  • OpherB
    OpherB
    664 Posts

    Re: How to display more then 50 members in hiearchy in Report Studio?

    ‏2011-05-19T19:13:26Z  
    • igorM
    • ‏2011-05-19T07:32:25Z
    OpherB, I did the following:
    1. In Cognos Connection I have clicked on More button at package.
    2. Clicked on link "Modify the package configuration".
    3. Changed setting "Maximum member limit in a data three level" from 50 to 1000.
    4. Clicked on OK button to save setting.

    Then I have republished package with Framework Manager, just to test if the settings is overwritten and I have found out that this settings is PRESERVED in my case.

    So just wondering which version of Cognos BI are you using? In my case it is Cognos BI v8.4.1 and in yours?

    Thanks for help.
    Currently using v8.3.
  • nvf
    nvf
    2 Posts

    Re: How to display more then 50 members in hiearchy in Report Studio?

    ‏2013-03-08T12:33:01Z  
    • igorM
    • ‏2011-05-19T07:32:25Z
    OpherB, I did the following:
    1. In Cognos Connection I have clicked on More button at package.
    2. Clicked on link "Modify the package configuration".
    3. Changed setting "Maximum member limit in a data three level" from 50 to 1000.
    4. Clicked on OK button to save setting.

    Then I have republished package with Framework Manager, just to test if the settings is overwritten and I have found out that this settings is PRESERVED in my case.

    So just wondering which version of Cognos BI are you using? In my case it is Cognos BI v8.4.1 and in yours?

    Thanks for help.
    Thanks igorM, your solution helped on Cognos 10.1!