Topic
No replies
KEM7_Derek_Fabb
KEM7_Derek_Fabb
1 Post
ACCEPTED ANSWER

Pinned topic Optim Database Administrator 2.2.3.0 fails to open workspace

‏2011-05-17T10:41:17Z |
I've got a problem where the database administrator tool will not open my existing workspace.

This is running on XP with SP3.

The error log contains the following:

eclipse.buildId=unknown
java.fullversion=JRE 1.6.0 IBM J9 2.4 Windows XP x86-32 jvmwi3260sr7-20091214_49398 (JIT enabled, AOT enabled)
J9VM - 20091214_049398
JIT - r9_20091123_13891
GC - 20091111_AA
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Framework arguments: -product com.ibm.datastudio.administrator.product.ide
Command-line arguments: -data C:\Documents and Settings\ddfabb\IBM\rationalsdp\workspace -os win32 -ws win32 -arch x86 -product com.ibm.datastudio.administrator.product.ide

!ENTRY org.eclipse.core.resources 2 10035 2011-05-17 11:24:20.650
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.eclipse.osgi 4 0 2011-05-17 11:24:29.030
!MESSAGE Application error
!STACK 1
java.lang.StackOverflowError
at org.eclipse.ui.part.MultiPageEditorPart.getEditor(Unknown Source)
at org.eclipse.ui.part.MultiPageEditorPart.getActiveEditor(Unknown Source)
at org.eclipse.ui.forms.editor.FormEditor.getActiveEditor(Unknown Source)
I can create another workspace and open the tool successfully, but I need to recover the original workspace.

Does anybody have a way out of this?