Topic
  • 2 replies
  • Latest Post - ‏2011-05-25T00:41:05Z by gvalenc
JCanipe
JCanipe
88 Posts

Pinned topic P8 content reference Response: 401: Unauthorized...

‏2011-05-11T18:08:19Z |
Using ICI 8.5.1 FP2,I periodically receive an authentication error when performing a GetNative request to a P8 repository when the content is actually a content reference. I remember a similar issue in IICE 8.4 but a fix was issued that would use the userid/pwd that was passed to the P8 connector during logon to be used in the Authentication/challenge to retrieve the content from the associated URL. If I obtain the associated error message http value, I can use the userid/pwd that was used to logon to the P8 connector and successfully receive the content (in other words, drop the returned http from the error message in a browser.)
Here is an example of the error:
COEN0151E: An error occurred while retrieving native content {008457AB-D00D-4D20-B60C-9D82F180B9F9} version 1 from the repository. : Response: '401: Unauthorized' for url: 'http://rvdrza3s00.wellsfargo.com:9185/AdminUpdate/showPdfFWGDocs.do?Id={9E6057C4-F7BC-45C2-AD66-3B29FAE69134}'

Has this been corrected in ICI 8.5.1 FP2 or does this look to be a P8 security issue?
Updated on 2011-05-25T00:41:05Z at 2011-05-25T00:41:05Z by gvalenc
  • JCanipe
    JCanipe
    88 Posts

    Re: P8 content reference Response: 401: Unauthorized...

    ‏2011-05-14T21:40:54Z  
    Due to the plethora of replies, let me ask this question another way. When ICI8.5.1 P8 connector retrieves content that was defined as a content reference (that is : HTTP://the.document...) and this HTTP request causes an HTTP challenge, what userid and password does ICI use to resolve the challenge?
  • gvalenc
    gvalenc
    13 Posts

    Re: P8 content reference Response: 401: Unauthorized...

    ‏2011-05-25T00:41:05Z  
    • JCanipe
    • ‏2011-05-14T21:40:54Z
    Due to the plethora of replies, let me ask this question another way. When ICI8.5.1 P8 connector retrieves content that was defined as a content reference (that is : HTTP://the.document...) and this HTTP request causes an HTTP challenge, what userid and password does ICI use to resolve the challenge?
    Hi Jeff

    Not sure if you're still having this issue, but ICI 8.5.1 FP2 definitely has the authentication fix made in IICE 8.4.x. The connector still uses the username/pass that was used to log on to the connector for the HTTP authentication.

    If your application code is doing the same thing as it was doing with IICE 8.4.x, I suspect the culprit could be either P8 or the JVM. I do recall a situation we encountered where certain JVMs were not using the authenticator.

    Another possibility is that your application code is accessing the connector instance with a different thread, in which case the HTTP authenticator would not have the same credentials. But again, if your application code hasn't changed, this isn't likely.

    If none of these possibilities prove fruitful, I think getting IBM Software Support involved is in order.

    Hope this helps!

    Gabriel