• No replies
5 Posts

Pinned topic WSRR query failure

‏2011-04-28T15:11:48Z |
I have recently followed the instructions in the RedPaper "Integrating WebSphere Service Registry and Repository with WebSphere DataPower. For DataPower to access the information on WSRR it uses REST and passes a query string.
Because I was having problems I took this query string and cut it down to bare essentials and ran it via a browser. It doesn't fail but brings back nothing. I do the same query in the WSRR UI and get results back.

What I'm putting into my browser...


...where "<.My.WSRR.IP.>" is my WSRR IP address.

I do what I think is the same query (ie: serach on the namespace) within WSRR UI and get 96 entries returned.

I've tried different "p1" values (eg: Name, Version, version, etc.) but I just get an empty response XML back. ie:

The original query string from the RedPaper looked like this...,%27

But I had to change the WSRR version from 6.3 to 7.0, changed the namespace and chopped out the additional query arguments. The redPaper version above has the special chars URL encoded (eg: %27).

I've tried my shorter version with both encoded and non-encoded special characters and get the same result. I don't think its to do with security as it seems to be hitting the WSRR OK and I've
sorted the browser with the credentials.

Can anyone see what I'm doing wrong?