Topic
  • 6 replies
  • Latest Post - ‏2011-05-03T15:17:40Z by dysonbags
dysonbags
dysonbags
24 Posts

Pinned topic Error loading bboopcrt

‏2011-04-26T09:15:17Z |
Get an error when I try to bring up the Daemon started task.

Trace: 2011/04/21 15:17:51.249 02 t=BE5A78 c=UNK key=S2 tag= (8401C3E5)
Description: Throw CORBA system except, w/MSG
exception id: CORBA::INTERNAL
minor code: c9c211eb
from filename: ./bbgoorbi.cpp
at line: 997
extended message: BBOO0335E BPX1LOD LOAD OF bboopcrt FAILED RC=81, REASON=53B006C.

I've found bboopcrt in /websphere/v8r0/z9cell/z9dmnode/DeploymentManager/lib but this is a symbolic link to an invalid library. Presumably this is left over from the previous version of WAS 8 that I had in this configuration.

I could change the link to point to the correct library, but I'd like to know why the link is wrong or if I did something wrong during the upgrade.

Cheers
Graham
Updated on 2011-05-03T15:17:40Z at 2011-05-03T15:17:40Z by dysonbags
  • dysonbags
    dysonbags
    24 Posts

    Re: Error loading bboopcrt

    ‏2011-05-03T10:40:39Z  
    Still can't get past this error.

    Cheers
    Graham
  • jmierze
    jmierze
    43 Posts

    Re: Error loading bboopcrt

    ‏2011-05-03T11:55:34Z  
    • dysonbags
    • ‏2011-05-03T10:40:39Z
    Still can't get past this error.

    Cheers
    Graham
    The beta releases of WebSphere Application Server Version 8 don't have full post-installer support; that is, you can't change the WAS product level underneath a configuration and expect the server to run correctly.

    Do you have the same problem if you configure a server at the current level of the code?

    Jeff Mierzejewski
  • dysonbags
    dysonbags
    24 Posts

    Re: Error loading bboopcrt

    ‏2011-05-03T12:56:53Z  
    • jmierze
    • ‏2011-05-03T11:55:34Z
    The beta releases of WebSphere Application Server Version 8 don't have full post-installer support; that is, you can't change the WAS product level underneath a configuration and expect the server to run correctly.

    Do you have the same problem if you configure a server at the current level of the code?

    Jeff Mierzejewski
    Hi Jeff,

    sorry, but I'm not familiar with some of the terms you use.

    I had an environment set up with the original release of WAS 8 beta. A DMGR, AGENT, and two application servers. All worked fine. I've now taken the latest release of the beta, run the IM jobs - all with RC=0. Now when I try to start the DMGR (and hence the DEMN), the DEMN falls over with this error.

    Are you saying that I need to start again from scratch? Delete everything in the ND and start again with zPMT?

    Cheers
    Graham
  • dysonbags
    dysonbags
    24 Posts

    Re: Error loading bboopcrt

    ‏2011-05-03T12:57:27Z  
    • jmierze
    • ‏2011-05-03T11:55:34Z
    The beta releases of WebSphere Application Server Version 8 don't have full post-installer support; that is, you can't change the WAS product level underneath a configuration and expect the server to run correctly.

    Do you have the same problem if you configure a server at the current level of the code?

    Jeff Mierzejewski
    Hi Jeff,

    sorry, but I'm not familiar with some of the terms you use.

    I had an environment set up with the original release of WAS 8 beta. A DMGR, AGENT, and two application servers. All worked fine. I've now taken the latest release of the beta, run the IM jobs - all with RC=0. Now when I try to start the DMGR (and hence the DEMN), the DEMN falls over with this error.

    Are you saying that I need to start again from scratch? Delete everything in the ND and start again with zPMT?

    Cheers
    Graham
  • jmierze
    jmierze
    43 Posts

    Re: Error loading bboopcrt

    ‏2011-05-03T13:30:07Z  
    • dysonbags
    • ‏2011-05-03T12:57:27Z
    Hi Jeff,

    sorry, but I'm not familiar with some of the terms you use.

    I had an environment set up with the original release of WAS 8 beta. A DMGR, AGENT, and two application servers. All worked fine. I've now taken the latest release of the beta, run the IM jobs - all with RC=0. Now when I try to start the DMGR (and hence the DEMN), the DEMN falls over with this error.

    Are you saying that I need to start again from scratch? Delete everything in the ND and start again with zPMT?

    Cheers
    Graham
    Yes, you have to start from scratch.

    Between one beta refresh and the next, enough changes are made that you cannot re-use a configuration from a previos beta release with code from a new beta release.

    With the general-release version of the product, the post-installer will make any necessary adjustments when upgrading, say, to a new fix pack level. This capability is not pessent in the beta code.

    Jeff Mierzejewski
    WebSphere Application Server for z/OS Installation and Configuration
    jmierze@us.ibm.com
  • dysonbags
    dysonbags
    24 Posts

    Re: Error loading bboopcrt

    ‏2011-05-03T15:17:40Z  
    • jmierze
    • ‏2011-05-03T13:30:07Z
    Yes, you have to start from scratch.

    Between one beta refresh and the next, enough changes are made that you cannot re-use a configuration from a previos beta release with code from a new beta release.

    With the general-release version of the product, the post-installer will make any necessary adjustments when upgrading, say, to a new fix pack level. This capability is not pessent in the beta code.

    Jeff Mierzejewski
    WebSphere Application Server for z/OS Installation and Configuration
    jmierze@us.ibm.com
    Hi Jeff,

    Yes, that works. I've redone the migration and the DMGR and the DEMN now start.

    Thanks for your help.

    Cheers
    Graham