Topic
2 replies Latest Post - ‏2011-04-15T05:28:50Z by eBolor
eBolor
eBolor
24 Posts
ACCEPTED ANSWER

Pinned topic Monitored Directory doesn't install application using property file

‏2011-04-12T08:31:34Z |
Hello,

I am testing the Monitored Directory feature, "Installing enterprise application files by adding them to a monitored directory". However application was not installed.

I followed these steps.

1. Set the Monitored Directory ON by using default directory.
C:\Program Files\IBM\WAS80Beta\AppServer\profiles\Dmgr01\monitoredDeployableApps
2. Restarted DM, Nodeagent, Cluster
3. Prepared property file to install application to cluster.

  1. Header
ResourceType=Application
ImplementingResourceType=Application
CreateDeleteCommandProperties=true
ResourceId=Deployment=

  1. Properties
Name=PerfUtil

TargetCluster=!{clusterName}
EarFileLocation=C:/work/Application/PerfUtil/PerfUtilEAR.ear

#
EnvironmentVariablesSection
#
#Environment Variables
clusterName=Cluster1

4. Copied property file to
C:\Program Files\IBM\WAS80Beta\AppServer\profiles\Dmgr01\monitoredDeployableApps\deploymentProperties

Then nothing happens after step 4.

5. When I use wsadmin using the same properties file to install the application, it works fine. The commands I am using.
AdminTask.applyConfigProperties()
AdminConfig.save()

6. When I try to delete property file in deploymentProperties, a Windows error message shows, saying the file cannot be deleted because it is being used by another user or program.

Does anyone know what the problem is here. Am I missing a step or doing something wrong?

Thank you in advance.
Updated on 2011-04-15T05:28:50Z at 2011-04-15T05:28:50Z by eBolor
  • eBolor
    eBolor
    24 Posts
    ACCEPTED ANSWER

    Re: Monitored Directory doesn't install application using property file

    ‏2011-04-12T08:33:28Z  in response to eBolor
    the wsadmin command I am using is

    AdminTask.applyConfigProperties()
    AdminConfig.save()
    • eBolor
      eBolor
      24 Posts
      ACCEPTED ANSWER

      Re: Monitored Directory doesn't install application using property file

      ‏2011-04-15T05:28:50Z  in response to eBolor
      Does anyone have information/advice regarding this?

      Is there a log file that records what's going on with Monitored Directory? I read it copies the file to a temporary place, where can I check if WAS noticed a file was added, and is executing the command or not?
      I checked wsadmin.traceout, and there was no change since I added property file to monitored directory.