Topic
  • 2 replies
  • Latest Post - ‏2011-04-08T11:04:08Z by SystemAdmin
SystemAdmin
SystemAdmin
704 Posts

Pinned topic IBM 32-bit HLLAPI - pcsws.exe hangs when used by multiple processes

‏2011-03-31T07:37:20Z |
Hello everyone,

We have a typical scenario of pcsws.exe (IBM Personal Communication emulator application) becoming unresponsive when multiple processes try to access IBM Personal Communication tool using HLLAPI.

We have specified proper sharing modes as per HLLAPI documentation - Process 1 is using SUPER_WRITE and process 2 has WRITE_SUPER option. Process 1 periodically uses "SEARCHPS" option in the HLLAPI call to know if the emulator session is actually running and scans for some specified text. However, at certain point of time, it is seen that HLLAPI call returns WHLLSYSERROR (9) - (A system error was encountered). At this point of time, pcsws.exe becomes unresponsive and subsequent calls to HLLAPI hangs from both Process 1 and Process 2. If pcsws.exe is terminated manually, then Process 1 and Process 2 continues execution and terminates accordingly.

Please let us know the possible causes and if there is any way to enable more logging for IBM Personal Communication emulator application other than the default - pcsmmerr.log. This log contains the following information -
" Module PCSHLAPI.C called GlobalUnlockShr at Line Number 1355 with HANDLE 017000B5.
This Memory has already been Freed by Module PCSWAINI.C at Line Number 2390 from pcsws.exe."

Any suggestion/ help is very much appreciated.

Thanks,
Subhro
Updated on 2011-04-08T11:04:08Z at 2011-04-08T11:04:08Z by SystemAdmin
  • jtoma
    jtoma
    757 Posts

    Re: IBM 32-bit HLLAPI - pcsws.exe hangs when used by multiple processes

    ‏2011-04-02T02:14:41Z  
    Hi Subhro,

    This is actually a forum for TAM E-SSO (single sign on). Is your problem with IBM PCOMM related to the TAM E-SSO product?

    Regards,
  • SystemAdmin
    SystemAdmin
    704 Posts

    Re: IBM 32-bit HLLAPI - pcsws.exe hangs when used by multiple processes

    ‏2011-04-08T11:04:08Z  
    • jtoma
    • ‏2011-04-02T02:14:41Z
    Hi Subhro,

    This is actually a forum for TAM E-SSO (single sign on). Is your problem with IBM PCOMM related to the TAM E-SSO product?

    Regards,
    No, this is not related to TAM E-SSO product. As I have mentioned, this is a specific scenario of sharing IBM terminal emulator session using HLLAPI between two processes.

    If this is not the right forum for this question, please let me know where I can post this query to get it answered.

    Thanks,
    Subhro