Topic
  • 2 replies
  • Latest Post - ‏2011-04-01T09:31:57Z by SystemAdmin
SystemAdmin
SystemAdmin
102 Posts

Pinned topic Support for Rational Software Architect v8.0.2

‏2011-03-29T10:10:17Z |
Hi

Should I be able to install the toolkit on Rational Software Architect v8.0.2?

I am currently getting the following error:
Cannot complete the install because of a conflicting dependency.
Software being installed: Application Migration Tool - OracleAS to WebSphere 2.1.0.201012020932 (com.ibm.ws.appconversion_feature.oracle.feature.group 2.1.0.201012020932)
Software currently installed: Shared profile 1.0.0.1301390743255 (SharedProfile_bootProfile 1.0.0.1301390743255)
Only one of the following can be installed at once:
Analysis History Data Source ODA Runtime Driver 7.0.100.v20100517_2203 (com.ibm.rsar.analysis.reporting.oda 7.0.100.v20100517_2203)
Analysis History Data Source ODA Runtime Driver 7.0.100.201012020932 (com.ibm.rsar.analysis.reporting.oda 7.0.100.201012020932)
Cannot satisfy dependency:
From: Shared profile 1.0.0.1301390743255 (SharedProfile_bootProfile 1.0.0.1301390743255)
To: com.ibm.rsar.analysis.reporting.oda http://7.0.100.v20100517_2203
Cannot satisfy dependency:
From: Application Migration Tool - Common Feature 2.1.0.201012020932 (com.ibm.ws.appconversion_feature.common.feature.group 2.1.0.201012020932)
To: com.ibm.rsar.analysis.reporting.oda http://7.0.100.201012020932
Cannot satisfy dependency:
From: Application Migration Tool - OracleAS to WebSphere 2.1.0.201012020932 (com.ibm.ws.appconversion_feature.oracle.feature.group 2.1.0.201012020932)
To: com.ibm.ws.appconversion_feature.common.feature.group 2.1.0

Any pointers to get this working?

Many thanks
Jonathan
Updated on 2011-04-01T09:31:57Z at 2011-04-01T09:31:57Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    102 Posts

    Re: Support for Rational Software Architect v8.0.2

    ‏2011-03-29T19:28:26Z  
    Hi, The toolkit is supported on Eclipse version 3.4.2 or higher and Rational Application Developer version 7.5 and higher. We have not tested the toolkit on Rational Software Architect.
  • SystemAdmin
    SystemAdmin
    102 Posts

    Re: Support for Rational Software Architect v8.0.2

    ‏2011-04-01T09:31:57Z  
    Hi, The toolkit is supported on Eclipse version 3.4.2 or higher and Rational Application Developer version 7.5 and higher. We have not tested the toolkit on Rational Software Architect.
    Hi Dana

    I tried instead with a new install of RAD v8.0.2 on Ubuntu.. I got the same issue, so removed the whole 'code analysis' section from my RAD install and then the toolkit installed correctly. It seems there is a clash of dependencies.

    Anyway it works now, so thanks for your help

    Jonathan