Topic
5 replies Latest Post - ‏2011-04-18T08:09:48Z by arsadler
arsadler
arsadler
10 Posts
ACCEPTED ANSWER

Pinned topic Problems installing HTI with WAS 6.1 ND on Windows

‏2011-03-28T15:41:54Z |
I have followed the steps in the install guid so far, but get the following error:


S:\IBM\WebSphere\HTI>s:\ibm\WebSphere\Profiles\AppSrv01\bin\wsadmin.bat -lang jython -f jython\install.jy nbenoa253Node01 MIDDLEMAN_01 WASX7209I: Connected to process 
"dmgr" on node nbenoa253CellManager01 using SOAP connector;  The type of process is: DeploymentManager *sys-package-mgr*: processing 

new jar, 
'S:\IBM\WebSphere\AppServer\lib\startup.jar'

...
more jars
...

*sys-package-mgr*: processing 

new jar, 
'S:\IBM\WebSphere\AppServer\deploytool\itp\plugins\com.ibm.etools.ejbdeploy\runtime\ejbmapvalidate.jar' WASX7303I: The following options are passed to the scripting environment and are available as arguments that are stored in the argv variable: 
"[nbenoa 253Node01, MIDDLEMAN_01]
" -------------------------------------------------------------------- Installing the Hung Thread Interrupter... nodeName:       nbenoa253Node01 serverName:     MIDDLEMAN_01 installDir:     S:/IBM/WebSphere/HTI -------------------------------------------------------------------- Setting genericJvmArguments of (cells/nbenoa253Cell01/nodes/nbenoa253Node01/servers/MIDDLEMAN_01|server.xml#JavaVirtualMachine_1290505050833) to -Duse r.language=en -Djava.awt.headless=

true -javaagent:S:/IBM/WebSphere/HTI/jars/agent.jar=-installDir=S:/IBM/WebSphere/HTI... Adding S:/IBM/WebSphere/HTI/jars/runtime.jar to bootClasspath... Creating a 

new CustomService... Creating a 

new MBeanProvider... Setting classpath to S:/IBM/WebSphere/HTI/jars/service.jar Creating a 

new extension MBean... Installing a console module... Failed to get environment, environ will be empty: (0, 
"Failed to execute command (['sh', '-c', 'env']): java.io.IOException: CreateProcess: sh -c env error=2
") WASX7017E: Exception received 

while running file 
"jython\install.jy"; exception information: com.ibm.bsf.BSFException: exception from Jython: Traceback (innermost last): File 
"<string>", line 163, in ? File 
"S:\IBM\WebSphere\AppServer\optionalLibraries\jython\Lib\javaos.py", line 137, in __getitem__ File 
"S:\IBM\WebSphere\AppServer\optionalLibraries\jython\Lib\UserDict.py", line 14, in __getitem__ KeyError: WAS_HOME   WASX7341W: No 
"save" was performed before the interactive scripting session exited; configuration changes will not be saved.

Any ideas ???
Updated on 2011-04-18T08:09:48Z at 2011-04-18T08:09:48Z by arsadler
  • arsadler
    arsadler
    10 Posts
    ACCEPTED ANSWER

    Re: Problems installing HTI with WAS 6.1 ND on Windows

    ‏2011-03-29T07:50:40Z  in response to arsadler
    Patching the HTI\jython\install.jy with:
    
    #wasHome = string.replace(os.environ[
    "WAS_HOME"], 
    "\\", "/
    ") wasHome       = string.replace(
    "S:\IBM\WebSphere\AppServer", 
    "\\", "/
    ")
    

    let me install the product, but WAS_HOME is set for sure in the windows environment variables !!
  • arsadler
    arsadler
    10 Posts
    ACCEPTED ANSWER

    Re: Problems installing HTI with WAS 6.1 ND on Windows

    ‏2011-03-29T08:48:27Z  in response to arsadler
    Hi Ahmed,

    *yes of course I did and I also found a workaround. The install guide doesn't point to the
    fact that there should be this environment variable set ...*

    I think it could be a problem with 1) the ND installation or 2) the fact that WAS_HOME
    Is only set in the setupCmdLine.bat. But saying that 2) can't be the problem as I have
    tried the install also with explicit set of this variable ...
    • SystemAdmin
      SystemAdmin
      20 Posts
      ACCEPTED ANSWER

      Re: Problems installing HTI with WAS 6.1 ND on Windows

      ‏2011-03-31T10:45:14Z  in response to arsadler
      Hi,

      You can extract hti zip file into WAS_HOME directory then run jython install command can fix thix issue!

      //Ahmed
  • arsadler
    arsadler
    10 Posts
    ACCEPTED ANSWER

    Re: Problems installing HTI with WAS 6.1 ND on Windows

    ‏2011-04-18T08:09:48Z  in response to arsadler
    Hmm, the unzip in a different directory doesn't help either. It's purely not picking up
    
    wasHome = string.replace(os.environ[
    "WAS_HOME"], 
    "\\", "/
    ")