IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
3 replies Latest Post - ‏2013-03-29T11:05:19Z by SystemAdmin
17 Posts

Pinned topic FFQJ0006W: Trouble importing pear. Annotator class not found.

‏2011-03-21T09:23:13Z |

I created a Java UIMA annotator (UIMA example RoomNumberAnnotator) within Eclipse. After exporting and installing the pear file in the local file system
I wanted to import the self-made Java-pear in LanguageWare workbench. Therefore I created a new "custom stage" and linked the TAE file path to the descriptor file
located in the desc folder of my installed pear. The next step I did was to set up the class path. I chose the jar file located in the lib folder of my installed pear.
I did no configuration for the resources data path.

I tested the custom stage annotation (RoomNumberAnnotator) within LanguageWare workbench and it worked. The next step was exporting the LanguageWare annotator for use
with IBM Content Analytics. I created a pear file and wanted to import it into IBM Content Analytics. After importing my text analysis engine I got the following
verification failure:

FFQJ0007W The installation verification failed.
FFQJ0006W The installation verification of failed due to org.apache.uima.resource.ResourceInitializationException:
Annotator class "org.apache.uima.tutorial.ex1.RoomNumberAnnotator" was not found.
(Descriptor: file:/C:/Program Files/IBM/es/esadmin/data/pearsupport/PearId9/desc/custom4.xml).

I'm wondering because I didn't get a verification failure during installation of the pear file after exporting it with exclipse (runpearinstaller.bat).
Also I got no failure within LanguageWare workbench where my annotation worked very well. Only the import to IBM Cognos Content Analytics makes some
trouble and I don't know why?

Can you give me some advise to handle this failure?
I would be very happy for any kind of information that helps me to solve the problem.

Thank you very much!
Updated on 2013-03-29T11:05:19Z at 2013-03-29T11:05:19Z by SystemAdmin
  • bfoyle
    60 Posts

    Re: FFQJ0006W: Trouble importing pear. Annotator class not found.

    ‏2011-04-03T17:39:26Z  in response to andy100
    Did you export the annotator from Languageware Resource Workbench directly to ICA or did you export it to a pear file and then manually deploy it to ICA?
  • andy100
    17 Posts

    Re: FFQJ0006W: Trouble importing pear. Annotator class not found.

    ‏2011-04-06T06:52:46Z  in response to andy100

    I found the solution :-) There were several reason I had trouble importing the pear file.
    After a second test I couldn't load the custom UIMA Java annotator within LanguageWare. Failure: "Annotator class not found".

    I went back to my Eclipse environment and analyzed the source code of my annotator. All seems to be correct. The reason the annotator didn't work within LanguageWare and Content Analytics was to downgrade my Java environment to Java SDK 1.5_x. LanguageWare has some trouble working with custom annotators coded on a Java SDK 1.6._x environment.

    Changing that parameter, my custom annotator works fine within LanguageWare and could successfully exported to Content Analytics (using ICA config file and manual installation).

    • SystemAdmin
      197 Posts

      Re: FFQJ0006W: Trouble importing pear. Annotator class not found.

      ‏2013-03-29T11:05:19Z  in response to andy100
      Hi Andy,
      I am using IBM Cognos Content Analytics v 2.1 in my end of study project. ( I am new using this tool)
      And I have some problems in the exploration text application.

      In fact, my boss want to see something like this demo : on the example of juice and tea type which exist in the firststep folder as xml files.

      I added the facets and the keywords but the tool is not able to do the text mining.
      It is only doing a keyword search.
      So I can't see the Time Series, Facet pairs, facets, trends ...

      Can you help me to activate the text mining ?

      Thanks for your help.