Topic
4 replies Latest Post - ‏2011-03-29T18:45:24Z by SystemAdmin
SystemAdmin
SystemAdmin
462 Posts
ACCEPTED ANSWER

Pinned topic Federating a v6.1 node to a v8 DMgr

‏2011-03-16T19:45:59Z |
I was able to do this with little difficulty in the last beta. I'm having serious difficulty with it in the new March 2011 beta. This will be a somewhat important issue for us.
Attempting to add the v6.1.0.35 node, either from the console or using addNode.sh appears to work just fine up until the nodeagent is started. It fails with an unusual error:

3/16/11 12:27:44:848 PDT 0000000a UserRegistryI E SECJ0331E: The registry implementation file com.ibm.ws.wim.registry.WIMUserRegistry cannot be initialized because of the following exception com.ibm.websphere.wim.exception.WIMApplicationException: CWWIM0006E Initialization of component, ConfigManager, failed: com.ibm.websphere.wim.exception.InitializationException: CWWIM0001E The configuration file '/was/v8/profiles/appsrv6/config/cells/lab/wim/config/wimconfig.xml' is not valid. Root cause is 'Feature 'supportChangeLog' not found. (file:///was/v8/profiles/appsrv6/all.datagraph, 42, 30)'.

Can v6.1 nodes still work with the v8 DMgr?

Attachments

Updated on 2011-03-29T18:45:24Z at 2011-03-29T18:45:24Z by SystemAdmin
  • emilyt
    emilyt
    8 Posts
    ACCEPTED ANSWER

    Re: Federating a v6.1 node to a v8 DMgr

    ‏2011-03-16T22:48:59Z  in response to SystemAdmin
    Downlevel v6.1 nodes should still work with the v8 Dmgr, just as they did in the prior Beta.

    Could you please post the /was/v8/profiles/appsrv6/config/cells/lab/wim/config/wimconfig.xml file?

    Emily Tuczkowski
    WebSphere Security
    • SystemAdmin
      SystemAdmin
      462 Posts
      ACCEPTED ANSWER

      Re: Federating a v6.1 node to a v8 DMgr

      ‏2011-03-17T14:11:15Z  in response to emilyt
      Thanx for the speedy reply! I'm actually listening to today's CEP as I do this.
      File attached...
      • Ranjan_Kumar
        Ranjan_Kumar
        6 Posts
        ACCEPTED ANSWER

        Re: Federating a v6.1 node to a v8 DMgr

        ‏2011-03-17T15:31:27Z  in response to SystemAdmin
        Thank you for the wimconfig.xml.
        We are investigating the issue but in the mean time you can try this workaround:

        Edit the wimconfig.xml (on DMgr) manually and delete this attribute:
        supportChangeLog="none"
        Save the config, synch the nodes and restart.

        I have attached the updated wimconfig.xml for reference. Please let us know if this workaround does not work.

        Thanks and regards,
        Ranjan Kumar.
  • SystemAdmin
    SystemAdmin
    462 Posts
    ACCEPTED ANSWER

    Re: Federating a v6.1 node to a v8 DMgr

    ‏2011-03-29T18:45:24Z  in response to SystemAdmin
    Thanks for the workaround. Looks good now...