Topic
  • 18 replies
  • Latest Post - ‏2016-12-02T13:47:14Z by monnewbie3
SystemAdmin
SystemAdmin
1959 Posts

Pinned topic Login Issue -The user is already authenticated in all available namespaces.

‏2011-03-16T12:28:00Z |
Hi Everyone,
I was wondering if anybody had experienced this issue before?

Few namespaces were created successfuly in Cognos 10 (OS win 2003 server)
The Cognos Webportal worked without any issues.

After creating a new namespace the following error was displayed right away on the webportal:
"AAA-AUT-0013 The user is already authenticated in all available namespaces".

Server, Cognos service restarts didn't help. The newly created namespace was removed from Cognos Configuration Manager but to no avail. The error is still displayed.

Any help would be greatly appreciated!
Updated on 2013-03-22T23:23:21Z at 2013-03-22T23:23:21Z by SystemAdmin
  • yangling
    yangling
    57 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-03-17T00:54:07Z  
    In your Cognos Configuration, did you change the anonymous access for the Cognos Namespace to false?
  • pavan009
    pavan009
    5 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-07T13:19:10Z  
    • yangling
    • ‏2011-03-17T00:54:07Z
    In your Cognos Configuration, did you change the anonymous access for the Cognos Namespace to false?
    yes I was tried on that way also.............
  • Neupane
    Neupane
    126 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-07T17:36:06Z  
    Log off and click on 'Home' icon.
    It may be confused with multiple namespaces if you have created multiple in cognos configuration.

    --
    Suraj Neupane
  • jparkcnx
    jparkcnx
    5 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-21T19:51:04Z  
    Hi,

    I am also having this exact problem. I've added an Active Directory namespace in Cognos 10 (OS windows server 2008), and when I try to open the webportal, I immediately get the error message "AAA-AUT-0013 The user is already authenticated in all available namespaces".

    I've tried the suggestions mentioned here, as well as the suggested solutions for the "CAM-AAA-0135" error code, and nothing has worked.

    Any help would be much appreciated!

    Thanks,

    Jon
  • Neupane
    Neupane
    126 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-21T21:23:06Z  
    • jparkcnx
    • ‏2011-06-21T19:51:04Z
    Hi,

    I am also having this exact problem. I've added an Active Directory namespace in Cognos 10 (OS windows server 2008), and when I try to open the webportal, I immediately get the error message "AAA-AUT-0013 The user is already authenticated in all available namespaces".

    I've tried the suggestions mentioned here, as well as the suggested solutions for the "CAM-AAA-0135" error code, and nothing has worked.

    Any help would be much appreciated!

    Thanks,

    Jon
    Disable 'Anonymous' authentication in IIS and enable 'Windows Authentication'.

    --
    Suraj Neupane
  • jparkcnx
    jparkcnx
    5 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-22T12:52:32Z  
    • Neupane
    • ‏2011-06-21T21:23:06Z
    Disable 'Anonymous' authentication in IIS and enable 'Windows Authentication'.

    --
    Suraj Neupane
    I disabled anonymous authentication in IIS, and enabled Windows Authentication, but that only prompted me for a login as soon as the request hit the server. I was still greeted with the AAA-AUT-013 "The user is already authenticated in all available namespaces" error.
  • Neupane
    Neupane
    126 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-22T14:52:58Z  
    • jparkcnx
    • ‏2011-06-22T12:52:32Z
    I disabled anonymous authentication in IIS, and enabled Windows Authentication, but that only prompted me for a login as soon as the request hit the server. I was still greeted with the AAA-AUT-013 "The user is already authenticated in all available namespaces" error.
    Do you have singlesignonoption and identitymapping configured in Cognos configuration?
    It should not prompt if that's setup and IIS has windows authentication.
    --
    Suraj Neupane
  • jparkcnx
    jparkcnx
    5 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-22T19:26:19Z  
    • Neupane
    • ‏2011-06-22T14:52:58Z
    Do you have singlesignonoption and identitymapping configured in Cognos configuration?
    It should not prompt if that's setup and IIS has windows authentication.
    --
    Suraj Neupane
    I configured singlesingon and identitymapping, and it no longer prompts for credentials, but I'm still getting the AAA-AUT-0013 error as soon as I try to open the webportal.
  • yangling
    yangling
    57 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-28T19:16:06Z  
    • jparkcnx
    • ‏2011-06-22T19:26:19Z
    I configured singlesingon and identitymapping, and it no longer prompts for credentials, but I'm still getting the AAA-AUT-0013 error as soon as I try to open the webportal.
    Did you chech this then?
  • jparkcnx
    jparkcnx
    5 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-06-28T19:30:29Z  
    • yangling
    • ‏2011-06-28T19:16:06Z
    Did you chech this then?
    yes, I've tried changing the service account, and cgi permissions. The error message appears as soon as I try to open the Cognos Connection web portal by navigating to http://<servername>/ibmcognos.
  • jparkcnx
    jparkcnx
    5 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2011-07-04T15:37:35Z  
    • jparkcnx
    • ‏2011-06-28T19:30:29Z
    yes, I've tried changing the service account, and cgi permissions. The error message appears as soon as I try to open the Cognos Connection web portal by navigating to http://<servername>/ibmcognos.
    When I look at the cogserver log file, I see this warning message: "AAA-LPS-0005 Unable to communicate with legacy namespace server, it may have become unavailable. Please try again later." Could this be a cause of the "User is already authenticated in all available namespaces" message that is appearing when I try to navigate to the web portal?

    The namespace that is causing the AAA-LPS-0005 warning is set up as Active Directory, and passes all the tests in the Cognos Configuration.

    Does anyone have any ideas as to what could be causing this? Or how to get around it?

    Thanks.
  • SystemAdmin
    SystemAdmin
    1959 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2012-01-04T15:25:37Z  
    • jparkcnx
    • ‏2011-07-04T15:37:35Z
    When I look at the cogserver log file, I see this warning message: "AAA-LPS-0005 Unable to communicate with legacy namespace server, it may have become unavailable. Please try again later." Could this be a cause of the "User is already authenticated in all available namespaces" message that is appearing when I try to navigate to the web portal?

    The namespace that is causing the AAA-LPS-0005 warning is set up as Active Directory, and passes all the tests in the Cognos Configuration.

    Does anyone have any ideas as to what could be causing this? Or how to get around it?

    Thanks.
    It happens if Authentication source is LDAP and directory server is down. Please check the directory server and restart it and then restart cognos server.
  • esso6919
    esso6919
    1 Post

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2012-06-11T02:16:57Z  
    It happens if Authentication source is LDAP and directory server is down. Please check the directory server and restart it and then restart cognos server.
    I got this error and i change the user that started the service of cognos , the default is "Local System Account", so i changed to "this user".

    restarted the service and everything were ok.
  • MKcogos
    MKcogos
    1 Post

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2012-06-20T15:59:12Z  
    • esso6919
    • ‏2012-06-11T02:16:57Z
    I got this error and i change the user that started the service of cognos , the default is "Local System Account", so i changed to "this user".

    restarted the service and everything were ok.
    can you please tell where you changed the user? in the services or somewhere else? thanks
  • SystemAdmin
    SystemAdmin
    1959 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2013-03-21T03:31:51Z  
    Hi,

    Today morning, even I got the "AAA-AUT-0013 The user is already authenticated in all available namespaces" message.

    All I did was performed a windows update on the Active Directory server (actually a virtual machine) and then restarted the machine. When I open http://servername:port/cognos10, i get the above error message.

    As mentioned in the post, I first disabled Anonymous Authentication in IIS and Enabled Windows Authentication. Tried the url, it worked. I was able to sign in but it was again and again asking for credentials. So, I just went back to IIS and enabled Anonymous Authentication and Disable Windows Authentication..Cognos started to work again..like normal...no problems in login anymore...seems that this is a random error..

    Regards
    Dev
  • SystemAdmin
    SystemAdmin
    1959 Posts

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2013-03-22T23:23:21Z  
    Hi,

    Today morning, even I got the "AAA-AUT-0013 The user is already authenticated in all available namespaces" message.

    All I did was performed a windows update on the Active Directory server (actually a virtual machine) and then restarted the machine. When I open http://servername:port/cognos10, i get the above error message.

    As mentioned in the post, I first disabled Anonymous Authentication in IIS and Enabled Windows Authentication. Tried the url, it worked. I was able to sign in but it was again and again asking for credentials. So, I just went back to IIS and enabled Anonymous Authentication and Disable Windows Authentication..Cognos started to work again..like normal...no problems in login anymore...seems that this is a random error..

    Regards
    Dev
    we received this error this afternoon. we found that the cause was the IIS settings controlling the ISAPI and CGI extensions that can run on the web server. the "IBMCOGNOS-ISAPI" entry had its Restriction set to "Not Allowed". Setting it back to "Allowed" cleared the error.
  • E1XT_Abhishek_Sanghani
    1 Post

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2013-11-11T10:29:50Z  
    • MKcogos
    • ‏2012-06-20T15:59:12Z
    can you please tell where you changed the user? in the services or somewhere else? thanks

    Got this error. After going through this discussion board, went through different options. Realised that the service was running as Local Account. Changed it to use Service Account and the error was gone.

    To MKcognos, run services.msc and locate the Cognos service. Right click and go in Properties. Change the user account used for running service. Once done, save it and close it. Restart the service from Cognos Configuration.

  • monnewbie3
    monnewbie3
    1 Post

    Re: Login Issue -The user is already authenticated in all available namespaces.

    ‏2016-12-02T13:47:14Z  

    I ran into this problem with TCR 3.1 

    The issue was under IBM cognos configuration (tcr_cogconfig.sh):

    Local Config -> Security -> VMMProvider -> Java class Name

    The Java Class name blank for some reason... I repopulated it with the default value "com.ibm.tivoli.reporting.advanced.cognos.auth.VMMProvider", tested the authentication (everything worked), restarted the service via the JazzSM profile and everything was fine.

     

    Cheers,