Topic
  • No replies
mpas
mpas
1 Post

Pinned topic JSP exception, [model] does not accept any expressions

‏2011-03-16T10:53:54Z |
Hi I am using the Websphere Process Server and WebSphere Integration developer. I created a web
module base on a IBM sample. The code ist the same code
from the tutorial an should work according to the tutorial!!! Thee is a JSP
in the ear module has following code:

<%@ page language="java" contentType="text/html; charset=ISO-8859-1"
pageEncoding="ISO-8859-1"%>
<%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>
<%@ taglib uri="http://com.ibm.bpe.jsf/taglib" prefix="bpe"%>
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Insert title here</title>
</head>
<body>
<f:view>
</f:view>
<h:form>
<h:outputText value="Input Message" />
<bpe:form model="#{MyHandler.inputMessage}" readOnly="true" />
<h:outputText value="Output Message" />
<bpe:form model="#{MyHandler.outputMessage}" />
</h:form>
</body>
</html>
Wenn I deploy and call the Start.jsp , I get following error:

JSPG0227E: Exception caught while translating /Start.jsp: /Start.jsp(20,4) --> JSPG0124E:
According to TLD or attribute directive in tag file, attribute
"model" does not accept any expressions. Value of expression is: "{MyHandler.inputMessage}".
I did not defined the "model" and I assume that this belongs to the JSF in IBM JSF JARs .
Maybe somebody see the reason for this error an can help.

Thanks