Topic
  • 12 replies
  • Latest Post - ‏2013-01-22T21:35:58Z by Ranjith_SC
Rob_Strong
Rob_Strong
10 Posts

Pinned topic Performing software update, message Unsatisfied dependency ...

‏2011-02-28T18:07:20Z |
Performing software update for Infosphere Data Architect, I get (many) messages such as the following. How can I resolve this one, for example?

Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation.edit 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.5.0,4.0.0)
Updated on 2013-01-22T21:35:58Z at 2013-01-22T21:35:58Z by Ranjith_SC
  • SystemAdmin
    SystemAdmin
    374 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-02-28T21:58:21Z  
    Hi Rob,

    Can you please state how you perform the software update?

    Thanks,
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-02-28T22:15:48Z  
    Hi Rob,

    Can you please state how you perform the software update?

    Thanks,
    Sure. 1) Launch IDA
    2) pulldown Help/Software Updates
    3) tab Installed Software
    4) button http://Update...
    5) popup Progress Information eventually displays Cannot complete ...
    6) popup Available Updates shows Graphical Modeling Framework Notation (V 1.3.0.v20100113-1121-33 ...
    with (in the Details window) the mentioned Unsatisfied dependency ...
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-02-28T22:17:49Z  
    Sure. 1) Launch IDA
    2) pulldown Help/Software Updates
    3) tab Installed Software
    4) button http://Update...
    5) popup Progress Information eventually displays Cannot complete ...
    6) popup Available Updates shows Graphical Modeling Framework Notation (V 1.3.0.v20100113-1121-33 ...
    with (in the Details window) the mentioned Unsatisfied dependency ...
    Oops ... did not intend for the square brackets to be interpreted by the wiki manager ... sorry for the extraneous fakelinks.
  • SystemAdmin
    SystemAdmin
    374 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T05:04:01Z  
    Oops ... did not intend for the square brackets to be interpreted by the wiki manager ... sorry for the extraneous fakelinks.
    This approach of software updating is not supported with Installation Manager. In case you're not aware of, Installation Manager is the main tool that installs IDA. Every update to IDA needs to go through Installation Manager by click "Update" from the main panel of Installation Manager.

    Which version of IDA do you have installed?

    Thanks,
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T18:18:26Z  
    This approach of software updating is not supported with Installation Manager. In case you're not aware of, Installation Manager is the main tool that installs IDA. Every update to IDA needs to go through Installation Manager by click "Update" from the main panel of Installation Manager.

    Which version of IDA do you have installed?

    Thanks,
    Interesting ... and strange. I had gotten the message that updates were available as a pop-up when opening IDA 7.5.3 ... I went to the Help pulldown to see how to proceed; it did NOT tell me I needed to launch Installation Manager to perform the update.

    I think it should.

    Anyway, the update through Installation Manager completed just fine. Thanks!
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T18:26:53Z  
    Interesting ... and strange. I had gotten the message that updates were available as a pop-up when opening IDA 7.5.3 ... I went to the Help pulldown to see how to proceed; it did NOT tell me I needed to launch Installation Manager to perform the update.

    I think it should.

    Anyway, the update through Installation Manager completed just fine. Thanks!
    More strange: I still get the pop-up stating "Updates are Available", and when I click on it, I get the statement that it STILL is trying to update "Graphical Modeling Framework Notation v1.3.0.v10100113-1121-33-8s733L537517999.

    Perhaps it is this pop-up that is a bug?

    with the following "details"

    Cannot complete the request. See the details.
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation.edit 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.5.0,4.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.5.0,4.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation.edit 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.5.0,3.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.5.0,3.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation.edit 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.5.0,3.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation 1.2.0.v20090521-1925 requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.5.0,3.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.5.0,3.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation 1.2.0.v20090521-1925 requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.5.0,4.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.runtime.notation 1.2.0.v20091021-2333 requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.5.0,4.0.0)
    Cannot find a solution where both "bundle org.eclipse.emf.ecore [2.5.0,3.0.0)" and "bundle org.eclipse.emf.ecore [2.4.0,2.5.0)" are satisfied.
    Cannot find a solution where both "bundle org.eclipse.emf.ecore [2.5.0,3.0.0)" and "bundle org.eclipse.emf.ecore [2.4.0,2.5.0)" are satisfied.
    Unsatisfied dependency: http://org.eclipse.gmf.bridge 1.1.0.v20090212-1755 requiredCapability: osgi.bundle/org.eclipse.gmf.runtime.notation/[1.0.0,2.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.bridge.ui 1.1.100.v20080417-1610 requiredCapability: osgi.bundle/org.eclipse.gmf.bridge/[1.1.0,2.0.0)
    Unsatisfied dependency: http://org.eclipse.gmf.doc.feature.group 1.3.0.v20090729-2029-35-8s733L3H7L1737L requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gmf.doc.ui/http://1.3.0.v20090729-2029,1.3.0.v20090729-2029
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T18:27:50Z  
    Still getting a pop-up that tells me there is an update available ...
  • SystemAdmin
    SystemAdmin
    374 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T21:51:35Z  
    Still getting a pop-up that tells me there is an update available ...
    Seems like the process you started yesterday wasn't killed completely? Just my theory. Is it possible for you to uninstall IDA and reinstall it from scratch, but this time do not attempt any update from the Help menu? I'm going to install IDA 7.5.3 in house to see if I can see that pop-up you're describing when launching IDA. This is the first time I hear anything about such pop-up.

    I do agree with you that it should be communicated to the users not to try the Eclipse software update feature, but everything should go through Installation Manager.

    Thanks,
  • SystemAdmin
    SystemAdmin
    374 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T21:53:38Z  
    Seems like the process you started yesterday wasn't killed completely? Just my theory. Is it possible for you to uninstall IDA and reinstall it from scratch, but this time do not attempt any update from the Help menu? I'm going to install IDA 7.5.3 in house to see if I can see that pop-up you're describing when launching IDA. This is the first time I hear anything about such pop-up.

    I do agree with you that it should be communicated to the users not to try the Eclipse software update feature, but everything should go through Installation Manager.

    Thanks,
    Can you capture a screen shot of the pop-up and attach it?
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T22:34:00Z  
    Can you capture a screen shot of the pop-up and attach it?
    Image of popup is attached.
  • Rob_Strong
    Rob_Strong
    10 Posts

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2011-03-01T22:37:34Z  
    Image of popup is attached.
    Oh! And if I click on the popup, it attempts to install the update and give me the attached popup. Yeah, I think this should be disabled (or else it should work!).
  • Ranjith_SC
    Ranjith_SC
    1 Post

    Re: Performing software update, message Unsatisfied dependency ...

    ‏2013-01-22T21:35:58Z  
    Oh! And if I click on the popup, it attempts to install the update and give me the attached popup. Yeah, I think this should be disabled (or else it should work!).
    Hi Friends, I am facing the same problem. If you have a solution to this issue, please share.