Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2011-03-24T14:31:28Z by Nogu
SystemAdmin
SystemAdmin
462 Posts
ACCEPTED ANSWER

Pinned topic plugin-cfg.xml error when installing application with monitored directory

‏2011-02-24T04:53:51Z |
Summary
When I installed an application with monitored directory,
the plugin-cfg.xml were generated incorrectly.
>>the plugin-cfg.xml was generated incorrectly.

Environment
Box1
AIX 6.1
IHS V8.0 Beta2 ( + IHS Admin Server )
Plug-in V8.0 Beta2

Box2
AIX 6.1
WAS V8.0 Beta2 ( AS Cluster configured)

Procedures
1. Install an application, which use "/(root)" as a Context Root(ex. snoop), with monitored directory.

2. Checked the current Web server plug-in configuration file

Written as follow in the configuration file.

<UriGroup Name="default_host_cluster_URIs">
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/commsvc.rest/*"/>
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/*"/>
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/ApplicationAAA/*"/>
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/*"/>
</UriGroup>

3. Click "Generate Plug-in" from Servers -> Server Types -> Web Servers
to update "Web server plug-in configuration" for web server.

4.Checked the plugin-cfg.xml
* /profile_root/config/cells/CellName/nodes/NodeName/servers/ServerName/plugin-cfg.xml

Written as follow in the plugin-cfg.xml

<UriGroup Name="default_host_cluster_URIs">
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/ApplicationAAA/*"/>
</UriGroup>

No Uri for "/*"

Expected Result
Written as follow , in plugin-cfg.xml,

<UriGroup Name="default_host_cluster_URIs">
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/ApplicationAAA/*"/>
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/*"/>
</UriGroup>

Comments
When I installed the applicaton from administrative console,
Uri for "/" was written.
Thanks.
Updated on 2011-03-24T14:31:28Z at 2011-03-24T14:31:28Z by Nogu
  • Nogu
    Nogu
    9 Posts
    ACCEPTED ANSWER

    Re: plugin-cfg.xml error when installing application with monitored directory

    ‏2011-03-24T14:31:28Z  in response to SystemAdmin
    Hello,

    I am a coworker of Hiro1234's.
    He reported this post, testing with Beta 2.
    Can anybody in Dev. take a look at this problem ?

    Thanks. Nogu.