Topic
2 replies Latest Post - ‏2011-02-22T16:16:51Z by EWC
EWC
EWC
2 Posts
ACCEPTED ANSWER

Pinned topic RHEL6 installation on 9117-MMA (570) LPAR

‏2011-02-21T22:55:10Z |
Have installed RHEL6-ppc on a lpar on a 9117-mma server pSeries system

RHEL6 boots and seems to work ok

Trying to get the GUI (GNOME) to work with Attachmate SSH product

When exec the XCLOCK program, the clock displays, which to me means the Xserver and client are configured correctly

When exec startx to get the GNOME GUI displayed, I get the following

(==) Using default built-in configuration (12 lines)
(EE) open /dev/fb0: No such device
(EE) No devices detected.

Fatal server error:
no screens found

The X Window System and Desktop groups have been installed.

In the /var/log/Xorg.0.log

everything looks good until

(II) LoadModule: "fbdev"
(II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 0.4.2
ABI class: X.Org Video Driver, version 6.0
(II) FBDEV: driver for framebuffer: fbdev
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib64/xorg/modules/linux/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 0.0.2
ABI class: X.Org Video Driver, version 6.0
(EE) open /dev/fb0: No such device
(EE) No devices detected.

Fatal server error:
no screens found
There is a /dev/fb0 file and a link /dev/fb pointing to /dev/fb0

Any ideas?

TKS
Updated on 2011-02-22T16:16:51Z at 2011-02-22T16:16:51Z by EWC
  • klausk
    klausk
    13 Posts
    ACCEPTED ANSWER

    Re: RHEL6 installation on 9117-MMA (570) LPAR

    ‏2011-02-21T23:07:17Z  in response to EWC
    If you are already able to see xclock, that means that there is an X server running somewhere and you are successfully attaching to it.

    Given that, you don't need to start another X server (i.e., you don't need "startx").

    If you'd like to run a full-fledged Window Manager on that same X server you got running, try running "gnome-session" instead.

    If you're already have a Window Manager running, you could start the apps directly (i.e., "gnome-terminal").

    -Klaus
  • EWC
    EWC
    2 Posts
    ACCEPTED ANSWER

    Re: RHEL6 installation on 9117-MMA (570) LPAR

    ‏2011-02-22T16:16:51Z  in response to EWC
    Thanks for the reply.

    I believed that the Xwindows was working correctly, and this reply allowed me to get beyond the point os self-doubt.
    To get the gnome desktop to display, entered the following command from command line

    gnome-session

    The desktop started

    Hope this helps others that are installing RHEL6 on pSeries server