Topic
  • 3 replies
  • Latest Post - ‏2012-05-04T21:55:51Z by SystemAdmin
Jaango
Jaango
267 Posts

Pinned topic Adding two FSH for a service

‏2011-01-28T12:33:10Z |
We have a WSP configured with one FSH for an ip address and port number and it is going to the configured rules
However when I add another FSH for the same service same ip address and another port number, the default request and response rule is invoked and the service fails with the below messages.
wsgw (MYWSP): rule (MYWSP_default_response-rule): implied action validate: 'INPUT wsdl local:///Service/MYServiceWithHeader.wsdl INPUT' failed: http://Ipaddress:port/MYService: empty input document cannot be schema validated
any idea why the default and not the configured rules are getting executed for the new FSH added.
Updated on 2012-05-04T21:55:51Z at 2012-05-04T21:55:51Z by SystemAdmin
  • Jaango
    Jaango
    267 Posts

    Re: Adding two FSH for a service

    ‏2011-01-28T12:48:19Z  
    Whenever I add a new FSH for the same service, i notice that along with ServiceXPort operation, ServiceXPort.0 is also created and requests to the added FSH is going to this port operation
  • SystemAdmin
    SystemAdmin
    6772 Posts

    Re: Adding two FSH for a service

    ‏2012-05-04T17:54:43Z  
    • Jaango
    • ‏2011-01-28T12:48:19Z
    Whenever I add a new FSH for the same service, i notice that along with ServiceXPort operation, ServiceXPort.0 is also created and requests to the added FSH is going to this port operation
    Hi,
    Did you find a root cause for this issue? I appreciate your valuable response.
    Thanx+regards
  • SystemAdmin
    SystemAdmin
    6772 Posts

    Re: Adding two FSH for a service

    ‏2012-05-04T21:55:51Z  
    • Jaango
    • ‏2011-01-28T12:48:19Z
    Whenever I add a new FSH for the same service, i notice that along with ServiceXPort operation, ServiceXPort.0 is also created and requests to the added FSH is going to this port operation
    I think you configured your processing policy at port level. Can you confirm where exactly your first processing rule is configured?