Topic
2 replies Latest Post - ‏2011-02-08T16:30:16Z by SystemAdmin
SystemAdmin
SystemAdmin
23 Posts
ACCEPTED ANSWER

Pinned topic HTTP 500 Internal Server Error, No messages

‏2011-01-20T22:02:35Z |
I am attempting to install CA1S (1.1), on a CICS/TS 3.2 system, z/OS 1.10, Java 5.0 (SR12). I have reviewed most of the postings here, so I'll briefly review the things I have tried ... I have run the sample programs to ensure that Java is installed properly. I have changed the UNIX permissions on all directories/files in and under CA1S to 777 to attempt to eliminate any permission issues. When I try to execute the HelloCICS sample PHP scripts, I just get an HTTP 500 Internal Server Error. I cannot find any associated messages in CICS message logs, nor on the z/OS console log, nor am I finding any log files created in Java log directories. I tried turning on tracing by creating a p8logging.properties file in the cas1/work/classes directory as described in other posts; no trace file is created. CICS is defaulting to 037 on localccsid, so the php.ini has unicode.runtime_encoding set to IBM-037.

I just downloaded Firefox, and I get the following messages that I do not get in IE when I try to run the sample programs:

XML Parsing Error: no element found
Location: http://anpdev:65432/ca1s/hellocics
Line Number 1, Column 1:
^

Similar message received for HelloCICS.php.

Any assistance would be greatly appreciated.

Thanks,
Steve
Updated on 2011-02-08T16:30:16Z at 2011-02-08T16:30:16Z by SystemAdmin
  • JonathanPLawrence
    JonathanPLawrence
    30 Posts
    ACCEPTED ANSWER

    Re: HTTP 500 Internal Server Error, No messages

    ‏2011-01-21T10:40:38Z  in response to SystemAdmin
    Steve,

    The first thing to mention is that the CA1S SupportPac is not supported and you should move to the CICS Transaction Server Feature Pack for Dynamic Scripting (http://www.ibm.com/software/htp/cics/scripting/) as soon as possible. NB this requires CICS Transaction Server v4.1. CICS Dynamic Scripting includes the same PHP technology as the CA1S SupportPac, and is supported as a CICS Feature.

    We are aware of an issue running the CA1S SupportPac on some z/OS v1.10 installations, however this should cause a CEEDUMP with the following message: "CEE3225S The system detected an IEEE invalid operation exception." If you are seeing this problem please report it to the forum.

    Otherwise it seems probable that a configuration problem is the cause. The inbound request may not be reaching the JVM for execution. You can check this by looking for the use count on program CA1SHNDL which should be > 0, and also check whether a CICS JVM has been initialized (CEMT I JVMPOOL).

    The next thing to check would be that you have followed all the steps for configuring your CA1S installation correctly, including editing the CA1S resource definitions to match your local installation. I suggest a careful review of all the CA1S installation instructions; please append a further post to the forum if this does not determine the cause. Further information including details of the configuration files will be needed.

    Jonathan Lawrence
    CICS Dynamic Scripting development
    IBM United Kingdom Limited
    • SystemAdmin
      SystemAdmin
      23 Posts
      ACCEPTED ANSWER

      Re: HTTP 500 Internal Server Error, No messages

      ‏2011-02-08T16:30:16Z  in response to JonathanPLawrence
      Thanks for the reply, Jonathan. Yes, it was a configuration issue, kinda/sorta. I found it was a permissions issue, so I pretty much went through the entire CA1S directory and changed everything to 777, and was then able to run the sample HelloCICS script. We'll try to nail down security more when/if we implement a real application; for a POC, we just want to see it work. :)

      Yes, we are aware that the SupportPac is unsupported and that there is a Feature Pack that is supported, but we are still running CICS/TS 3.2, with 4.1 implementation months away, so this is our only option for exploring this exciting capability in CICS without waiting. We were hoping to develop a POC on the SupportPac that would help justify a project once we are on 4.1.

      Thanks again,
      Steve