• No replies
3 Posts

Pinned topic Help in using PDT

‏2011-01-20T11:25:16Z |

I am using Cell Simulator on x86 platform on Fedora 14.
I want to experiment with PDT.
I verfied that following directories are present in my installation -

PDT development trace includes                 /opt/cell/sysroot/usr/include/trace PDT production trace libraries                 /opt/cell/sysroot/usr/lib/trace PDT production trace 64 bit libraries          /opt/cell/sysroot/usr/lib64/trace PDT SPU development trace includes             /opt/cell/sysroot/usr/spu/include/trace PDT SPU development trace libraries            /opt/cell/sysroot/usr/spu/lib/trace PDT configuration                              /opt/cell/sysroot/usr/share/pdt/config PDT examples                                   /opt/cell/sdk/src/pdt-cell-examples.tar

Initially I tried to use Eclipse IDE to compile the program simple spu simd as given in IDE Tutorial and User's Guide Chapter 11, IDE PDT Plugin.
I followed the exact steps that are given in this tutorial.
I was able to compile and run the application as mentioned in the tutorial.
But the program runs and terminates throwing an exception saying "no output files generated"

Hence, I tried to run the PDT using the command line.
For this, I am trying to use the PDT examples that are located at -
I could compile the applications without any problems.
However when I run the application it gives me segmentation fault.
Also, I check out that in my simulator, there is no directory called as
/usr/lib/modules. Also I did not find any pdt.ko anywhere.

Can anyone please help me with this problem?

Thank You,