IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 5 replies
  • Latest Post - ‏2012-03-16T20:17:18Z by SKATKIN
lple2003
lple2003
3 Posts

Pinned topic rhel6 install error: No filesystem could mount root, tried: iso9660

‏2011-01-10T23:44:52Z |
I tried to install rhel6 (RHEL6.0-20100922.1-Server-ppc64-DVD1.iso, fromt ftp3)
On a P7 (model 780) partition with virtual drive and boot from the virtual cd, got error:

No filesystem could mount root, tried: iso9660
Full screen is:

registered taskstats version 1
rtc-generic rtc-generic: setting system clock to 2011-01-10 23:05:44 UTC (129470
0744)
Initalizing network drop monitor service
md: Waiting for all devices to be available before autodetect
md: If you don't use raid, use raid=noautodetect
md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
RAMDISK: gzip image found at block 0
RAMDISK: EOF while reading compressed data
uncompression error
List of all partitions:
No filesystem could mount root, tried: iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
Call Trace:
c0000003fcbe3c30 c000000000012d84 .show_stack+0x74/0x1c0 (unreliable)
c0000003fcbe3ce0 c000000000582b50 .panic+0x80/0x1a8
c0000003fcbe3d70 c0000000007f14c8 .mount_block_root+0x2e8/0x324
c0000003fcbe3e50 c0000000007f1750 .prepare_namespace+0x1c4/0x218
c0000003fcbe3ee0 c0000000007f0520 .kernel_init+0x2f4/0x320
c0000003fcbe3f90 c000000000031b14 .kernel_thread+0x54/0x70
Rebooting in 180 seconds..
Does it mean the iso image is no good, I downloaded it several times, same problem.
Bad dvd image from ftp3 ? Any idea ?
Updated on 2012-03-16T20:17:18Z at 2012-03-16T20:17:18Z by SKATKIN
  • AntonBlanchard
    AntonBlanchard
    4 Posts

    Re: rhel6 install error: No filesystem could mount root, tried: iso9660

    ‏2011-01-11T00:07:33Z  
    Sounds like the NVRAM settings were altered by AIX. Try clearing the NVRAM:

    http://www.ibm.com/developerworks/wikis/display/LinuxP/Claim+failed+for+initrd+error+with+SUSE

    Anton
  • lple2003
    lple2003
    3 Posts

    Re: rhel6 install error: No filesystem could mount root, tried: iso9660

    ‏2011-01-11T22:09:04Z  
    Sounds like the NVRAM settings were altered by AIX. Try clearing the NVRAM:

    http://www.ibm.com/developerworks/wikis/display/LinuxP/Claim+failed+for+initrd+error+with+SUSE

    Anton
    That works, thanks Anton, we have power 7 that we build, rebuild and re-rebuild partitions all the time, between ios, aix, LoP and such... but never got that problem til now, hope there's no more "gotcha" :-)
  • mehari
    mehari
    1 Post

    Re: rhel6 install error: No filesystem could mount root, tried: iso9660

    ‏2011-01-13T10:17:31Z  
    • lple2003
    • ‏2011-01-11T22:09:04Z
    That works, thanks Anton, we have power 7 that we build, rebuild and re-rebuild partitions all the time, between ios, aix, LoP and such... but never got that problem til now, hope there's no more "gotcha" :-)
    bonjour,
    I have the same problem when trying to install RedHat 6 ppc64 on a PS701 Power7 Blade ... I have the following error :
    ==========================================================================
    Initalizing network drop monitor service
    md: Waiting for all devices to be available before autodetect
    md: If you don't use raid, use raid=noautodetect
    md: Autodetecting RAID arrays.
    md: Scanned 0 and added 0 devices.
    md: autorun ...
    md: ... autorun DONE.
    RAMDISK: gzip image found at block 0
    RAMDISK: EOF while reading compressed data
    uncompression error
    List of all partitions:
    No filesystem could mount root, tried: iso9660
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
    Call Trace:
    c0000007b124fc30 c000000000012d84 .show_stack+0x74/0x1c0 (unreliable)
    c0000007b124fce0 c000000000582b50 .panic+0x80/0x1a8
    c0000007b124fd70 c0000000007f14c8 .mount_block_root+0x2e8/0x324
    c0000007b124fe50 c0000000007f1750 .prepare_namespace+0x1c4/0x218
    c0000007b124fee0 c0000000007f0520 .kernel_init+0x2f4/0x320
    c0000007b124ff90 c000000000031b14 .kernel_thread+0x54/0x70
    Rebooting in 180 seconds..
    ==================================================================

    I have seen your post : could you please explain me what you have done to perform / complete your RedHat 6 installation ?
    Thanks for your help.
    Regards.
    Patrick
  • lple2003
    lple2003
    3 Posts

    Re: rhel6 install error: No filesystem could mount root, tried: iso9660

    ‏2011-01-13T17:50:53Z  
    • mehari
    • ‏2011-01-13T10:17:31Z
    bonjour,
    I have the same problem when trying to install RedHat 6 ppc64 on a PS701 Power7 Blade ... I have the following error :
    ==========================================================================
    Initalizing network drop monitor service
    md: Waiting for all devices to be available before autodetect
    md: If you don't use raid, use raid=noautodetect
    md: Autodetecting RAID arrays.
    md: Scanned 0 and added 0 devices.
    md: autorun ...
    md: ... autorun DONE.
    RAMDISK: gzip image found at block 0
    RAMDISK: EOF while reading compressed data
    uncompression error
    List of all partitions:
    No filesystem could mount root, tried: iso9660
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
    Call Trace:
    c0000007b124fc30 c000000000012d84 .show_stack+0x74/0x1c0 (unreliable)
    c0000007b124fce0 c000000000582b50 .panic+0x80/0x1a8
    c0000007b124fd70 c0000000007f14c8 .mount_block_root+0x2e8/0x324
    c0000007b124fe50 c0000000007f1750 .prepare_namespace+0x1c4/0x218
    c0000007b124fee0 c0000000007f0520 .kernel_init+0x2f4/0x320
    c0000007b124ff90 c000000000031b14 .kernel_thread+0x54/0x70
    Rebooting in 180 seconds..
    ==================================================================

    I have seen your post : could you please explain me what you have done to perform / complete your RedHat 6 installation ?
    Thanks for your help.
    Regards.
    Patrick
    Hi

    When yur system comes up to SMS, type "8" to get to the firmware prompt >

    From there you can enter the 2 commands: "dev nvram" and "wipe-nvram"

    Then the system will automaticaly reboot to clear the nvram
  • SKATKIN
    SKATKIN
    1 Post

    Re: rhel6 install error: No filesystem could mount root, tried: iso9660

    ‏2012-03-16T20:17:18Z  
    • lple2003
    • ‏2011-01-13T17:50:53Z
    Hi

    When yur system comes up to SMS, type "8" to get to the firmware prompt >

    From there you can enter the 2 commands: "dev nvram" and "wipe-nvram"

    Then the system will automaticaly reboot to clear the nvram
    I'm getting this exact same error trying to install RHEL6.2 as a z/Linux guest machine under z/VM 6.2 on an IBM z10 mainframe. Anyone have any ideas for me? I've eliminated the possibility of a corrupt initrd image and clearing NVRAM isn't valid in my case...
    TIA