Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
8 replies Latest Post - ‏2012-09-14T11:29:09Z by HariBabuNunna
SystemAdmin
SystemAdmin
2233 Posts
ACCEPTED ANSWER

Pinned topic Publishing to IBM WASCE V2.1 server at localhost

‏2011-01-04T10:58:22Z |
We are using Eclipse,DB2,WASCE to develop our project.For that we installed WEP,while running a small sample of jsp we are getting following errors.We are unable to run the program.Please help me to resolve this problem.

Publishing to IBM WASCE V2.1 server at localhost has encountered problem.
Distribution of module failed.
See log for details.
Error unmarshaling return; nested exception is:
java.net.MalformedURLException: no protocol: Files/IBM/WebSphere/AppServerCommunityEdition/repository/org/apache/geronimo/modules/geronimo-common/2.0.1/geronimo-common-2.0.1.jar
java.rmi.UnmarshalException: Error unmarshaling return; nested exception is:
java.net.MalformedURLException: no protocol: Files/IBM/WebSphere/AppServerCommunityEdition/repository/org/apache/geronimo/modules/geronimo-common/2.0.1/geronimo-common-2.0.1.jar
at sun.rmi.transport.StreamRemoteCall.executeCall(Unknown Source)
at sun.rmi.server.UnicastRef.invoke(Unknown Source)
at com.sun.jmx.remote.internal.PRef.invoke(Unknown Source)
at javax.management.remote.rmi.RMIConnectionImpl_Stub.invoke(Unknown Source)
at javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.invoke(Unknown Source)
at org.apache.geronimo.system.jmx.KernelDelegate.invokeKernel(KernelDelegate.java:889)
at org.apache.geronimo.system.jmx.KernelDelegate.invoke(KernelDelegate.java:550)
at org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.doDeploy(AbstractDeployCommand.java:116)
at org.apache.geronimo.deployment.plugin.local.DistributeCommand.run(DistributeCommand.java:61)
at java.lang.Thread.run(Unknown Source)
Caused by: java.net.MalformedURLException: no protocol: Files/IBM/WebSphere/AppServerCommunityEdition/repository/org/apache/geronimo/modules/geronimo-common/2.0.1/geronimo-common-2.0.1.jar
at java.net.URL.<init>(Unknown Source)
at java.net.URL.<init>(Unknown Source)
at java.net.URL.<init>(Unknown Source)
at sun.rmi.server.LoaderHandler.pathToURLs(Unknown Source)
at sun.rmi.server.LoaderHandler.loadClass(Unknown Source)
at java.rmi.server.RMIClassLoader$2.loadClass(Unknown Source)
at java.rmi.server.RMIClassLoader.loadClass(Unknown Source)
at sun.rmi.server.MarshalInputStream.resolveClass(Unknown Source) etc............

Please helpl me.....
Updated on 2012-09-14T11:29:09Z at 2012-09-14T11:29:09Z by HariBabuNunna
  • Shawn_Jiang
    Shawn_Jiang
    154 Posts
    ACCEPTED ANSWER

    Re: Publishing to IBM WASCE V2.1 server at localhost

    ‏2011-01-04T12:31:03Z  in response to SystemAdmin
    Seems it's caused by installing CE in path "C:\program files\xxxx" that contains a space. You could try to install CE on a path without space.

    BTW, what's the CE version you are using ?
    • ShashiVishwakarma
      ShashiVishwakarma
      3 Posts
      ACCEPTED ANSWER

      Re: Publishing to IBM WASCE V2.1 server at localhost

      ‏2011-01-04T13:19:04Z  in response to Shawn_Jiang
      I have installed wasce v2.0 for windows.
      and i have installed WEP v2.1
      sorry i did not understand that what do u mean by 'install CE on a path without space'.
    • ShashiVishwakarma
      ShashiVishwakarma
      3 Posts
      ACCEPTED ANSWER

      Re: Publishing to IBM WASCE V2.1 server at localhost

      ‏2011-01-04T13:21:16Z  in response to Shawn_Jiang
      I have installed wasce v2.0 for windows.
      and i have installed WEP v2.1
      sorry i did not understand that what do u mean by 'install CE on a path without space'.

      please explain in detail... i am newbie about this software.
      • Kevan
        Kevan
        121 Posts
        ACCEPTED ANSWER

        Re: Publishing to IBM WASCE V2.1 server at localhost

        ‏2011-01-04T17:15:36Z  in response to ShashiVishwakarma
        You currently have WAS CE installed in "c:\Program Files\IBM\WebSphere". By "path without a space", Shawn means "Program Files". Installing WAS CE in an alternate location should fix your problem.

        WAS CE 2.0 is pretty old. I would suggest you use the latest version of WAS CE 2.1.

        --kevan
        • SystemAdmin
          SystemAdmin
          2233 Posts
          ACCEPTED ANSWER

          Re: Publishing to IBM WASCE V2.1 server at localhost

          ‏2011-01-08T05:09:13Z  in response to Kevan
          Hello Kevan,
          My publishing problem is solve,according to your answer.Thank you !
          Now i have new problem can you help me in that............

          This is post i had put in WASCE forums.

          http://www.ibm.com/developerworks/forums/thread.jspa?threadID=357125&tstart=0

          Please Help me.
    • saps
      saps
      1 Post
      ACCEPTED ANSWER

      Re: Publishing to IBM WASCE V2.1 server at localhost

      ‏2011-06-23T07:35:32Z  in response to Shawn_Jiang
      Hi,
      I am facing the same problem "distribution of modules failed".
      I tried installing WASCE 2.1 at an alternate location (a path without spaces) but didn't helped at all.
      Plz reply.
      Regards,
      Mohit Sapra
      • Kevan
        Kevan
        121 Posts
        ACCEPTED ANSWER

        Re: Publishing to IBM WASCE V2.1 server at localhost

        ‏2011-06-23T13:43:46Z  in response to saps
        In order for us to help you, you'll need to post precise details (WAS CE version, installation location, operating system) of your installation and your failure stacktrace.

        --kevan
        • HariBabuNunna
          HariBabuNunna
          1 Post
          ACCEPTED ANSWER

          Re: Publishing to IBM WASCE V2.1 server at localhost

          ‏2012-09-14T11:29:09Z  in response to Kevan
          Hi,
          Are there any docs to refer for building and deploying Webservices using CXF and WASCE2.1.6 server. I am using WASCE 2.1.6. Windows env and CXF 2.5.2.