Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2011-01-22T20:44:34Z by SystemAdmin
mousey
mousey
1 Post
ACCEPTED ANSWER

Pinned topic llconfig -i command fails

‏2010-12-13T14:49:21Z |
Hi all,
I'm trying to run llconfig -i to import the confguration file into XCAT so I can test the LLAPI related functions for DB access on a small standalone box. Unfortunately I'm receiving the following error message :


[root@shivling loadl]# llconfig -i LoadLeveler tables are being created in the xcatdb database. Initializing configuration data in the LoadLeveler tables from the following file or files: /home/loadl/LoadL_config   Continue? (y/n): y 12/13 13:44:17 [MySQL][ODBC 3.51 Driver][mysqld-5.0.45]Cannot add or update a child row: a foreign key constraint fails (`xcatdb/TLL_CFGCluster`, CONSTRAINT `TLL_CFGCluster_ibfk_1` FOREIGN KEY (`clusterID`) REFERENCES `TLL_Cluster` (`clusterID`) ON DELETE CASCADE) (SQL State=HYT00, Native Error Code=1452) 12/13 13:44:17 llconfig: 2544-005 Inserting data into table TLL_CFGCluster was not successful. SQL STATUS=-1. llconfig: A database operation was not successful. llconfig: The database was not initialized.



Software levels ---------------   RHEL5.3 (x86_64) LoadL-4.1.1.1 (x86_64) mysql-server-5.0.45-7.el5 mysql-5.0.45-7.el5 mysql-devel-5.0.45-7.el5 perl-DBD-MySQL-3.0007-2.el5 mysql-connector-odbc-3.51.12-2.2 xCAT-server-2.5.1-snap201012090302


Have tested basic access via isql -v xcatdb as root and loadl user and all is ok, guess I've done something wrong here but I don't see what I've missed at the moment.

Any suggestions gratefully received.
Updated on 2011-01-22T20:44:34Z at 2011-01-22T20:44:34Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    46 Posts
    ACCEPTED ANSWER

    Re: llconfig -i command fails

    ‏2010-12-14T20:31:58Z  in response to mousey
    Hi Mousey,

    If possible, we'd like to see a mysqldump of xcatdb so we can what is in the DB.
    I've sent you a private message with some more details.

    Thanks!
  • SystemAdmin
    SystemAdmin
    46 Posts
    ACCEPTED ANSWER

    Re: llconfig -i command fails

    ‏2011-01-22T20:44:34Z  in response to mousey
    We discovered that there is a problem related to the version of mysql-connector-odbc.

    The default versions that install for RHEL 5.2 and 5.3 (3.51.12) show the problem.
    If you use RHEL 5.2 or 5.3 move up to version 3.51.26 or higher of
    mysql-connector-odbc to eliminate the problem. (There may be other
    levels between 3.51.12 and 3.51.26 that work, but we did not try them all.)

    RHEL 5.4 which has a default version 3.51.27, does not show the problem.

    MySQL has a site, http://downloads.mysql.com/archives.php?p=mysql-connector-odbc-3.51
    that has many versions of myql-connector-odbc(see the Archive link).