Topic
2 replies Latest Post - ‏2010-12-03T15:55:47Z by Antonello_Supino
Antonello_Supino
Antonello_Supino
54 Posts
ACCEPTED ANSWER

Pinned topic Upgrade a ISW 9.7.1 server with DB2 already patched to 9.7.3a to ISW 9.7.2

‏2010-12-02T22:37:26Z |
Hello,
I have a Server with ISW 9.7.1 (one single machine with both Database Server and Application Server) with DB2 already patched to 9.7.3a using the DB2 universal fixpack (ESE+Wrappers).

I need to apply ISW fixpack 9.7.2.

In a previous post on this forum I got some informations:
https://www.ibm.com/developerworks/forums/forum.jspa?forumID=1062&start=45

Anyway, if I only try to install the ISW fixpack 9.7.2 flagging only the Application Server the Data Server Client became flagged because of its dependence of cubing services. If i flag both Database Server and Application Server the DB2 server it seems that I will risk to downgrade the DB2 fixpack from 9.7.3a to 9.7.2 or maybe the installation could file.

Because I do not want to risk to comprise the installation, can anyone hint me how to proceed or if some documentation about the ISW fixpack process have been released?

Thank You
AS
Updated on 2010-12-03T15:55:47Z at 2010-12-03T15:55:47Z by Antonello_Supino
  • BoYang
    BoYang
    3 Posts
    ACCEPTED ANSWER

    Re: Upgrade a ISW 9.7.1 server with DB2 already patched to 9.7.3a to ISW 9.7.2

    ‏2010-12-02T23:21:24Z  in response to Antonello_Supino
    Hi Antonello,

    You can just leave the Data Server Client flagged if you wish to upgrade only the Application Server node. The installer will be able to detect that the Data Server Client/ESE is already on the system will not attempt to downgrade or install a new copy of DB2 product.

    In general, during Warehouse product upgrade, the existing DB2 and WAS product will not be touched.
    thanks,

    Bo
    • Antonello_Supino
      Antonello_Supino
      54 Posts
      ACCEPTED ANSWER

      Re: Upgrade a ISW 9.7.1 server with DB2 already patched to 9.7.3a to ISW 9.7.2

      ‏2010-12-03T15:55:47Z  in response to BoYang
      Hello,
      thank you for your suggestion anyway because I have Data Server and Application Server on the same node and because I needed to patch the Intelligent Miner as well i selected all components exept the Data Server client.

      The upgrading process completed successfully without any issue.
      DB2 remained at v 9.7.3a and was not downgraded, WAS at 7.0.0.3 and was not modified.
      All ISW components were successfully updated and schedule, and deployed DWH applications remained available and I tested they works.

      Thank you
      AS