Topic
  • 4 replies
  • Latest Post - ‏2013-03-11T15:11:22Z by SystemAdmin
jcdfr
jcdfr
3 Posts

Pinned topic Failover takes too long windows 2008 / DS3512

‏2010-12-02T19:39:25Z |
Hi,
I'm new in the ibm world and i have a question for you.

I'm using an x3650 M3, it comes with 2 SAS HBA LSI 6gb single port. Windows 2008 R2.

Each of those Hba are connected to a controller of a DS3512 Dual SAS controller.
I have only one server connected to the DS3512. I have setup a host win2003, 2008 non clustered (not the DMP option).

I can see with dsmutil the 2 paths for each of the LUNs.

When i unplug the owner controller or the sas cable, during a file copy, it takes around 3minutes to failover. During this time file copy hang.

Is there a way to reduce this time ?
Somebody experience same problem ?
a misconfiguration ?

Thanks for reading.
Best regards.
Updated on 2013-03-11T15:11:22Z at 2013-03-11T15:11:22Z by SystemAdmin
  • pavel.alexei
    pavel.alexei
    335 Posts

    Re: Failover takes too long windows 2008 / DS3512

    ‏2010-12-03T15:02:32Z  
    Follow next recommendation i found in "System Storage DS3000 Storage Manager Version 2. Installation and Support Guide for Microsoft Windows Server 2003, Linux, Novell NetWare, and VMware ESX Server"
    Configuring SAS HBA BIOS timeout settings for correct failover
    To make sure that the DS3200 storage subsystem provides correct path failover during heavy I/O in a VMware environment, you must reconfigure two timeout values in the BIOS of the SAS HBA. Failure to do so can cause I/O timeouts. The values that you must change are Report Device Missing Delay and I/O Device Missing Delay.
    To change the SAS HBA BIOS timeout settings, complete the following steps:
    1. Restart the host with the SAS HBAs.
    2. When you are prompted during POST, press Ctrl+C to start the LSI Corp (SAS)
    Configuration Utility.
    Note: If you experience PCI Resource Allocation Errors that prohibit the configuration utility from initializing, you might be forced to disable some PCI devices or control ROM execution space. This error message indicates that the system ROM space is full and there is no more room
    for additional adapters that use ROM space. For more information, see the Retain Tips for “1801 PCI Allocation Errors” at http://www.ibm.com/systems/support/.
    3. On the Adapter List screen, use the arrow keys to select a SAS HBA, and then press Enter. The Adapter Properties screen is displayed.
    4. Select Advanced Adapter Properties and press Enter.
    5. Select Adapter Timing Properties and press Enter.
    6. Change the Report Device Missing Delay to 10 seconds by pressing the + key, - key, or Spacebar.
    7. Change the IO Device Missing Delay to 0 seconds by pressing the + key, - key, or Spacebar.
    8. Repeat step 3 through step 7 for each SAS HBA in the host servers
  • jcdfr
    jcdfr
    3 Posts

    Re: Failover takes too long windows 2008 / DS3512

    ‏2010-12-06T09:41:06Z  
    Follow next recommendation i found in "System Storage DS3000 Storage Manager Version 2. Installation and Support Guide for Microsoft Windows Server 2003, Linux, Novell NetWare, and VMware ESX Server"
    Configuring SAS HBA BIOS timeout settings for correct failover
    To make sure that the DS3200 storage subsystem provides correct path failover during heavy I/O in a VMware environment, you must reconfigure two timeout values in the BIOS of the SAS HBA. Failure to do so can cause I/O timeouts. The values that you must change are Report Device Missing Delay and I/O Device Missing Delay.
    To change the SAS HBA BIOS timeout settings, complete the following steps:
    1. Restart the host with the SAS HBAs.
    2. When you are prompted during POST, press Ctrl+C to start the LSI Corp (SAS)
    Configuration Utility.
    Note: If you experience PCI Resource Allocation Errors that prohibit the configuration utility from initializing, you might be forced to disable some PCI devices or control ROM execution space. This error message indicates that the system ROM space is full and there is no more room
    for additional adapters that use ROM space. For more information, see the Retain Tips for “1801 PCI Allocation Errors” at http://www.ibm.com/systems/support/.
    3. On the Adapter List screen, use the arrow keys to select a SAS HBA, and then press Enter. The Adapter Properties screen is displayed.
    4. Select Advanced Adapter Properties and press Enter.
    5. Select Adapter Timing Properties and press Enter.
    6. Change the Report Device Missing Delay to 10 seconds by pressing the + key, - key, or Spacebar.
    7. Change the IO Device Missing Delay to 0 seconds by pressing the + key, - key, or Spacebar.
    8. Repeat step 3 through step 7 for each SAS HBA in the host servers
    Thanks for you answer, i will try that as soon as possible, maybe next thursday.

    Regards.
  • jcdfr
    jcdfr
    3 Posts

    Re: Failover takes too long windows 2008 / DS3512

    ‏2010-12-13T18:30:33Z  
    Follow next recommendation i found in "System Storage DS3000 Storage Manager Version 2. Installation and Support Guide for Microsoft Windows Server 2003, Linux, Novell NetWare, and VMware ESX Server"
    Configuring SAS HBA BIOS timeout settings for correct failover
    To make sure that the DS3200 storage subsystem provides correct path failover during heavy I/O in a VMware environment, you must reconfigure two timeout values in the BIOS of the SAS HBA. Failure to do so can cause I/O timeouts. The values that you must change are Report Device Missing Delay and I/O Device Missing Delay.
    To change the SAS HBA BIOS timeout settings, complete the following steps:
    1. Restart the host with the SAS HBAs.
    2. When you are prompted during POST, press Ctrl+C to start the LSI Corp (SAS)
    Configuration Utility.
    Note: If you experience PCI Resource Allocation Errors that prohibit the configuration utility from initializing, you might be forced to disable some PCI devices or control ROM execution space. This error message indicates that the system ROM space is full and there is no more room
    for additional adapters that use ROM space. For more information, see the Retain Tips for “1801 PCI Allocation Errors” at http://www.ibm.com/systems/support/.
    3. On the Adapter List screen, use the arrow keys to select a SAS HBA, and then press Enter. The Adapter Properties screen is displayed.
    4. Select Advanced Adapter Properties and press Enter.
    5. Select Adapter Timing Properties and press Enter.
    6. Change the Report Device Missing Delay to 10 seconds by pressing the + key, - key, or Spacebar.
    7. Change the IO Device Missing Delay to 0 seconds by pressing the + key, - key, or Spacebar.
    8. Repeat step 3 through step 7 for each SAS HBA in the host servers
    Thanks, it works.

    Modifying the "Report Device Missing delay" to 10 do the trick
    I haven't change the IO Device Missing delay (default :8)

    The hardest thing was to access HBA SAS Bios !!!!
    You must add the legacy option in the boot manager, but its not enough ! i must change the pci order execution to see the hba bios, to make my sas hba first.
    At last, select start options et enter on the Legacy option.

    Regards.
  • SystemAdmin
    SystemAdmin
    4779 Posts

    Re: Failover takes too long windows 2008 / DS3512

    ‏2013-03-11T15:11:22Z  
    • jcdfr
    • ‏2010-12-13T18:30:33Z
    Thanks, it works.

    Modifying the "Report Device Missing delay" to 10 do the trick
    I haven't change the IO Device Missing delay (default :8)

    The hardest thing was to access HBA SAS Bios !!!!
    You must add the legacy option in the boot manager, but its not enough ! i must change the pci order execution to see the hba bios, to make my sas hba first.
    At last, select start options et enter on the Legacy option.

    Regards.
    I was experiencing the same thing on Red Hat EL 6.2 and I found this post extremely helpful. I found that the easiest method to access the HBA BIOS is to use the F12 option at boot, then select "Legacy Only" as the boot device. That will display all the devices on the screen and you'll see the LSI SAS option come up with the CTRL-C option to configure. After you've made your changes, reboot and it will boot as normal and you won't have to make any UEFI changes.

    In our case, we needed a quick failover so we set both items to 5 seconds. MUCH better than 144 seconds!

    Thanks to all that worked on this. This should be documented in the HBA documentation.