Topic
10 replies Latest Post - ‏2012-02-28T08:23:50Z by QiM
NWDB_Irina_Latfullina
4 Posts
ACCEPTED ANSWER

Pinned topic Installing Design Studio

‏2010-11-26T13:37:11Z |
Hi,

I'm trying to install Design Studio on my computer (Windows XP Proffessional), but during the installaton occures some fatall error regarding on installation of Eclipse. After that Design Studio (of course) does not run and gives an error "eclipse.exe not found".

To solve this problem I installed Eclipse myself (at first the latest version), Design Studion installed correctly (no errors in logs), but when I'm trying to launch it, Eclipse starts, in which there is no functional of Design Studio.

Then I tried to install the version of Eclipse written in the Installation requirements (version 3.4.2). In logs there wasn't any error. At this time during the launching of Design Studio I get the pop-up error message and request to see the following log file:

!SESSION 2010-11-26 11:01:16.453
eclipse.buildId=M20090211-1700
java.version=1.6.0_22
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments: -product com.ibm.datatools.sqw.product.ifwhluw.ifwhluw
Command-line arguments: -os win32 -ws win32 -arch x86 -product com.ibm.datatools.sqw.product.ifwhluw.ifwhluw

!ENTRY org.eclipse.equinox.app 0 0 2010-11-26 11:01:18.468
!MESSAGE Product com.ibm.datatools.sqw.product.ifwhluw.ifwhluw could not be found.

!ENTRY org.eclipse.osgi 4 0 2010-11-26 11:01:19.921
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

Do you have any idea about how to solve this problem?
I appreciate any help.

Thanks in advance.
Updated on 2012-02-28T08:23:50Z at 2012-02-28T08:23:50Z by QiM
  • NWDB_Irina_Latfullina
    4 Posts
    ACCEPTED ANSWER

    Re: Installing Design Studio

    ‏2010-12-02T11:44:39Z  in response to NWDB_Irina_Latfullina
    I solved the problem myself just installing Design Studio on Windows 7.
  • Nafeespari
    Nafeespari
    18 Posts
    ACCEPTED ANSWER

    Re: Installing Design Studio

    ‏2011-04-13T09:44:13Z  in response to NWDB_Irina_Latfullina
    Hi Irina,

    I am a newbie to IBM...and wondering where to find Design Studio. I installed InfoSphere Enterprise Edition 9.7 and want to explore IBM's data mining world. So far no luck. I came across one manual that says to use Design Studio. But I can't find it.

    Can you re-direct me to some download page please? I ve got passport advantage account with IBM.

    Thanks...
    Nafees
    • M._Haide
      M._Haide
      6 Posts
      ACCEPTED ANSWER

      Re: Installing Design Studio

      ‏2011-04-15T12:07:20Z  in response to Nafeespari
      Hi Nafees,
      there is a description available what you need to download:

      https://www-304.ibm.com/support/docview.wss?uid=swg24026988

      The Design Studio is in the client package, which is for Windows: CZK6QML

      If you like to work with Mining be sure that you have installed DB2 and the data mining part.

      Regards,

      Michael
      • Nafeespari
        Nafeespari
        18 Posts
        ACCEPTED ANSWER

        Re: Installing Design Studio

        ‏2011-04-18T12:50:30Z  in response to M._Haide
        Hi Michael,

        I downloaded the client package CZK6QML. I try to install it on Windiw 7 64bit machine but the it says the platform not supported? I thought it would just run in 32 bit mode even on 64 bit machine. Or am I doing something wrong here?

        Nafees
        • JP_Parkin
          JP_Parkin
          128 Posts
          ACCEPTED ANSWER

          Re: Installing Design Studio

          ‏2011-04-18T16:35:46Z  in response to Nafeespari
          You can install the 32-bit client on the 64-bit Windows 7 OS, you just need to ignore the warning about the OS not being supported. There are some potential side effects with having both 64-bit and 32-bit versions of the DB2 client on the same machine. If you only use DB2 via the Design Studio then this should not be an issue. If you use a 64-bit DB2 client on the system you will find that you cannot upgrade the 64-bit DB2 client ( this is a known limitation ). We are in the process of publishing a technote that explains how to work around this limitation and we're also working on plans for a proper 64-bit ISW client Windows package so that you are not impacted by this limitation.

          Best regards,
          JP
          • Nafeespari
            Nafeespari
            18 Posts
            ACCEPTED ANSWER

            Re: Installing Design Studio

            ‏2011-04-19T14:04:03Z  in response to JP_Parkin
            The "Launchpad" application does not allow installation of the client. I ran the install.exe in ISW folder instead and it worked. I am mentioning it for those may also face the same problem.

            I installed InfoSphere 9.7 on a Win Sever 2008 64 bit machine and I want to use design studio from my client machine. I used the configuration assistant on my client and it connected to the db2 server. But in the design studio, that connection is not visible nor can I connect to the db2 on the remote machine there.

            Any tip on that plz?
            Thanks JP.
  • Munchun
    Munchun
    2 Posts
    ACCEPTED ANSWER

    Re: Installing Design Studio

    ‏2012-02-22T08:23:12Z  in response to NWDB_Irina_Latfullina
    Hello
    I am trying to install InfoSphere Warehouse Client 9.7.3. The installtion completes with the message that installation was complete but with some serious issues.

    It gives me a fatal error -

    com.ibm.ds.ia.install.wizard.action.InstallEclipseFeatures
    Status: FATAL ERROR
    Additional Notes: FATAL ERROR - class com.ibm.ds.ia.install.wizard.action.InstallEclipseFeatures FatalInstallException: Cannot run program "\IBMIMc" (in directory "\"): CreateProcess error=2, The system cannot find the file specified.
    When I try to launch Design Studio - it gives me an error the eclipse.exe was not found.

    How and what to do resolve this error?

    Thanks & Regards
    Alok
    • QiM
      QiM
      2 Posts
      ACCEPTED ANSWER

      Re: Installing Design Studio

      ‏2012-02-23T04:42:33Z  in response to Munchun
      Hi Munchun,
      From the log, looks like the Installation Manager is not found which leads the Design Studio installation fail. Design Studio need be deployed by IM. The most possible reason would be that the environment is dirty, the IM registry is lost.

      Would you please check whether IM is installed before the installation. And Please paste more log information before this error here to help address this problem, and also please provide which image is used and on which platform the installer was run.
      • Munchun
        Munchun
        2 Posts
        ACCEPTED ANSWER

        Re: Installing Design Studio

        ‏2012-02-28T08:01:37Z  in response to QiM
        Hello QiM

        I have downloaded from extreme leverage -

        CI4QLML, -> IBM InfoSphere Warehouse Enterprise Edition - PVU Option - Quick Start and Activation V9.7.3 Multiplatform Multilingual
        CZYL8ML-> IBM InfoSphere Warehouse Server V9.7.3 for Windows on 32-bit AMD and Intel systems (x86) Multilingual
        CZYM1ML -> IBM InfoSphere Warehouse Client V9.7.3 for Windows on 32-bit AMD and Intel systems (x86) Multilingual

        I am installing these on Windows 7.
        I was able to successfully install IIW Server. However, when I install InfoSphere Warehouse Client 9.7.3. The installation completes with the message that installation was complete but with some serious issues.
        • QiM
          QiM
          2 Posts
          ACCEPTED ANSWER

          Re: Installing Design Studio

          ‏2012-02-28T08:23:50Z  in response to Munchun
          Hi,

          According to the log, your machine is Windows 7 64bit. But the installer is for windows 32bit, so the Installation Manger can not be correctly detected which leads the Design Studio installation fail.

          Please try to get the 9.7.3 Windows 64b build and run again or switch to a Windows 32b machine with current image.