Topic
  • 3 replies
  • Latest Post - ‏2010-12-01T09:22:31Z by NWDB_Irina_Latfullina
NWDB_Irina_Latfullina
4 Posts

Pinned topic Administration concole problem: "HTTP Request Error"

‏2010-11-26T13:28:36Z |
Hi,

I installed Infosphere Warehouse 9.7.2 on Windows Server 2003 and configured it like in tutorial.

But when I'm logging in and clicking on "Warehouse Administration Console", I get the pop-up message "HTTP Request Error" and I don't get the tabs "SQL Warehousing" and "Cubing Services". The same error occures when I'm trying to open the tab "Mining".

I was trying to restart WAS and clearing the cache in my browser (Firefox 3.6.12), but I keep getting the same problem.

In installation log I've got the one error:"Unable to turn on WAS security". I do not think the problem with this, but I could be wrong.

Do you have any idea about the cause of this error? Or how can I get access to these both tabs?

I appreciate any help.

Thanks in advance.
Updated on 2010-12-01T09:22:31Z at 2010-12-01T09:22:31Z by NWDB_Irina_Latfullina
  • agrin
    agrin
    1 Post

    Re: Administration concole problem: "HTTP Request Error"

    ‏2010-11-26T14:43:59Z  
    Hi Irina,

    during the last Migration of IWH from 9.5 to 9.7.2 we've got the message "HTTP Request Error" also. Some Tabs in Admin Console were not accessable as you desribe.
    I'm not sure the WAS security causes that error, but it'd be better to configure it in proper way. We opened a PMR regarding this issue, but after a long research the root cause of the issue couldn't be found. We've got an answer:
    The development team has reviewed the various logs and setup multiple
    test environments in attempts to recreate the problems encountered in
    the customer's production environment. The logs and files provided from
    the customer's environment lead us to believe that some of the files for
    the Warehouse application were not installed, or were somehow deleted
    from the file system. While, the install logs appear to indicate that
    the product was installed properly - thus identifying some problem after
    install, there's no way for us to explain definitely how or why
    the files were missing.
    The only way we had - trying to install the IWH AC from the scratch. The new installation worked properly.
    That could be your approach.
    Greetings,
    Arkadi
  • JP_Parkin
    JP_Parkin
    128 Posts

    Re: Administration concole problem: "HTTP Request Error"

    ‏2010-11-26T15:04:58Z  
    If you are able to sign-on, then the problem is probably not related to the WAS security message.

    The HTTP Request Errors are typically an indication that the metadata database tables in the SQWCTRL database are not setup or that there is a problem accessing the database.

    For diagnosing this problem I suggest the following steps :

    1) Take a look at the WebSphere Application Server SystemOut.log ( in a directory like <WAS AppServer install>\profiles\AppSrv01\logs\server1 ). Open the file and look towards the bottom of the file. You should see a series of lines like the following which will indicate that your metadata tables have been successfully created.

    
    [11/23/10 13:48:18:609 EST] 00000062 SystemOut     O ----- Scheduler: All Table Exist ------ [11/23/10 13:48:19:328 EST] 00000069 SystemOut     O --------------- SQWMetaService: All tables exist! ------------- [11/23/10 13:48:19:343 EST] 00000069 SystemOut     O --------------- SQWMetaService: New Columns 
    
    for Application table exist! -------------
    


    2) If you don't see this, then what you will probably see instead is a number of java stack exceptions that will identify the database you are attempting to connect with and potentially some SQL errors or messages indicating the source of the problem.

    3) If the error indicates a connection problem, then you can confirm the location of the metadata database by looking at the file named AppServer\profiles\AppSrv01\IBMDataTools\Config\metadb.properties. This will will contain a URL for connecting to the database that can be updated if you believe the database you are connecting to is wrong.

    4) If the error indicates a permissions problem with the connecting userid ( the user in the metadb.properties file needs to be able to create the tables ), then you can either grant the user DBADM privileges ( since they need to be able to create tablespaces, bufferpools and tables ) and restart WAS. Once the tables are created, you can remove the additional permissions that you granted to the user. We are working on a script so that these tables can be created before starting WAS ( ie. by a DBA ) but that is not yet available.

    If these suggestions don't seem to resolve the problem, the other point to note is that your metadata Database should not be partitioned as some of the tables cannot be created in a DPF environment. There are some workarounds for this situation if you happen to run into that scenario - the simplest being to create a single partitioned database for the metadata.

    Finally, posting the SystemOut.log to the forum might help us to help you resolve the problem if the above suggestions do not work.

    Best regards,
    JP
  • NWDB_Irina_Latfullina
    4 Posts

    Re: Administration concole problem: "HTTP Request Error"

    ‏2010-12-01T09:22:31Z  
    • JP_Parkin
    • ‏2010-11-26T15:04:58Z
    If you are able to sign-on, then the problem is probably not related to the WAS security message.

    The HTTP Request Errors are typically an indication that the metadata database tables in the SQWCTRL database are not setup or that there is a problem accessing the database.

    For diagnosing this problem I suggest the following steps :

    1) Take a look at the WebSphere Application Server SystemOut.log ( in a directory like <WAS AppServer install>\profiles\AppSrv01\logs\server1 ). Open the file and look towards the bottom of the file. You should see a series of lines like the following which will indicate that your metadata tables have been successfully created.

    <pre class="jive-pre"> [11/23/10 13:48:18:609 EST] 00000062 SystemOut O ----- Scheduler: All Table Exist ------ [11/23/10 13:48:19:328 EST] 00000069 SystemOut O --------------- SQWMetaService: All tables exist! ------------- [11/23/10 13:48:19:343 EST] 00000069 SystemOut O --------------- SQWMetaService: New Columns for Application table exist! ------------- </pre>

    2) If you don't see this, then what you will probably see instead is a number of java stack exceptions that will identify the database you are attempting to connect with and potentially some SQL errors or messages indicating the source of the problem.

    3) If the error indicates a connection problem, then you can confirm the location of the metadata database by looking at the file named AppServer\profiles\AppSrv01\IBMDataTools\Config\metadb.properties. This will will contain a URL for connecting to the database that can be updated if you believe the database you are connecting to is wrong.

    4) If the error indicates a permissions problem with the connecting userid ( the user in the metadb.properties file needs to be able to create the tables ), then you can either grant the user DBADM privileges ( since they need to be able to create tablespaces, bufferpools and tables ) and restart WAS. Once the tables are created, you can remove the additional permissions that you granted to the user. We are working on a script so that these tables can be created before starting WAS ( ie. by a DBA ) but that is not yet available.

    If these suggestions don't seem to resolve the problem, the other point to note is that your metadata Database should not be partitioned as some of the tables cannot be created in a DPF environment. There are some workarounds for this situation if you happen to run into that scenario - the simplest being to create a single partitioned database for the metadata.

    Finally, posting the SystemOut.log to the forum might help us to help you resolve the problem if the above suggestions do not work.

    Best regards,
    JP
    Thank you for your help.
    I was trying to change the access settings to the database, but it didn't work.

    Then I just reinstalled Warehouse. It wasn't too easy, because there always were fatal errors, but finally I did it! And everything work fine!