Topic
14 replies Latest Post - ‏2012-11-15T04:04:18Z by Novikov_Alexander
JGOMEZ_at_MSI
JGOMEZ_at_MSI
5 Posts
ACCEPTED ANSWER

Pinned topic DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

‏2010-11-08T16:25:54Z |
Hello.

We just got an IBM fibrechannel SAN of type DS4300 (at least, we think so; it has the numbers "1722 - 60U" printed in the label in its back).

This hardware is running with firmware version 05.33.05.00. We would like to upgrade the firmware to the latest compatible version for this hardware, but doing such a thing is proving to be quite a difficult task (we are used to dealing with HP SAN kit of the MSA family, but this is our first IBM kit).

Anyway, we downloaded "IBM System Storage Manager 10", version 10.60.G5.16, but it cannot proceed to upgrade the firmware: it says the current firmware version in our DS4300 is to old so it cannot handle it.

Then we downloaded "IBM System Storage Manager 10", version 10.15.G5.09, and this management software can indeed see and manage our DS4300, but the "Controller Firmware Upgrade Tool" (version 10.15.G5.01) included with this software says that it "upgrades the controller firmware for storage subsystems from version 6.14 or higher to version 7.10 or higher". So we cannot proceed this way either, as our fw version is 5.33.05.

So we are lost. We don't know what IBM software and which version of it we need to get to be able to upgrade the firmware in our DS4300.

The reason we want to upgrade its firmware, is to test it with a cluster installation of SQL Server 2008 running on Windows Server 2008 R2 x64.

Could anyone please give us a helping hand, or some pointer in the right direction?

Thanks a lot.

JGOMEZ.
Updated on 2012-11-15T04:04:18Z at 2012-11-15T04:04:18Z by Novikov_Alexander
  • JGOMEZ_at_MSI
    JGOMEZ_at_MSI
    5 Posts
    ACCEPTED ANSWER

    Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

    ‏2010-11-08T16:42:28Z  in response to JGOMEZ_at_MSI
    I forgot to mention our DS4300 has a dual controller, just in case that is significant.
  • JGOMEZ_at_MSI
    JGOMEZ_at_MSI
    5 Posts
    ACCEPTED ANSWER

    Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

    ‏2010-11-11T12:22:42Z  in response to JGOMEZ_at_MSI
    bump.

    Someone, any help, please?
  • SystemAdmin
    SystemAdmin
    4779 Posts
    ACCEPTED ANSWER

    Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

    ‏2010-11-12T09:27:46Z  in response to JGOMEZ_at_MSI
    Get SM 9.19 from here.

    http://www-947.ibm.com/support/entry/portal/docdisplay?brand=5000008&lndocid=MIGR-66515

    The readme might help you:

    ftp://ftp.software.ibm.com/systems/support/system_x/ibm_sw_ds4kfc2_09.19.xx.12_windows_intl386.txt

    Still looking for an older copy of the controller firmware to help with an intermediate jump.
    Thinking this level might do the trick:

    http://public.dhe.ibm.com/systems/support/system_x/ibm_fw_ds4k_06192400_anyos_anycpu.zip

    Regards, Anthony Vandewerdt

    Visit my blog: http://tinyurl.com/23wgvkw
    Follow me on twitter: http://twitter.com/anthonyvdwerdt
    • SystemAdmin
      SystemAdmin
      4779 Posts
      ACCEPTED ANSWER

      Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

      ‏2010-11-12T09:28:56Z  in response to SystemAdmin
      You can find mountains of older files here:

      http://public.dhe.ibm.com/systems/support/system_x/

      Regards, Anthony Vandewerdt

      Visit my blog: http://tinyurl.com/23wgvkw
      Follow me on twitter: http://twitter.com/anthonyvdwerdt
      • JGOMEZ_at_MSI
        JGOMEZ_at_MSI
        5 Posts
        ACCEPTED ANSWER

        Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

        ‏2010-11-12T13:43:46Z  in response to SystemAdmin
        Thanks a lot, Anthony.

        Using the info you provided, I have done quite some progress.

        I used "IBM System Storage Manager 9" version 09.60.35.05 and with it I upgraded the firmware to version 06.60.22.00, which is the last firmware available for my DS4300 in IBM's support web page. I also upgraded the NVRAM in the DS4300 with the version included in the ZIP package of firmware 06.60.22.00.

        So far, so good - all is working fine. I have created some arrays and logical volumes.
        I have one last question. The latest firmware available in the IBM support web page for DS4300, is version 06.60.22.00. However, it seems it exists version 07.15.07.00, here:

        http://public.dhe.ibm.com/systems/support/system_x/ibm_fw_ds4kfc_07150700_anyos_anycpu.zip

        Is it safe to upgrade my DS4300 to firmware version 07.15.07.00 ?

        Thanks a lot.
        • SystemAdmin
          SystemAdmin
          4779 Posts
          ACCEPTED ANSWER

          Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

          ‏2010-11-13T06:46:50Z  in response to JGOMEZ_at_MSI
          You cannot go past 6.60.22.0 on DS4300 (FastT 600)
          Its the end of the road for code updates.

          You can confirm from the CHG document:

          ftp://ftp.software.ibm.com/systems/support/system_x/ibm_fw_ds4kfc1_07150700_anyos_anycpu.chg

          "IBM System Storage™ DS4000 storage subsystem controller firmware version
          07.15.07.00 for the DS4200-all models, the DS4700-all models and the
          DS4800-all models storage subsystems only"

          Regards, Anthony Vandewerdt

          Visit my blog: http://tinyurl.com/23wgvkw
          Follow me on twitter: http://twitter.com/anthonyvdwerdt
          • JGOMEZ_at_MSI
            JGOMEZ_at_MSI
            5 Posts
            ACCEPTED ANSWER

            Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

            ‏2010-11-15T16:16:37Z  in response to SystemAdmin
            Thank you very much, Anthony.

            You have been of great help. :-)

            -JGOMEZ.
          • SystemAdmin
            SystemAdmin
            4779 Posts
            ACCEPTED ANSWER

            Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

            ‏2012-11-12T16:44:51Z  in response to SystemAdmin
            Hello Anthony, the last firware available for FastT600 controllers is 6.60.34, is it ok to use?

            By the way, i need 5.33 to go back if something goes not ok, where can i find it?

            Thank you.
            • Novikov_Alexander
              Novikov_Alexander
              1392 Posts
              ACCEPTED ANSWER

              Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

              ‏2012-11-12T19:23:03Z  in response to SystemAdmin
              Dear Angel Prieto,

              there is info in change history:

              Version 05.33.07.00 09/2003 Initial Release
              Version 05.33.05.00 09/2003 Initial Release for Netware only

              I am sure this versions were not published and came preinstalled from factory.

              The next version 05.34.02.00 available here:

              http://ps-2.kev009.com/pccbbs/pc_servers/26k9278.txt
              http://ps-2.kev009.com/pccbbs/pc_servers/26k9278.zip

              Regards,
              Alexander Novikov
              Russia, Moscow
              • SystemAdmin
                SystemAdmin
                4779 Posts
                ACCEPTED ANSWER

                Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

                ‏2012-11-12T19:31:01Z  in response to Novikov_Alexander
                Thanks a lot, so 6.60.34 is the last firmware for FastT600?
                • Novikov_Alexander
                  Novikov_Alexander
                  1392 Posts
                  ACCEPTED ANSWER

                  Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

                  ‏2012-11-13T03:42:50Z  in response to SystemAdmin
                  Hi Angel Prieto,

                  last firmware for FastT600/DS4300 available on IBM Fix Central:

                  Here is the generated link to the Fix Central page.

                  http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=Mid-range+disk+systems&product=ibm/Storage_Disk/DS4300+Express&release=All&platform=All&function=all&source=fc

                  Regards,
                  Alexander Novikov
                  Russia, Moscow
                  • SystemAdmin
                    SystemAdmin
                    4779 Posts
                    ACCEPTED ANSWER

                    Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

                    ‏2012-11-13T11:48:41Z  in response to Novikov_Alexander
                    Ok, perfect.

                    And when I update firmware will I need to update HBA's drivers?
                    Could there be a lost of service and that hosts could lose their disks?

                    Thank you very much.
                    • SystemAdmin
                      SystemAdmin
                      4779 Posts
                      ACCEPTED ANSWER

                      Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

                      ‏2012-11-13T12:00:25Z  in response to SystemAdmin
                      And for the last, should I update disk's firmware?

                      Thank you.
                      • Novikov_Alexander
                        Novikov_Alexander
                        1392 Posts
                        ACCEPTED ANSWER

                        Re: DS4300 firmware upgrade: I'm at 5.33.05 fw level (help!)

                        ‏2012-11-15T04:04:18Z  in response to SystemAdmin
                        Hi Angel Prieto,

                        there is info in DS4300 firmware readme file:

                        "Make any hard disk drive and/or drive expansion enclosure ESM firmware
                        updates as required BEFORE proceeding to upgrade the DS4000 controller
                        with the firmware and NVSRAM files packaged with this README file.
                        FAILURE to observe the minimum firmware requirement might cause your
                        DS4000 storage subsystem to be OUT-OF-SERVICE. Check the IBM System
                        Storage™ Disk Storage Systems Technical Support web site for the latest
                        released hard drive firmware if you have not already upgraded drive
                        firmware to the latest supported version. (See 1.4 Dependencies)"

                        Regards,
                        Alexander Novikov
                        Russia, Moscow