Topic
  • 2 replies
  • Latest Post - ‏2010-11-04T23:04:24Z by TedKirby
TedKirby
TedKirby
8 Posts

Pinned topic Problem with samples in new Nov 5 2010 release

‏2010-11-04T20:42:14Z |
I get the following error when importing either sample application:

A problem occurred during the import operation.
One or more constraints have not been satisfied.
OSGi Bundle requires Java 1.5 or newer.
Updated on 2010-11-04T23:04:24Z at 2010-11-04T23:04:24Z by TedKirby
  • SystemAdmin
    SystemAdmin
    9 Posts

    Re: Problem with samples in new Nov 5 2010 release

    ‏2010-11-04T21:02:10Z  
    What is your Java Installed JRE level ?
    The OSGi development tools requires a JRE that is 1.5 or newer.
  • TedKirby
    TedKirby
    8 Posts

    Re: Problem with samples in new Nov 5 2010 release

    ‏2010-11-04T23:04:24Z  
    What is your Java Installed JRE level ?
    The OSGi development tools requires a JRE that is 1.5 or newer.
    Thanks to Zina's excellent help, my problem is resolved. It seems my workspace got corrupted. I reinstalled eclipse, but still had problems with the old workspace. Creating a new workspace solved the problem. I am using a Mac with Java 6.