IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 2 replies
  • Latest Post - ‏2010-11-27T14:39:12Z by RobCor
RobCor
RobCor
2 Posts

Pinned topic Getting error similar to APAR - PM06364 - But I am using newer SCA pack

‏2010-11-03T20:27:26Z |
Hi All,

I am getting an error similar to APAR - PM06364.
http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg1PM06364

I am currently using SCA feature pack 1.0.1.5. When I look at the WireFormatJMSBytes class in the com.ibm.ws.soa.sca.bindings.jar it does not have the equals method mentioned in PM06364(it says the equals method will be added as a fix).

I have another server that has the older SCA feature pack 1.0.1.1. When I look at that WireFormatJMSBytes class in the com.ibm.ws.soa.sca.bindings.jar it does have the equals method that is mentioned in PM06364. And my code works there with no error. The PM06364 mentions a fix for this being added for 1.0.1.3.

Was the fix added and then somehow dropped? -or- maybe my installations are incorrect or something. If anyone knows, please let me know.

Thanks.

-Rob Corbin
Updated on 2010-11-27T14:39:12Z at 2010-11-27T14:39:12Z by RobCor
  • KaushikMukherjee
    KaushikMukherjee
    1 Post

    Re: Getting error similar to APAR - PM06364 - But I am using newer SCA pack

    ‏2010-11-03T21:04:14Z  
    Hi Rob,

    Can you check the compile dates on the class files in the different jars just to verify that the 1.0.1.5 install root has the newer class/jar.

    Thanks,
    Kaushik
  • RobCor
    RobCor
    2 Posts

    Re: Getting error similar to APAR - PM06364 - But I am using newer SCA pack

    ‏2010-11-27T14:39:12Z  
    This issue has been resolved. Once the server was upgraded to SCA feature pack version 1.0.1.7, the equals method is back and the code no longer errors. Not sure about a root cause for the original problem. SCA 1.0.1.5 should have had method I needed.

    Thanks.

    -Rob