Topic
  • 5 replies
  • Latest Post - ‏2012-12-06T06:26:32Z by SystemAdmin
SystemAdmin
SystemAdmin
5842 Posts

Pinned topic Email Lisnter Error

‏2010-10-30T09:51:50Z |
Hi All,

I am getting following error in Administrator Email Address when trying to configure Email Listner in TSRM 7.2:

Error connecting to mail server for e-mail address <email_address> on mail server <server_ip> .Please review the Maximo log file.
java.lang.SecurityException Access to default session denied
at javax.mail.Session.getDefaultInstance(Session.java 292)
at psdi.common.emailstner.EmailListnerTask.readMessagesFromMailServer(EmailListnerTask.java 599)
at psdi.common.emailstner.EmailListnerTask.performTask(EmailListnerTask.java 259)
at psdi.common.emailstner.EmailListnerCron.cronAction(EmailListnerCron.java 49)
at psdi.server.CronTaskManager.callCronMethod(CronTaskManager.java 1552)
at psdi.server.CronTaskManager.access$400(CronTaskManager.java 83)
at psdi.server.CronTaskManager$CronThread.run(CronTaskManager.java 2070)

I have tested IMAP connectivity using telnet. Mail server configuration is fine and IMAP through telnet is replying the requests using same email address and password.

Also if I give wrong password in email listner configuration the behaviour of the error doesnt change. I get same error inputing valid or invalid password.

Kindly suggest.
Updated on 2012-12-06T06:26:32Z at 2012-12-06T06:26:32Z by SystemAdmin
  • E.A.
    E.A.
    17 Posts

    Re: Email Lisnter Error

    ‏2010-11-01T06:20:02Z  
    Good day!

    To solve your problem, try to use the script "testmail.bat".
    This script can be found here: <Maximo directory> \ tools \ maximo \ internal \ testmail.bat

    This script takes steps to connect to your mail server if there are errors, they will be displayed on the screen.
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: Email Lisnter Error

    ‏2010-11-01T07:20:02Z  
    • E.A.
    • ‏2010-11-01T06:20:02Z
    Good day!

    To solve your problem, try to use the script "testmail.bat".
    This script can be found here: <Maximo directory> \ tools \ maximo \ internal \ testmail.bat

    This script takes steps to connect to your mail server if there are errors, they will be displayed on the screen.
    Thanks for the reply.

    I am getting following output when running command:

    D:\ibm\SMP\maximo\tools\maximo\internal>TestEmail.bat <server_ip> 143 tsrm@domain.com 123456 imap true
    • Email test: Connected to e-mail accounttsrm@domain.com
    DEBUG: setDebug: JavaMail version 1.3.2
    DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.
    IMAPStore,Sun Microsystems, Inc]
    DEBUG: mail.imap.fetchsize: 16384
    • OK Domino IMAP4 Server Release 7.0.3FP1 ready Mon, 1 Nov 2010 12:12:12 +0500
    A0 CAPABILITY
    • CAPABILITY IMAP4rev1 AUTH=PLAIN LITERAL+ NAMESPACE QUOTA UIDPLUS
    A0 OK CAPABILITY completed
    IMAP DEBUG: AUTH: PLAIN
    DEBUG: protocolConnect login, host=<server_ip>, user=tsrm@domain.com, pa
    ssword=<non-null>
    A1 AUTHENTICATE PLAIN
    +
    dHNybUBhc2thcmliYW5rLmNvbS5wawB0c3JtQGFza2FyaWJhbmsuY29tLnBrADEyMzQ1Ng==
    A1 OK AUTHENTICATE completed
    A2 CAPABILITY
    • CAPABILITY IMAP4rev1 AUTH=PLAIN LITERAL+ NAMESPACE QUOTA UIDPLUS
    A2 OK CAPABILITY completed
    IMAP DEBUG: AUTH: PLAIN
    DEBUG: connection available -- size: 1
    A3 EXAMINE INBOX
    A3 OK READ-ONLY EXAMINE completed
    Exception in thread "main" java.lang.NoClassDefFoundError: com.sun.mail.util.Sha
    redByteArrayInputStream
    at java.lang.J9VMInternals.verifyImpl(Native Method)
    at java.lang.J9VMInternals.verify(J9VMInternals.java:63)
    at java.lang.J9VMInternals.verify(J9VMInternals.java:61)
    at java.lang.J9VMInternals.initialize(J9VMInternals.java:124)
    at com.sun.mail.imap.IMAPFolder.open(IMAPFolder.java:990)
    at psdi.tools.TestEmail.<init>(Unknown Source)
    at psdi.tools.TestEmail.main(Unknown Source)

    Mail server connectivity is fine I think. Don't know what this error is all about. Any ideas ?

    Takecare.
  • E.A.
    E.A.
    17 Posts

    Re: Email Lisnter Error

    ‏2010-11-01T15:18:42Z  
    Thanks for the reply.

    I am getting following output when running command:

    D:\ibm\SMP\maximo\tools\maximo\internal>TestEmail.bat <server_ip> 143 tsrm@domain.com 123456 imap true
    • Email test: Connected to e-mail accounttsrm@domain.com
    DEBUG: setDebug: JavaMail version 1.3.2
    DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.
    IMAPStore,Sun Microsystems, Inc]
    DEBUG: mail.imap.fetchsize: 16384
    • OK Domino IMAP4 Server Release 7.0.3FP1 ready Mon, 1 Nov 2010 12:12:12 +0500
    A0 CAPABILITY
    • CAPABILITY IMAP4rev1 AUTH=PLAIN LITERAL+ NAMESPACE QUOTA UIDPLUS
    A0 OK CAPABILITY completed
    IMAP DEBUG: AUTH: PLAIN
    DEBUG: protocolConnect login, host=<server_ip>, user=tsrm@domain.com, pa
    ssword=<non-null>
    A1 AUTHENTICATE PLAIN
    +
    dHNybUBhc2thcmliYW5rLmNvbS5wawB0c3JtQGFza2FyaWJhbmsuY29tLnBrADEyMzQ1Ng==
    A1 OK AUTHENTICATE completed
    A2 CAPABILITY
    • CAPABILITY IMAP4rev1 AUTH=PLAIN LITERAL+ NAMESPACE QUOTA UIDPLUS
    A2 OK CAPABILITY completed
    IMAP DEBUG: AUTH: PLAIN
    DEBUG: connection available -- size: 1
    A3 EXAMINE INBOX
    A3 OK READ-ONLY EXAMINE completed
    Exception in thread "main" java.lang.NoClassDefFoundError: com.sun.mail.util.Sha
    redByteArrayInputStream
    at java.lang.J9VMInternals.verifyImpl(Native Method)
    at java.lang.J9VMInternals.verify(J9VMInternals.java:63)
    at java.lang.J9VMInternals.verify(J9VMInternals.java:61)
    at java.lang.J9VMInternals.initialize(J9VMInternals.java:124)
    at com.sun.mail.imap.IMAPFolder.open(IMAPFolder.java:990)
    at psdi.tools.TestEmail.<init>(Unknown Source)
    at psdi.tools.TestEmail.main(Unknown Source)

    Mail server connectivity is fine I think. Don't know what this error is all about. Any ideas ?

    Takecare.
    Did you try to send mail using SMTP protocol?

    Mail is sent normally, or has occurred is the same mistake?

    I work with TSRM version 7.2.0 and these problems did not arise, although the problem similar to your's was in version 7.1.1. : http://www-01.ibm.com/support/docview.wss?rs=0&dc=DB500&q1=java.lang.SecurityException+Access+to+default+session+denied&uid=swg1IZ85367&loc=en_US&cs=utf-8&cc=us&lang = en
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: Email Lisnter Error

    ‏2010-11-02T05:32:55Z  
    • E.A.
    • ‏2010-11-01T15:18:42Z
    Did you try to send mail using SMTP protocol?

    Mail is sent normally, or has occurred is the same mistake?

    I work with TSRM version 7.2.0 and these problems did not arise, although the problem similar to your's was in version 7.1.1. : http://www-01.ibm.com/support/docview.wss?rs=0&dc=DB500&q1=java.lang.SecurityException+Access+to+default+session+denied&uid=swg1IZ85367&loc=en_US&cs=utf-8&cc=us&lang = en
    Problem resolved by following this solution:
    http://www-01.ibm.com/support/docview.wss?uid=swg21315815

    Regards
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: Email Lisnter Error

    ‏2012-12-06T06:26:32Z  
    Problem resolved by following this solution:
    http://www-01.ibm.com/support/docview.wss?uid=swg21315815

    Regards
    Hi Muhammed,

    The link is not active currently. Could you please post the cause of that error and remedy. Thanks.