Topic
  • 2 replies
  • Latest Post - ‏2010-10-31T22:25:22Z by RodrigoEsteban
RodrigoEsteban
RodrigoEsteban
2 Posts

Pinned topic RedHat 5 - Boot PXE but DHCP can't configure an IP on eth0

‏2010-10-26T20:21:58Z |
Hi all!

I have a bladecenter H chasis with 4 swtiches BNT Layer 2/3 and 22 bladeServer HS22 with two onboard Ethernet adapter and one combo card (44X1940 FC x2 /Ethernet x2) on each blade.

Only switches on bay 1 and 2 are pluged in and have patch cord.

The problem (only with redhat 4/5 Enterprise Edition) is that i want to install Redhat over lan.
First the blade server boot via PXE, this works just fine. So, the RedHat begins installation but can't obtain an IP address from DHCP server for eth0. I set it up manually. Afeter that i get the following message: Could not connect with image repository, please mount installation media.

I do not understand why the blade boot fine via PXE, but when RedHat installation begin the network connection is lost.

Does anyone have any idea?

Thank! and sorry about my english!
Updated on 2010-10-31T22:25:22Z at 2010-10-31T22:25:22Z by RodrigoEsteban
  • sdenham
    sdenham
    3 Posts

    Re: RedHat 5 - Boot PXE but DHCP can't configure an IP on eth0

    ‏2010-10-28T20:15:38Z  
    This symptom often indicates the switches are configured to do spanning-tree searches. When RHEL's anaconda installer configures the Ethernet port, it disables it and re-enables it. If the port is set to do spanning tree, the time it takes the port to become ready again may be many seconds, and longer than the timeout period in anaconda, so the 2nd PXE request appears to fail even though the inital one worked. For Cisco switches the solution is to set the port to "portfast" mode - other switch families have similar settings, sometimes distinguishing whether the port goes to a server or another switch.
  • RodrigoEsteban
    RodrigoEsteban
    2 Posts

    Re: RedHat 5 - Boot PXE but DHCP can't configure an IP on eth0

    ‏2010-10-31T22:25:22Z  
    • sdenham
    • ‏2010-10-28T20:15:38Z
    This symptom often indicates the switches are configured to do spanning-tree searches. When RHEL's anaconda installer configures the Ethernet port, it disables it and re-enables it. If the port is set to do spanning tree, the time it takes the port to become ready again may be many seconds, and longer than the timeout period in anaconda, so the 2nd PXE request appears to fail even though the inital one worked. For Cisco switches the solution is to set the port to "portfast" mode - other switch families have similar settings, sometimes distinguishing whether the port goes to a server or another switch.
    Thanks for the tip!
    The problem was that bladeserver switchs over the order of networks adapter, so for RedHat eth0 is the port connected to switch in bay 7, eth1 for switch in bay 9, eth2 for switch in bay 1 and eth3 for switch in bay 2.
    Basically the only thing i have to do was plug all switches (only switchs in bay 1 & 2 were connected)to the network.

    Regards