Topic
  • 4 replies
  • Latest Post - ‏2013-03-14T14:40:59Z by MichaelAM
robinsguk
robinsguk
46 Posts

Pinned topic Error starting Firefox

‏2010-10-25T06:43:16Z |
Hello,

I'm having trouble running firefox. Here's my environment:

AIX 6.1 TL5
Firefox 3.5.8.0

I have downloaded the firefox gz file from the IBM Entitled Software site so it's the correct version for my system.

installp reports that Firefox.base is installed and committed.

When I try and run /usr/bin/firefox I receive:

exec(): 0509-0366 Cannot load program /usr/mozilla/firefox/firefox-bin because of the following errors:
0509-022 Cannot load module /usr/lib/libfontconfig.a(libfontconfig.so.1).
0509-150 Dependant module /lib/libxml2.a(libxml2.so.2) could not be loaded.
0509-103 The module has an invalid magic number.
0509-022 Cannot load module firefox-bin.
0509-150 Dependant module /usr/lib/libfontconfig.a(libfontconfig.so.1) could not be loaded
0509-022 Cannot load module.

So, I can see there's an issue with libxml2.
libxml2-2.6.17-3 is installed and committed.

Files libxml2.a and libxml2.so.2 is are /lib

Can anyone suggest what I need to do to correct this error?

Thanks

Glenn
Updated on 2013-03-14T14:40:59Z at 2013-03-14T14:40:59Z by MichaelAM
  • SimonMarchese
    SimonMarchese
    8 Posts

    Re: Error starting Firefox

    ‏2010-10-27T16:30:58Z  
    Can you check whether the prequisite RPMs are installed? This is from the README for Firefox 3.5.8 from the ESS site.

    1. Before Firefox(64 bit) can be installed, the prerequisite RPMs from the
    Firefox CD or from the AIX Toolbox for Linux Applications must be installed.
    The specific 64 bit RPMs required by Firefox are the following:

    atk-1.12.3-2.aix5.2.ppc.rpm
    cairo-1.8.8-1.aix5.2.ppc.rpm
    expat-2.0.1-1.aix5.2.ppc.rpm
    fontconfig-2.4.2-1.aix5.2.ppc.rpm
    freetype2-2.3.9-1.aix5.2.ppc.rpm
    gettext-0.10.40-6.aix5.1.ppc.rpm
    glib2-2.12.4-2.aix5.2.ppc.rpm
    gtk2-2.10.6-4.aix5.2.ppc.rpm
    libjpeg-6b-6.aix5.1.ppc.rpm
    libpng-1.2.32-2.aix5.2.ppc.rpm
    libtiff-3.8.2-1.aix5.2.ppc.rpm
    pango-1.14.5-4.aix5.2.ppc.rpm
    xcursor-1.1.7-3.aix5.2.ppc.rpm
    xft-2.1.6-5.aix5.1.ppc.rpm
    xrender-0.9.1-3.aix5.2.ppc.rpm
    zlib-1.2.3-3.aix5.1.ppc.rpm
    pixman-0.12.0-3.aix5.2.ppc.rpm
  • tiana
    tiana
    6 Posts

    Re: Error starting Firefox

    ‏2011-07-12T16:23:32Z  
    Can you check whether the prequisite RPMs are installed? This is from the README for Firefox 3.5.8 from the ESS site.

    1. Before Firefox(64 bit) can be installed, the prerequisite RPMs from the
    Firefox CD or from the AIX Toolbox for Linux Applications must be installed.
    The specific 64 bit RPMs required by Firefox are the following:

    atk-1.12.3-2.aix5.2.ppc.rpm
    cairo-1.8.8-1.aix5.2.ppc.rpm
    expat-2.0.1-1.aix5.2.ppc.rpm
    fontconfig-2.4.2-1.aix5.2.ppc.rpm
    freetype2-2.3.9-1.aix5.2.ppc.rpm
    gettext-0.10.40-6.aix5.1.ppc.rpm
    glib2-2.12.4-2.aix5.2.ppc.rpm
    gtk2-2.10.6-4.aix5.2.ppc.rpm
    libjpeg-6b-6.aix5.1.ppc.rpm
    libpng-1.2.32-2.aix5.2.ppc.rpm
    libtiff-3.8.2-1.aix5.2.ppc.rpm
    pango-1.14.5-4.aix5.2.ppc.rpm
    xcursor-1.1.7-3.aix5.2.ppc.rpm
    xft-2.1.6-5.aix5.1.ppc.rpm
    xrender-0.9.1-3.aix5.2.ppc.rpm
    zlib-1.2.3-3.aix5.1.ppc.rpm
    pixman-0.12.0-3.aix5.2.ppc.rpm
    hi,

    i followed the link in the readme doc which took me to another link 'ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/INSTALLP/ppc/rpm.rte' where i'm to finally download the packages and it gave me page error. pls is there any other link i go to to download the packaged. thank in advance.
  • SystemAdmin
    SystemAdmin
    6902 Posts

    Re: Error starting Firefox

    ‏2013-03-09T20:04:00Z  
    • tiana
    • ‏2011-07-12T16:23:32Z
    hi,

    i followed the link in the readme doc which took me to another link 'ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/INSTALLP/ppc/rpm.rte' where i'm to finally download the packages and it gave me page error. pls is there any other link i go to to download the packaged. thank in advance.
    bash-4.2# firefox
    Could not load program /usr/mozilla/firefox/firefox-bin:
    Could not load module /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1).
    Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
    Member libiconv.so.2 is not found in archive
    Could not load module firefox-bin.
    Dependent module /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1) could not be loaded.
    Could not load module .
    bash-4.2#
    Can you please provide any suggestion on this errors
  • MichaelAM
    MichaelAM
    11 Posts

    Re: Error starting Firefox

    ‏2013-03-14T14:40:59Z  
    bash-4.2# firefox
    Could not load program /usr/mozilla/firefox/firefox-bin:
    Could not load module /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1).
    Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
    Member libiconv.so.2 is not found in archive
    Could not load module firefox-bin.
    Dependent module /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1) could not be loaded.
    Could not load module .
    bash-4.2#
    Can you please provide any suggestion on this errors
    1st step: verify that the iconv fileset is installed: bos.rte.iconv

    michael@x054:[/home/michael]lslpp -w /usr/lib/libiconv.a
    File Fileset Type

    /usr/lib/libiconv.a bos.rte.iconv File