Topic
  • 2 replies
  • Latest Post - ‏2011-01-06T09:01:19Z by ZhenYuHu
dot7171
dot7171
6 Posts

Pinned topic When manually bringing Primary Node down PowerHA tries to varyoff rootvg

‏2010-10-18T16:53:25Z |
Using AIX 5.3 and PowerHA 5.3

Nothing has changed since I last tested. We did have the server crash last year and it did fail over to the failover server

For some reason hacmp.out shows rootvg in the list of volume groups that the resource group has and because of that manually bringing down the PowerHa on the node just hangs and I end of having to do a shutdown

+star_rg:process_resources+2326 eval JOB_TYPE=VGS ACTION=RELEASE VOLUME_GROUPS
="h6190vg,unixvg,rootvg" RESOURCE_GROUPS="star_rg " EXPORT_FILESYSTEM=""
+star_rg:process_resources+2326 JOB_TYPE=VGS ACTION=RELEASE VOLUME_GROUPS=h619
0vg,unixvg,rootvg RESOURCE_GROUPS=star_rg EXPORT_FILESYSTEM=

But the cllsvg show only the two shared volume groups that are suppose to be in the resource group

  1. cllsvg -g star_rg
h6190vg
unixvg

I have provided IBM a snap last Wednesday but so far they have found nothing

I do have a directory soft linked from the unixvg share to /opt and I thought maybe that was causing it so before I brought the server down this morning I unlinked it but still had the problem

Has anyone every seen this before and if so what did you do to fix it
Updated on 2011-01-06T09:01:19Z at 2011-01-06T09:01:19Z by ZhenYuHu
  • dot7171
    dot7171
    6 Posts

    Re: When manually bringing Primary Node down PowerHA tries to varyoff rootvg

    ‏2010-11-01T15:43:21Z  
    Found the problem

    in rootvg there was a logical volume lv_hbo closed and without a mount point

    In the odm "CuAt" this logical volume had a mount point "/hbo"

    There is a mount on the Shared Volume "unixvg" also called "/hbo"

    Solution removed the logical volume "lv_hbo" in rootvg
  • ZhenYuHu
    ZhenYuHu
    2 Posts

    Re: When manually bringing Primary Node down PowerHA tries to varyoff rootvg

    ‏2011-01-06T09:01:19Z  
    • dot7171
    • ‏2010-11-01T15:43:21Z
    Found the problem

    in rootvg there was a logical volume lv_hbo closed and without a mount point

    In the odm "CuAt" this logical volume had a mount point "/hbo"

    There is a mount on the Shared Volume "unixvg" also called "/hbo"

    Solution removed the logical volume "lv_hbo" in rootvg
    I think HACMP use the LV information not /etc/filesystems.
    Once at the customer site, I chang FS information in /etc/filesystems, this is invalid to HACMP. HACMP also mount FS use the mount point saved in LV.