Topic
  • 2 replies
  • Latest Post - ‏2010-10-08T14:00:08Z by senthil400
senthil400
senthil400
2 Posts

Pinned topic Cannot complete the install in Eclipse Java EE IDE - Helois

‏2010-10-07T13:51:37Z |
Hello,

1)I installed the following version.

Eclipse Java EE IDE for Web Developers.
Version: Helios Service Release 1
Build id: 20100917-0705

2)As per the document, I went Helios update site and installed (http://download.eclipse.org/releases/helios) on Eclipse 3.6 install Business Intelligence, Reporting and Charting and Web, XML and Java EE
Development.

3)Then I tried to add Application Migration Tool.

It says dependency issues. Let me know how I can resolve this.
Cannot complete the install because of a conflicting dependency.
Software being installed: Application Migration Tool - Common Feature 2.0.0.201009130928 (com.ibm.ws.appconversion_feature.common.feature.group 2.0.0.201009130928)
Software currently installed: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
Only one of the following can be installed at once:
Standard Widget Toolkit 3.6.0.v3650b (org.eclipse.swt 3.6.0.v3650b)
Standard Widget Toolkit 3.6.1.v3655c (org.eclipse.swt 3.6.1.v3655c)
org.eclipse.swt 3.3.0.v3346
Cannot satisfy dependency:
From: Java Architectural Core Plug-in 7.0.0.201009130928 (com.ibm.rsaz.analysis.architecture.core 7.0.0.201009130928)
To: bundle org.eclipse.swt [3.4.0,3.6.1)
Cannot satisfy dependency:
From: Application Migration Tool - Common Feature 2.0.0.201009130928 (com.ibm.ws.appconversion_feature.common.feature.group 2.0.0.201009130928)
To: com.ibm.rsaz.analysis.architecture.core [7.0.0,8.0.0)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
To: org.eclipse.epp.package.jee.feature.feature.group http://1.3.1.20100916-1202
Cannot satisfy dependency:
From: Java EE IDE Feature 1.3.1.20100916-1202 (org.eclipse.epp.package.jee.feature.feature.group 1.3.1.20100916-1202)
To: org.eclipse.platform.feature.group http://3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L
Cannot satisfy dependency:
From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
To: org.eclipse.rcp.feature.group http://3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T
Cannot satisfy dependency:
From: Eclipse RCP 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T)
To: org.eclipse.swt http://3.6.1.v3655c
Updated on 2010-10-08T14:00:08Z at 2010-10-08T14:00:08Z by senthil400
  • SystemAdmin
    SystemAdmin
    102 Posts

    Re: Cannot complete the install in Eclipse Java EE IDE - Helois

    ‏2010-10-07T20:35:59Z  
    Thank you for taking the time to post this issue to the forum. We are working on a new build to fix the dependency problem. As soon as the the build is available on developerWorks, I will post another reply.

    In the mean time, the current build should install to Eclipse 3.6.0 and lower. We apologize for your inconvenience.

    Cindy
  • senthil400
    senthil400
    2 Posts

    Re: Cannot complete the install in Eclipse Java EE IDE - Helois

    ‏2010-10-08T14:00:08Z  
    Thank you for taking the time to post this issue to the forum. We are working on a new build to fix the dependency problem. As soon as the the build is available on developerWorks, I will post another reply.

    In the mean time, the current build should install to Eclipse 3.6.0 and lower. We apologize for your inconvenience.

    Cindy
    Hi Cindy,

    It installed in Eclipse 3.6.0.
    Thanks.

    Regards,
    Senthil.