IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 15 replies
  • Latest Post - ‏2011-09-15T00:57:32Z by ReddiSekharaSingala
vivek090
vivek090
2 Posts

Pinned topic ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

‏2010-10-05T14:39:47Z |
Hi All,
I am using gcc for compilation. During compilation of one of the modules, I am getting the following error during linking:
ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT (entry 550) in object ./.libs/libcheck.ahttp://check_library_init.o:
The symbol refers to a csect with symbol number 0, which was not
found. The new symbol cannot be associated with a csect and
is being ignored.

Can someone please help resolve this error.

Thanks and Regards,
Vivek
Updated on 2011-09-15T00:57:32Z at 2011-09-15T00:57:32Z by ReddiSekharaSingala
  • vivek090
    vivek090
    2 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2010-10-06T13:50:02Z  
    Hi All,
    Got over the error after linking with the compiled libz.a the above error is resolved.

    Regards,
    Vivek
  • gsperanza
    gsperanza
    1 Post

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2010-12-07T18:35:51Z  
    • vivek090
    • ‏2010-10-06T13:50:02Z
    Hi All,
    Got over the error after linking with the compiled libz.a the above error is resolved.

    Regards,
    Vivek
    Vivek

    I am a newbie and am getting the same error when using gcc to run some makefiles on unix 6.1 using gcc 4.2.4.
    Can you elaborate on how you linked libz.a?
  • Datatron
    Datatron
    1 Post

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2010-12-31T00:13:59Z  
    • gsperanza
    • ‏2010-12-07T18:35:51Z
    Vivek

    I am a newbie and am getting the same error when using gcc to run some makefiles on unix 6.1 using gcc 4.2.4.
    Can you elaborate on how you linked libz.a?
    I too am having the same problem, trying to compile many programs, and receiving the similar error. as stated previously, could someone please respond with a more detail instructions on how to resolve the problem. thank you.
  • SystemAdmin
    SystemAdmin
    549 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-01-11T09:02:27Z  
    Try to use the GNU Linker (see binutils GNU collection) instead of the AIX native linker (ld command).
  • vbaranov
    vbaranov
    2 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-02-14T18:41:50Z  
    A reason for this are uninitialized static variables in source while using a debug option (-g): use "-g0" or just don't use it. Such behavior is being observed since AIX 5.3 TL12. Refer to the "Bug 46072" at
    http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46072
    for further details.

    Val
  • DavidKirkby
    DavidKirkby
    5 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-22T21:16:14Z  
    • vbaranov
    • ‏2011-02-14T18:41:50Z
    A reason for this are uninitialized static variables in source while using a debug option (-g): use "-g0" or just don't use it. Such behavior is being observed since AIX 5.3 TL12. Refer to the "Bug 46072" at
    http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46072
    for further details.

    Val
    Am I right in assuming this problem is caused by a patch released by IBM? If so, why has the problem not been corrected in a subsequent patch?

    For small projects it might be practical to just initialize all static variable that are uninitialized. But for large projects, where you need to get agreement from others to make these changes, that solution is just impractical.

    Likewise compiling without -g is not always practical, as many open-source projects based on autoconf/automake do this by default.

    Is there no more robust solution to this problem?

    Dave
  • DavidKirkby
    DavidKirkby
    5 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-23T17:13:09Z  
    Could someone with an AIX support contract raise this officially with IBM? It might help get a propor solution, rather than a list of workarounds.

    Dave
  • vbaranov
    vbaranov
    2 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-23T21:21:59Z  
    Could someone with an AIX support contract raise this officially with IBM? It might help get a propor solution, rather than a list of workarounds.

    Dave
    This is not a "bug", this is a "feature". IBM will never fix that (my best guess).
    This issue was reported as a bug at GCC bugzilla - refer to
    http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46072
    for the details.
  • DavidKirkby
    DavidKirkby
    5 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-23T21:40:28Z  
    • vbaranov
    • ‏2011-03-23T21:21:59Z
    This is not a "bug", this is a "feature". IBM will never fix that (my best guess).
    This issue was reported as a bug at GCC bugzilla - refer to
    http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46072
    for the details.
    vbaranov ,

    I know you say it's a "feature", but the gcc folks seem to think it's an AIX "bug". The fact it happens when one updates AIX would tend to make them think that even more, though I'm personally aware that is not proof it's an AIX bug.

    I'm not saying who is right or wrong, but it could possibly be either

    * A gcc bug
    * A bug in the AIX linker
    * A bug in the AIX assembler.

    AIX is a pretty rare operating system and you would need to convince the gcc folks that this is a gcc bug for them to do anything about it. So far, there's nothing to convince them that this is not simply an AIX bug.

    Hence sitting on this, waiting for the gcc folks to "fix" this is probably not going to achieve anything without proof its a gcc bug.

    Dave
  • haubi
    haubi
    37 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-24T10:43:20Z  
    Could someone with an AIX support contract raise this officially with IBM? It might help get a propor solution, rather than a list of workarounds.

    Dave
    Seems this issue is already known as APAR IZ69955, and a fix is already available somehow.
    However, this fix introduces another problem - already known to IBM, but I don't have that APAR number yet.

    In the meantime, there is a workaround (or fix?) available in gcc's bug report.
    /haubi/
  • DavidKirkby
    DavidKirkby
    5 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-24T12:31:17Z  
    • haubi
    • ‏2011-03-24T10:43:20Z
    Seems this issue is already known as APAR IZ69955, and a fix is already available somehow.
    However, this fix introduces another problem - already known to IBM, but I don't have that APAR number yet.

    In the meantime, there is a workaround (or fix?) available in gcc's bug report.
    /haubi/
    haubi,
    Thank you for the information. But I can't really see from "APAR IZ69955" that this is the problem we have here. For a start there's a mention of C++, no mention of C, or static variables. Are you sure this is the same problem?

    Dave
  • haubi
    haubi
    37 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-24T14:07:33Z  
    haubi,
    Thank you for the information. But I can't really see from "APAR IZ69955" that this is the problem we have here. For a start there's a mention of C++, no mention of C, or static variables. Are you sure this is the same problem?

    Dave
    > But I can't really see from "APAR IZ69955" that this is the problem we have here.

    Well, me neither...
    But this (indirectly) was the answer our customer got when reporting the issue with gcc and uninitialized static variables.

    So let's see what IBM comes up with to fix the subsequent problem.

    /haubi/
  • DavidKirkby
    DavidKirkby
    5 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-03-24T18:10:21Z  
    • haubi
    • ‏2011-03-24T14:07:33Z
    > But I can't really see from "APAR IZ69955" that this is the problem we have here.

    Well, me neither...
    But this (indirectly) was the answer our customer got when reporting the issue with gcc and uninitialized static variables.

    So let's see what IBM comes up with to fix the subsequent problem.

    /haubi/
    > haubi wrote:
    > > But I can't really see from "APAR IZ69955" that this is the problem we have here.
    >
    > Well, me neither...
    > But this (indirectly) was the answer our customer got when reporting the issue with gcc and uninitialized static variables.
    >
    > So let's see what IBM comes up with to fix the subsequent problem.
    >
    > /haubi/

    Since you too don't see it is related, could you create a more obvious bug report, that describes the situation with gcc more precisely?

    From looking at APAR IZ69955, neither of us can see it is related. I personally can't possibly imagine any IBM developer having connecting the issues we have with gcc to that bug report. They are as different as chalk and cheese!

    Dave

    Dave
  • haubi
    haubi
    37 Posts

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-04-07T08:05:40Z  
    > haubi wrote:
    > > But I can't really see from "APAR IZ69955" that this is the problem we have here.
    >
    > Well, me neither...
    > But this (indirectly) was the answer our customer got when reporting the issue with gcc and uninitialized static variables.
    >
    > So let's see what IBM comes up with to fix the subsequent problem.
    >
    > /haubi/

    Since you too don't see it is related, could you create a more obvious bug report, that describes the situation with gcc more precisely?

    From looking at APAR IZ69955, neither of us can see it is related. I personally can't possibly imagine any IBM developer having connecting the issues we have with gcc to that bug report. They are as different as chalk and cheese!

    Dave

    Dave
    Just found APAR IZ98134 that looks like adressing this problem.
    /haubi/
  • ReddiSekharaSingala
    ReddiSekharaSingala
    1 Post

    Re: ld: 0711-593 SEVERE ERROR: Symbol C_BSTAT

    ‏2011-09-15T00:57:32Z  
    • haubi
    • ‏2011-04-07T08:05:40Z
    Just found APAR IZ98134 that looks like adressing this problem.
    /haubi/
    Hi All.

    I am very new to AIX , I want to know about AIX ,is there any AIX GUI for Connecting from Windows XP to AIX ,

    I need do the installation and configuraion for TAMIT sowftware in AIX

    Thanks in advance .

    Please help me.