Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2010-10-09T11:42:22Z by Srikrishan
SAM_DESH
SAM_DESH
1 Post
ACCEPTED ANSWER

Pinned topic RHEL 5.5 upgrade package error - Failed dependencies.

‏2010-10-01T08:57:15Z |
Hi,

I am trying to upgrade packages on RHEL 5.5. When i try to do so, i get the following error:

  1. rpm -ivh libgcc-4.4.4-5.el6.i686.rpm
warning: libgcc-4.4.4-5.el6.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID f21541eb
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by libgcc-4.4.4-5.el6.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by libgcc-4.4.4-5.el6.i686

The packages i am trying to install are RHEL 6 beta packages.So are they compatible on RHEL 5.5?
If not, what should be done to make them compatible?

I am new to patch management in RHEL,so any suggestion will be helpful.
Updated on 2010-10-09T11:42:22Z at 2010-10-09T11:42:22Z by Srikrishan
  • Srikrishan
    Srikrishan
    1 Post
    ACCEPTED ANSWER

    Re: RHEL 5.5 upgrade package error - Failed dependencies.

    ‏2010-10-09T11:42:22Z  in response to SAM_DESH
    >The packages i am trying to install are RHEL 6 beta packages.So are they compatible on RHEL 5.5?
    >If not, what should be done to make them compatible?

    Why are u trying to install RHEL6 packages on RHEL5.5, any particular reason?
    > rpm -ivh libgcc-4.4.4-5.el6.i686.rpm
    > warning: libgcc-4.4.4-5.el6.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID f21541eb
    > error: Failed dependencies:
    > rpmlib(FileDigests) <= 4.6.0-1 is needed by libgcc-4.4.4-5.el6.i686
    > rpmlib(PayloadIsXz) <= 5.2-1 is needed by libgcc-4.4.4-5.el6.i686

    The rpm option used while upgrading should be "-Uvh" so the command should be "rpm -Uvh libgcc...."
    The errors quite clearly say that you need to have the RHEL6 version packages which are required by libgcc.

    Please think again for doing this as this cab leave you system in a unstable state. Please consider doing a full upgrade to RHEL6 if possible.

    -Sri