Topic
  • 2 replies
  • Latest Post - ‏2010-09-18T00:31:41Z by smalabarba
SystemAdmin
SystemAdmin
8 Posts

Pinned topic Search in Browser

‏2010-09-17T04:52:12Z |
How to configure "Search in Browser" using FileNet Services for Lotus Quick v1.1.0.1?
Added "clientInfo.searchPage.url=http://hqdemo1:9080/WorkplaceXT/Search.jsf" to fnqs-siteprefs.properties which, is located in /QuickrRoot.

I was expecting to see a new entry in context menu for Search in Browser.
Updated on 2010-09-18T00:31:41Z at 2010-09-18T00:31:41Z by smalabarba
  • TigerTrix
    TigerTrix
    18 Posts

    Re: Search in Browser

    ‏2010-09-17T17:41:27Z  
    Documentation:
    Overview of Search In Browser
    Configuring for P8
    Configuring for CM8

    1. Make sure you have Connectors 8.5 or later on the desktop. I don't believe this works with Connectors 8.1.1 or 8.2.

    2. For the configuration change to take effect in the ECM server, remember to restart your application server so that the JVM re-reads the property file from disk. Remember that just stopping and starting the application within the app server is probably not enough because the JVM instance is still the same and needs to be restarted. This means restarting the WAS profile that the app is running in, probably server1. Also make sure you are restarting the correct server. Sometimes administrators accidentally mistake the Lotus Quickr server with the IBM ECM Services for Lotus Quickr server. Sometimes to make sure you are restarting the correct one, just navigate to the WAS folder, under the profile, under installedApps, you should see the ECM services app to ensure you have the correct profile you are about to restart.

    3. For the configturation change to take effect on the desktop, if you had already added the library as a place on the desktop, you need to add places again. Right-click on the library on the desktop, select "Add Places", it should auto-fill the server info for that library and list more libraries for that server or else re-enter. WHen the list of libraries comes up, leave the library checked as it was and just click finish. This should be enough for the application to re-read the library configuration and notice the change. The application reads the library configuration only once and caches it. You need to get the application to re-read it by re-adding places. But you don't have to remove & add the place back. But if it doesn't work, that would be the next thing to try. This is the step at the bottom of the configuration documentation titled "Changing the setting for existing libraries already on your desktop".

    Did this solve your problem? If not, can you provide more details? Also, if you are up for it, a good way to see if it is really configured and running live is to use a TCP/IP trace (or use Fiddler if you don't want to configure anything) on the desktop and see when you add places what server info properties are reported back to the application in the XML response for getServerInfo. One of them should be "searchPage.url".
  • smalabarba
    smalabarba
    12 Posts

    Re: Search in Browser

    ‏2010-09-18T00:31:41Z  
    • TigerTrix
    • ‏2010-09-17T17:41:27Z
    Documentation:
    Overview of Search In Browser
    Configuring for P8
    Configuring for CM8

    1. Make sure you have Connectors 8.5 or later on the desktop. I don't believe this works with Connectors 8.1.1 or 8.2.

    2. For the configuration change to take effect in the ECM server, remember to restart your application server so that the JVM re-reads the property file from disk. Remember that just stopping and starting the application within the app server is probably not enough because the JVM instance is still the same and needs to be restarted. This means restarting the WAS profile that the app is running in, probably server1. Also make sure you are restarting the correct server. Sometimes administrators accidentally mistake the Lotus Quickr server with the IBM ECM Services for Lotus Quickr server. Sometimes to make sure you are restarting the correct one, just navigate to the WAS folder, under the profile, under installedApps, you should see the ECM services app to ensure you have the correct profile you are about to restart.

    3. For the configturation change to take effect on the desktop, if you had already added the library as a place on the desktop, you need to add places again. Right-click on the library on the desktop, select "Add Places", it should auto-fill the server info for that library and list more libraries for that server or else re-enter. WHen the list of libraries comes up, leave the library checked as it was and just click finish. This should be enough for the application to re-read the library configuration and notice the change. The application reads the library configuration only once and caches it. You need to get the application to re-read it by re-adding places. But you don't have to remove & add the place back. But if it doesn't work, that would be the next thing to try. This is the step at the bottom of the configuration documentation titled "Changing the setting for existing libraries already on your desktop".

    Did this solve your problem? If not, can you provide more details? Also, if you are up for it, a good way to see if it is really configured and running live is to use a TCP/IP trace (or use Fiddler if you don't want to configure anything) on the desktop and see when you add places what server info properties are reported back to the application in the XML response for getServerInfo. One of them should be "searchPage.url".
    In FileNet Services for Lotus Quickr, you don't have to restart the WAS profile. Just the enterprise application ("FNQuickrServices" by default).

    There's more info on this page. Most settings are re-read from the site preferences document automatically, but the searchPage URL setting isn't.