Topic
2 replies Latest Post - ‏2010-08-30T06:54:05Z by Saruton
Saruton
Saruton
111 Posts
ACCEPTED ANSWER

Pinned topic Error during installation of IMP Runtime

‏2010-08-23T08:46:49Z |
Hi All,

During the setup of Streams Studio to Eclipse IDE for C/C++ Developers (Ver.3.5), an error occurs as follows:


Cannot complete the install because one or more required items could not be
found.
Software currently installed: InfoSphere Streams Studio 1.2.0.201002102141
(com.ibm.distillery.ssd.feature.feature.group 1.2.0.201002102141)
Missing requirement: IMP Transformation Toolkit (Incubation)
0.1.93.v201008201835 (org.eclipse.imp.xform 0.1.93.v201008201835) requires
'bundle org.junit 0.0.0' but it could not be found
Cannot satisfy dependency:
From: InfoSphere Streams Studio 1.2.0.201002102141
(com.ibm.distillery.ssd.feature.feature.group 1.2.0.201002102141)
To: org.eclipse.imp.runtime.feature.group 0.1.97
Cannot satisfy dependency:
From: IMP Runtime (Incubation) 0.1.108.v201008201835
(org.eclipse.imp.runtime.feature.group 0.1.108.v201008201835)
To: org.eclipse.imp.xform http://0.1.93.v201008201835


Meanwhile when I setup Streams Studio to Eclipse IDE for Java EE Developers (Ver.3.5), this error doesn't occur. Why?

Should I choose Java EE Developers, not C/C++ Developers?
Could you tell me the solvent to this problem?

Thank you very much in advance.
  • SystemAdmin
    SystemAdmin
    1245 Posts
    ACCEPTED ANSWER

    Re: Error during installation of IMP Runtime

    ‏2010-08-24T00:47:45Z  in response to Saruton
    I would recommend installing the Eclipse Java Development Tools (JDT), which includes the org.junit plugin referenced by the dependencies error that you encountered.

    The feature ID of the JDT is org.eclipse.jdt. Both the 3.5.2 and 3.6.0 versions reference org.junit.

    Likely for the Java EE Developers includes the JDT, which would explain why the dependency was resolved.

    Please tell me if this resolves the dependency issue, and I'll update the product documentation.

    Thanks,
    Andy
    • Saruton
      Saruton
      111 Posts
      ACCEPTED ANSWER

      Re: Error during installation of IMP Runtime

      ‏2010-08-30T06:54:05Z  in response to SystemAdmin
      Thank you for your advice and sorry that my response has been late.

      I added JDT (3.6.0) to my Eclipse and I didn't encounter the dependency error.

      As the prerequisite for installation of Streams Studio, JDT is required, isn't it?
      I'm going to add this description to my document.

      Thanks a lot!