Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2010-08-18T04:47:59Z by buildforge_user
buildforge_user
buildforge_user
2 Posts
ACCEPTED ANSWER

Pinned topic Headless Build - BuildForge/RAD7 Env - IOUtils Error

‏2010-08-17T16:12:16Z |
Hi,

I am trying to do a headless build on the command line using the RunAntRAD.bat file, but the build errors out with an IOUtils error.

I am attaching the complete log. Any ideas on how I can troubleshoot the error.

When I run the same build script in my RAD7 workspace, it works fine, its only when I try to run the script using the RunAntRAD.bat file that the build fails.

Could someone please provide some feedback?

Thanks much!!
Updated on 2010-08-18T04:47:59Z at 2010-08-18T04:47:59Z by buildforge_user
  • SystemAdmin
    SystemAdmin
    805 Posts
    ACCEPTED ANSWER

    Re: Headless Build - BuildForge/RAD7 Env - IOUtils Error

    ‏2010-08-17T18:07:56Z  in response to buildforge_user
    From the log, seems you have some third-party plug-in from Instantiations, which has a dependency on the Apache commons library.

    "java.lang.NoClassDefFoundError: org.apache.commons.io.IOUtils
    projectBuild at com.instantiations.assist.eclipse.junit.editor.core.TestCaseSourceDescriber.describe(TestCaseSourceDescriber.java:86)"

    You probably need to add its location to your CLASSPATH .
    • buildforge_user
      buildforge_user
      2 Posts
      ACCEPTED ANSWER

      Re: Headless Build - BuildForge/RAD7 Env - IOUtils Error

      ‏2010-08-18T04:47:59Z  in response to SystemAdmin
      Robert,

      Thanks for your response. I believe the error relates to the IOUtils class in the commons-io.1.4.jar and the editor.jar for the instantiations plugins.

      I put both of these in the classpath in the .bat file and also in the "Environment Variables" of the machine that I am running it on from the command line

      See below:

      classpath is " D:\BF_COB\UI\i276663\COBUtilityManager_ear\lib\commons-io-1.4.jar;C:\IBM\SDP70\plugins\com.instantiations.assist.eclipse.junit.editor_5.0.0\editor.jar

      ALLUSERSPROFILE=C:\Documents and Settings\All Users
      ANT_HOME=C:\Program Files\IBM\SDP70Shared\plugins\org.apache.ant_1.6.5
      APPDATA=C:\Documents and Settings\I276663\Application Data
      CANDLE_HOME=C:\IBM\ITM
      CLASSPATH=D:\BF_COB\UI\i276663\COBUtilityManager_ear\lib\commons-io-1.4.jar;C:\I
      BM\SDP70\plugins\com.instantiations.assist.eclipse.junit.editor_5.0.0\editor.jar

      CLIENTNAME=P471NH00

      The issue remains and I still get the same error. Please advise.

      Thanks!