Topic
  • 2 replies
  • Latest Post - ‏2013-03-18T08:47:16Z by SystemAdmin
SystemAdmin
SystemAdmin
6195 Posts

Pinned topic How to add EGL Rich UI into RBD

‏2008-11-21T17:56:59Z |
Hi all,

I am trying to add EGL Rich UI into RBD with the help of Installation guide pdf which is available on EGL Cafe.
when I try to add that It gives the following error as below.
IBM Rational EGL Rich Web Support (2.0.0) requires plug-in "org.eclipse.wst.wsdl (1.1.200)", or equivalent.
Could you tell me that I have to add this plug-in explicitly into RBD?
help me out ASAP.
thanks,
Prabhu
Attachments:
Rich UI.bmp
Updated on 2013-03-18T08:47:16Z at 2013-03-18T08:47:16Z by SystemAdmin
  • jsayles
    jsayles
    420 Posts

    Re: How to add EGL Rich UI into RBD

    ‏2008-11-28T12:24:27Z  

    Hi Prabhu. I think we discussed this over eMail, right? Rich UI will be available in EGL version 7.5.1 - due out in December.
    Until then, feel free to read the EGL/Rich UI materials on the Cafe in the Rich UI hub
  • SystemAdmin
    SystemAdmin
    6195 Posts

    How to call a service from EGL Rich UI ( RBD version 7.5.1.8)

    ‏2013-03-18T08:47:16Z  
    • jsayles
    • ‏2008-11-28T12:24:27Z

    Hi Prabhu. I think we discussed this over eMail, right? Rich UI will be available in EGL version 7.5.1 - due out in December.
    Until then, feel free to read the EGL/Rich UI materials on the Cafe in the Rich UI hub
    Hi i am new to Rich-ui programming,

    Am using the licensed RBD version 7.5.1.8 , i am trying to call a service from the UI handler (simple hello world program) when i test my program am getting the below error message,

    CRRUI1083E] An error occurred while the click browser event was being handled.
    CRRUI3651E Service binding key : 'newserv' does not exist in the deployment descriptor 'Richproj'
    CRRUI2094E Here are the EGL function calls leading to this error:

    ServiceBinder.ServiceBinder.getBinding() native JavaScript
    ServiceLib.ServiceLib.bindService() native JavaScript
    final1.GoButton_onClick() native JavaScript
    Button.Widget.runEventHandlers() native JavaScript
    I think i need to follow some setting in my RBD for rich UI (I have done the basic setting in the prefrence )or add entry of program or service in the deployment descriptor ,

    The same code is working in EGL commuity edition but not in RBD version 7.5.1.8, in community edition i never added any entry in the deployment descriptor.

    Can anyone help me how to do it because i tried by myself it is giving the same error again.

    Thanks