Topic
6 replies Latest Post - ‏2012-11-28T20:02:09Z by mdindagur
neilgreggs
neilgreggs
14 Posts
ACCEPTED ANSWER

Pinned topic Using ICAP with McAfree Email and Web Security Applicance v5.1

‏2010-08-12T12:49:20Z |
Hello

I am looking to utilise a McAfree Email and Web Security Applicance v5.1 virtual appliance to provide ICAP AV functionality with a DP MPGW.

When I go to configure an Anti-Virus Action, For ICAP Host Type there are several options. Would I be right to select Webwasher as McAfee purchased the company? Currently I have this selected but the MPGW does not direct any traffic towards the ICAP applicance.

I have the hostname as the IP address and the port as the default 1344 but I am unsure of the Remote-uri, I currently have it set as icap://ip address/

If anyone can provide assistance as to how to configure ICAP correctly from a DP MPGW and A McAfee device it would be greatly appreciated.

Many thanks
Neil
Updated on 2012-11-28T20:02:09Z at 2012-11-28T20:02:09Z by mdindagur
  • Ramsyee
    Ramsyee
    127 Posts
    ACCEPTED ANSWER

    Re: Using ICAP with McAfree Email and Web Security Applicance v5.1

    ‏2012-06-19T00:16:06Z  in response to neilgreggs
    Hi floks

    Looking for same info(above) Does anyone configured yet with webwasher. If yes

    Please share the details

    THanks in advance
  • msiebler
    msiebler
    140 Posts
    ACCEPTED ANSWER

    Re: Using ICAP with McAfree Email and Web Security Applicance v5.1

    ‏2012-06-19T10:49:48Z  in response to neilgreggs
    we do test w/ webwasher so it should work; so if you do not see any requests you my need to check your routing
    • Ramsyee
      Ramsyee
      127 Posts
      ACCEPTED ANSWER

      Re: Using ICAP with McAfree Email and Web Security Applicance v5.1

      ‏2012-06-19T17:01:20Z  in response to msiebler
      Thanks for your reply

      1)Checked the routing, it is fine
      2)Can i know what did you put in uri portion in datapower

      3)I checked with webwasher team they say they have enabled icap. What else i can ask to enable ?
      • msiebler
        msiebler
        140 Posts
        ACCEPTED ANSWER

        Re: Using ICAP with McAfree Email and Web Security Applicance v5.1

        ‏2012-06-19T22:02:19Z  in response to Ramsyee
        if you have put in the host & port i think you do not need the uri; try removingit
        also; does your input have an attachment to scan?
        • Ramsyee
          Ramsyee
          127 Posts
          ACCEPTED ANSWER

          Re: Using ICAP with McAfree Email and Web Security Applicance v5.1

          ‏2012-06-21T17:21:56Z  in response to msiebler
          Thanks for all

          The issue is resolved. I just used host and port and no uri.

          It was the issue with Webwasher Ip.
          • mdindagur
            mdindagur
            41 Posts
            ACCEPTED ANSWER

            Re: Using ICAP with McAfree Email and Web Security Applicance v5.1

            ‏2012-11-28T20:02:09Z  in response to Ramsyee
            Hi,

            We are trying to use symantec protection engine for virus scan using datapower MPGW, as explained by this post. In our case, If we don't specify the uri, we get the following error:

            Error occurred when connecting to URL 'icap://host:port/'

            Moreover, though Symantec scan engine has around 12 service options documented, the only URI which seems to connect to scan engine is avscan. There doesnt seem to be a set standard. I am not sure if this is an issue with scan engines or the datapower mappings for ICAPRemoteURI to be supplied to the scan engine. Any suggestions in this regard is highly appreciated.
            thanks,
            -Mahesh M