Topic
  • 12 replies
  • Latest Post - ‏2011-08-10T19:49:19Z by SystemAdmin
Steen Brahe
Steen Brahe
3 Posts

Pinned topic Problem with installing the Eclipse tooling

‏2010-08-09T13:20:31Z |
I am using the Eclipse 3.6 JEE edition and try to install the Rational OSGi tooling through the Eclipse Marketplace.
However, it comes with an error message saying:
No repository found at http://public.dhe.ibm.com/ibmdl/export/pub/software/rational/OSGiAppTools.

Is the repository missing, or can it be a local firewall issue at my location?
Updated on 2011-08-10T19:49:19Z at 2011-08-10T19:49:19Z by SystemAdmin
  • deboer
    deboer
    2 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-09T13:51:46Z  
    Hi Steen,

    That is the correct URL (see instructions at [1]), and it was working for me on Friday, and still is today. It could have been a temporary hiccup, but I would not expect a firewall to cause issues since it uses port 80. Please try again and let me know if you still have problems.

    Tim

    [1] http://www.ibm.com/developerworks/rational/downloads/10/rationaldevtoolsforosgiapplications.html
  • Steen Brahe
    Steen Brahe
    3 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-11T10:50:10Z  
    • deboer
    • ‏2010-08-09T13:51:46Z
    Hi Steen,

    That is the correct URL (see instructions at [1]), and it was working for me on Friday, and still is today. It could have been a temporary hiccup, but I would not expect a firewall to cause issues since it uses port 80. Please try again and let me know if you still have problems.

    Tim

    [1] http://www.ibm.com/developerworks/rational/downloads/10/rationaldevtoolsforosgiapplications.html
    Hi Tim,
    I tried again, and the same problem occurred.
    I also tried to use a mac from my private network (instead of Windows XP PC from the company network), and the result was the same.
  • Nelson.Jean
    Nelson.Jean
    4 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-11T14:28:27Z  
    Hi Tim,
    I tried again, and the same problem occurred.
    I also tried to use a mac from my private network (instead of Windows XP PC from the company network), and the result was the same.
    Hi Steen,

    Are you able to reach the URL directly from a browser?

    • Nelson
  • pientka
    pientka
    2 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-19T07:07:11Z  
    Hi Steen,

    Are you able to reach the URL directly from a browser?

    • Nelson
    I've the same problem with
    http://public.dhe.ibm.com/ibmdl/export/pub/software/rational/OSGiAppTools
    for days
    The requested URL /ibmdl/export/pub/software/rational/OSGiAppTools was not found on this server.
    IBM_HTTP_Server Server at public.dhe.ibm.com Port 80
  • Nelson.Jean
    Nelson.Jean
    4 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-19T14:18:34Z  
    • pientka
    • ‏2010-08-19T07:07:11Z
    I've the same problem with
    http://public.dhe.ibm.com/ibmdl/export/pub/software/rational/OSGiAppTools
    for days
    The requested URL /ibmdl/export/pub/software/rational/OSGiAppTools was not found on this server.
    IBM_HTTP_Server Server at public.dhe.ibm.com Port 80
    Hi Frank,

    I just pointed my browser to http://public.dhe.ibm.com/ibmdl/export/pub/software/rational/OSGiAppTools and I can see the files.

    I'll look into it and see why you can't seem to access it.

    • Nelson
  • Nelson.Jean
    Nelson.Jean
    4 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-19T14:39:31Z  
    • pientka
    • ‏2010-08-19T07:07:11Z
    I've the same problem with
    http://public.dhe.ibm.com/ibmdl/export/pub/software/rational/OSGiAppTools
    for days
    The requested URL /ibmdl/export/pub/software/rational/OSGiAppTools was not found on this server.
    IBM_HTTP_Server Server at public.dhe.ibm.com Port 80
    Hi Frank,

    The I/T folks found a bug which they have corrected now. Can you try accessing the site again?

    • Nelson
  • Nelson.Jean
    Nelson.Jean
    4 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-19T14:40:22Z  
    Hi Tim,
    I tried again, and the same problem occurred.
    I also tried to use a mac from my private network (instead of Windows XP PC from the company network), and the result was the same.
    Hi Steen,

    The problem should be fixed now -- can you try the site again?

    • Nelson
  • pientka
    pientka
    2 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2010-08-23T08:28:49Z  
    Hi Frank,

    The I/T folks found a bug which they have corrected now. Can you try accessing the site again?

    • Nelson
    now it works fine, thanks for help
  • SystemAdmin
    SystemAdmin
    9 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2011-03-07T01:03:49Z  
    • pientka
    • ‏2010-08-23T08:28:49Z
    now it works fine, thanks for help
    Again: the update site is empty. Can you please reupload the newest versions?
  • Champagne
    Champagne
    3 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2011-07-16T16:28:32Z  
    This is a little frustrating, I seem to spend more time trying to install this than I do actually trying to use it.

    I have had this installed once but was having quite a few problems so I decided to reinstall it today.
    Now as it goes through the installation proceedure I get the "Problem Occurred" message
    Installing Software has encountered a problem.

    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.reporting, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    Problems downloading artifact: osgi.bundle,oracle.database.driver.jdk14,10.2.0.1.
    MD5 hash is not as expected. Expected: 18b41634dcf1c4a05a3b70a0b264fc09 and found df03c060988fbab31b5c26507c4cef14.

    Does anyone have a practical guide to installation of this that might stop me wasting my time?
  • Champagne
    Champagne
    3 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2011-07-22T16:06:28Z  
    The error I'm getting now seems to indicate that there is a problem with the packages on the site for download.

    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.reporting, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    Problems downloading artifact: osgi.bundle,oracle.database.driver.jdk14,10.2.0.1.
    MD5 hash is not as expected. Expected: 18b41634dcf1c4a05a3b70a0b264fc09 and found df03c060988fbab31b5c26507c4cef14.

    Is anyone else finding this?
  • SystemAdmin
    SystemAdmin
    9 Posts

    Re: Problem with installing the Eclipse tooling

    ‏2011-08-10T19:49:19Z  
    • Champagne
    • ‏2011-07-22T16:06:28Z
    The error I'm getting now seems to indicate that there is a problem with the packages on the site for download.

    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.reporting, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    Problems downloading artifact: osgi.bundle,oracle.database.driver.jdk14,10.2.0.1.
    MD5 hash is not as expected. Expected: 18b41634dcf1c4a05a3b70a0b264fc09 and found df03c060988fbab31b5c26507c4cef14.

    Is anyone else finding this?
    I just installed it and it looks good to me.
    You start installing the latest Eclipse for Java EE developer.
    Then you Launch your Eclipse, and Go to Help > Install New Software, then you add the URL
    http://public.dhe.ibm.com/ibmdl/export/pub/software/rational/OSGiAppTools

    That should work for you !!

    Let me know if you are still seeing any problems.