Topic
  • 5 replies
  • Latest Post - ‏2011-01-03T14:43:37Z by Damien Garbarino
YannickGodin
YannickGodin
1 Post

Pinned topic ilog elixir 2.0 OrgChart FXB4 sdk 4.0 compatibility mode on MX only

‏2010-07-22T17:21:31Z |
Hi, i know that i need to use elixir 3.0 for applications using FXB SDK4.0, but i thought that i would be able to continue using my current 2.0 version with a project configured to run with compatibility mode turned on + MX Only as components sets. But that's not the case, it does compile but i'm getting a runtime error with the OrgChart:

ArgumentError: Error #1063: Argument count mismatch on mx.graphics::SolidColorStroke/apply(). Expected 3, got 1.
at ilog.utils::GraphicsUtil$/drawDashedLineImpl()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/utilities/src/flex/ilog/utils/GraphicsUtil.as:83]
at ilog.utils::GraphicsUtil$/drawDashedLine()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/utilities/src/flex/ilog/utils/GraphicsUtil.as:48]
at ilog.orgchart::OrgChart$/drawDashedLine()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/orgchart/src/flex/ilog/orgchart/OrgChart.as:2727]
at ilog.orgchart::OrgChart/drawLine()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/orgchart/src/flex/ilog/orgchart/OrgChart.as:2686]
at ilog.orgchart::OrgChart/drawAssistantsLinks()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/orgchart/src/flex/ilog/orgchart/OrgChart.as:2363]
at ilog.orgchart::OrgChart/drawLinksRecursively()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/orgchart/src/flex/ilog/orgchart/OrgChart.as:2329]
at ilog.orgchart::OrgChart/drawLinks()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/orgchart/src/flex/ilog/orgchart/OrgChart.as:2316]
at ilog.orgchart::OrgChart/updateDisplayList()[/usr/flex/elixir2.0/flex-suite/trunk/build/bin/sources/library/orgchart/src/flex/ilog/orgchart/OrgChart.as:4467]
I have tried to use the 3.0 demo with the compatibility mode but it won't compile. Help would be appreciated

Yannick.
Updated on 2011-01-03T14:43:37Z at 2011-01-03T14:43:37Z by Damien Garbarino
  • Damien Garbarino
    Damien Garbarino
    181 Posts

    Re: ilog elixir 2.0 OrgChart FXB4 sdk 4.0 compatibility mode on MX only

    ‏2010-07-27T12:44:39Z  
    Hi Yannick,

    Unfortunately, the 2.0 release does not support SDK 4.0 as defined in release notes and user manual. It will not work because of API incompatibilities.

    IBM ILOG Elixir 3.0 SWC has a minimum SDK version support of 4.0 and so does not support 3.0 compatibility mode.

    Thanks,

    Damien
  • esrefatak
    esrefatak
    19 Posts

    Re: ilog elixir 2.0 OrgChart FXB4 sdk 4.0 compatibility mode on MX only

    ‏2011-01-01T10:55:03Z  
    Hi Yannick,

    Unfortunately, the 2.0 release does not support SDK 4.0 as defined in release notes and user manual. It will not work because of API incompatibilities.

    IBM ILOG Elixir 3.0 SWC has a minimum SDK version support of 4.0 and so does not support 3.0 compatibility mode.

    Thanks,

    Damien
    Hi Damien,

    I am getting same error although I use Flex SDK 4.0.0 and Elixir 3.0. I am sending the some screenshots, shows my settings.

    I can send you the complete source code, privately.

    Esref Atak
    http://www.flexnedir.com
  • Damien Garbarino
    Damien Garbarino
    181 Posts

    Re: ilog elixir 2.0 OrgChart FXB4 sdk 4.0 compatibility mode on MX only

    ‏2011-01-03T08:58:21Z  
    • esrefatak
    • ‏2011-01-01T10:55:03Z
    Hi Damien,

    I am getting same error although I use Flex SDK 4.0.0 and Elixir 3.0. I am sending the some screenshots, shows my settings.

    I can send you the complete source code, privately.

    Esref Atak
    http://www.flexnedir.com
    Hi,

    Are you sure to use the SDK 4.0 with Elixir 3.0?

    Because the error means that the SDK version or the IBM ILOG Elixir version is not correct (API incompatibility).

    Thanks,

    Damien
  • esrefatak
    esrefatak
    19 Posts

    Re: ilog elixir 2.0 OrgChart FXB4 sdk 4.0 compatibility mode on MX only

    ‏2011-01-03T12:52:42Z  
    Hi,

    Are you sure to use the SDK 4.0 with Elixir 3.0?

    Because the error means that the SDK version or the IBM ILOG Elixir version is not correct (API incompatibility).

    Thanks,

    Damien
    Hi Damien. Thanks for your response. I am really sure, I am using SDK 4.0 with Elixir 3.0. As you can see in screenshot.

    The point is ; i have migrated from Mac to Win. copying files from Mac to Win. Is it important?
  • Damien Garbarino
    Damien Garbarino
    181 Posts

    Re: ilog elixir 2.0 OrgChart FXB4 sdk 4.0 compatibility mode on MX only

    ‏2011-01-03T14:43:37Z  
    • esrefatak
    • ‏2011-01-03T12:52:42Z
    Hi Damien. Thanks for your response. I am really sure, I am using SDK 4.0 with Elixir 3.0. As you can see in screenshot.

    The point is ; i have migrated from Mac to Win. copying files from Mac to Win. Is it important?
    Sorry but I tested again and it works perfectly.

    Please re-download the SDK 4.0 (or 4.1) and try again.

    Concerning the migration from MAC to windows, I didn't personally tested this kind of migration. I don't foresee issues with source files.

    Thanks,

    Damien