Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2010-09-03T04:50:19Z by bfields
bfields
bfields
8 Posts
ACCEPTED ANSWER

Pinned topic Install: Eclipse Classic update shows missing plugins after base install

‏2010-07-18T05:51:24Z |
I enabled Eclipse Classic update under Preferences -> Workspace -> Capabilities. Added any external update site and searched for new features to install (example update site for PMD: http://pmd.sourceforge.net/eclipse). There are missing plugin dependencies in the base RSA8 installation which prevents adding additional plugins:

Rational Software Analyzer Reporting (7.0.400.v20100518_1916) requires plug-in "com.lowagie.itext (1.5.0)", or later version.

RRC Integration Feature (1.0.0.v20100605_0748) requires plug-in "org.eclipse.uml2.uml (2.0.3)" or compatible.

UML2 (2.0.3.v200702141227) requires plug-in "org.eclipse.emf.codegen.ecore (2.2.0)", or equivalent.

Rational Software Analyzer Reporting (7.0.400.v20100518_1916) requires plug-in "com.ibm.icu (3.4.4)", or compatible.

I gave up after adding these four external dependencies manually because it kept giving me an infinite loop with the error "Error notifying registry change listener. Error notifying registry change listener. Invalid registry object". It also could not find the compatible features I added for itext and icu. I never could get the Classic Update to work.
Updated on 2010-09-03T04:50:19Z at 2010-09-03T04:50:19Z by bfields
  • bfields
    bfields
    8 Posts
    ACCEPTED ANSWER

    Re: Install: Eclipse Classic update shows missing plugins after base install

    ‏2010-09-03T04:50:19Z  in response to bfields
    Has this issue been fixed in the released version? It makes it impossible to add external plugins to the Eclipse configuration. I never got a response to the original problem report.