Topic
6 replies Latest Post - ‏2010-08-09T20:47:03Z by Conan_Chan
SystemAdmin
SystemAdmin
19 Posts
ACCEPTED ANSWER

Pinned topic [Web] Unable to launch AJAX Test Server

‏2010-06-20T17:33:40Z |
I wanted to explore the DOJO support by RAD/RSA in the new version. After copy/paste of a small test script, I tried to launch the AJAX Test Server. An error message popped up stating the org.eclipse.wst.server.preview bundle was missing. I did install RSA complete (except for the C/C++ support).
Updated on 2010-08-09T20:47:03Z at 2010-08-09T20:47:03Z by Conan_Chan
  • SystemAdmin
    SystemAdmin
    19 Posts
    ACCEPTED ANSWER

    Re: [Web] Unable to launch AJAX Test Server

    ‏2010-06-20T17:34:25Z  in response to SystemAdmin
    Fixed the problem by adding the RAD beta install. This should not be required should it?
    • Conan_Chan
      Conan_Chan
      3 Posts
      ACCEPTED ANSWER

      Re: [Web] Unable to launch AJAX Test Server

      ‏2010-07-07T14:58:37Z  in response to SystemAdmin
      Can you please tells me the list of install feature selected for RSx and RAD?
      (There is a View Installed Package html from the start menu)
      • SystemAdmin
        SystemAdmin
        19 Posts
        ACCEPTED ANSWER

        Re: [Web] Unable to launch AJAX Test Server

        ‏2010-07-23T07:01:46Z  in response to Conan_Chan
        Hi Conan,

        Here the list of installed features.

        Kind regards,
        René
        • Conan_Chan
          Conan_Chan
          3 Posts
          ACCEPTED ANSWER

          Re: [Web] Unable to launch AJAX Test Server

          ‏2010-08-09T17:24:58Z  in response to SystemAdmin
          org.eclipse.wst.server_adapters.feature which contains org.eclipse.wst.server.preview is part of RAD 8 beta 1 and beta 2 and upcoming GM.

          Therefore from the Install side org.eclipse.wst.server.preview should have been available.

          I think we will need someone from the AJax tools to look into why it is not loaded when only RAD is installed.
          • jim_zhang
            jim_zhang
            1 Post
            ACCEPTED ANSWER

            Re: [Web] Unable to launch AJAX Test Server

            ‏2010-08-09T19:30:28Z  in response to Conan_Chan
            There's no reason this should fail, unless the install is somehow corrupted. Please go to "Help -> About <product name>" dialog and click on "Installation Details" button. In the "Plugins" tab, search for "org.eclipse.wst.server.preview".

            There are two possible outcomes:
            • the plugin is not listed: your installation is not valid, because this is required by the components you have chosen to install. In this case open the file C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager Beta\logs\index.xml (yours may vary based on the OS). There you should be able to view logs for each installation. There may be messages about install problems.

            • the plugin is listed: for some reason it was not successfully activated. In this case open the file <your workspace>/.metadata/.log. There may be messages about plugin activation problems.

            Let us know what you find out.
            • Conan_Chan
              Conan_Chan
              3 Posts
              ACCEPTED ANSWER

              Re: [Web] Unable to launch AJAX Test Server

              ‏2010-08-09T20:47:03Z  in response to jim_zhang
              I misinterpreted the scenario in reverse.. and thought it is fixed after Installing RSA beta.

              Instead it is fix after installing RAD beta..

              I doubled checked RSA 8 beta 1, org.eclipse.wst.server_adapters.feature is not there.

              But RSA 8 beta 2 and the up coming RSA 8 GM has it..

              So this problem has already been addressed.