Topic
  • 8 replies
  • Latest Post - ‏2011-12-09T09:52:55Z by MarkN
Panchal
Panchal
34 Posts

Pinned topic OSGi Feature-pack doesn't seem to work with WPS Server

‏2010-06-08T17:01:18Z |
Hi,
We have WPS 7.0.0.2 installed with the following feature packs
SCA 1.0.1.5
AriesAndJPA FeaturePack 1.0.0 (latest release)

The details of the version Info is [rovided in the attached zip file.
When I deployed my OSGi application in a regular WAS installation with the same featurepacks it works. But the same EBA file when imported and deployed within this environment gives me the following error


[6/8/10 12:34:36:646 EDT] 0000004c Core          E   CWSCA3050E: The com.ibm.ws.osgi.web.extender.module.ModuleClassLoader@2b2e2b2e Local ClassPath: Parent: com.ibm.ws.osgi.web.extender.WABClassLoader@393d393d Delegation Mode: PARENT_FIRST 

class loader did not start because the application is stopped. [6/8/10 12:34:36:662 EDT] 0000004c WebModuleExte E   CWSAH0011E: An internal error occurred. The runtime environment could not start the Web bundle com.dev.test.web_1.0.0.43 because of exception java.lang.RuntimeException: Unable to start a Web Application: com.dev.test.web_1.0.0.43


We get the same error when we create a plain WAS profile instead of a WPS profile with the WPS installation.

Please help us in resolving this issue.

Thanks in advance.
Updated on 2011-12-09T09:52:55Z at 2011-12-09T09:52:55Z by MarkN
  • SystemAdmin
    SystemAdmin
    153 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2010-06-09T08:50:14Z  
    Hi Panchal,

    This problem unfortunately looks like a bug in the interaction with the WPS product. Could you raise a PMR for this issue? Please include the logs that you have attached to the post.

    Regards,

    Valentin
  • Panchal
    Panchal
    34 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2010-06-09T13:47:48Z  
    Thanks. Will create a PMR.
  • SystemAdmin
    SystemAdmin
    153 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2011-02-28T09:53:46Z  
    We are facing the same problems with Mediation Modules installed on WPS.
    2/28/11 10:26:27:828 CET 00000084 Core E CWSCA3050E: The
    com.ibm.ws.classloader.CompoundClassLoader@7fa97fa9appwar:VisenoMediationService_1_0App
    Local ClassPath:
    Parent: com.ibm.ws.classloader.ProtectionClassLoader@54b154b1
    Delegation Mode: PARENT_FIRST class loader did not start because the application is stopped.
    2/28/11 10:26:27:833 CET 00000084 Core E CWSCA3050E: The
    com.ibm.ws.classloader.CompoundClassLoader@7fa97fa9appwar:VisenoMediationService_1_0App
    Local ClassPath:
    Parent: com.ibm.ws.classloader.ProtectionClassLoader@54b154b1
    Delegation Mode: PARENT_FIRST class loader did not start because the application is stopped.

    This log is repeated for around ten times.
  • lenet
    lenet
    1 Post

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2011-03-22T12:16:50Z  
    Was your PMR resolved, and what was the solution? Seeing the exact same error now on WPS 7.0.0.3
  • MarkN
    MarkN
    124 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2011-05-04T10:32:55Z  
    • lenet
    • ‏2011-03-22T12:16:50Z
    Was your PMR resolved, and what was the solution? Seeing the exact same error now on WPS 7.0.0.3
    Hello,
    I'm sorry for the long period of silence on this thread. We've been working with the WPS development team to isolate and develop a fix for this problem. I've raised PMR 55949,999,000 to request the release of the WPS patch that we've now tested internally. I'll update this thread again once something's available to download. Thank you for your patience :)

    Regards,
    Mark
  • MarkN
    MarkN
    124 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2011-07-01T11:32:57Z  
    Hello,
    A fix is now available for this problem. Please see APAR JR39549 available from here.

    Regards,
    Mark
  • SystemAdmin
    SystemAdmin
    153 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2011-12-09T08:46:26Z  
    Hi, I get the following error on a WebSphere ESB 7.0.0.3 server:

    12/6/11 16:29:19:193 CET 0000e5b9 Core E CWSCA3050E: The
    com.ibm.ws.classloader.CompoundClassLoader@10001appwar:sapDebitorIntegrationApp_v0-0
    Local ClassPath:
    Parent: com.ibm.ws.classloader.ProtectionClassLoader@3b173b17
    Delegation Mode: PARENT_FIRST class loader did not start because the ap-plication is stopped.

    It is not really reproducible, but occurs from time to time. Is this problem also fixed by APAR JR39549 ?

    Thanks, Daniel
  • MarkN
    MarkN
    124 Posts

    Re: OSGi Feature-pack doesn't seem to work with WPS Server

    ‏2011-12-09T09:52:55Z  
    Hi, I get the following error on a WebSphere ESB 7.0.0.3 server:

    12/6/11 16:29:19:193 CET 0000e5b9 Core E CWSCA3050E: The
    com.ibm.ws.classloader.CompoundClassLoader@10001appwar:sapDebitorIntegrationApp_v0-0
    Local ClassPath:
    Parent: com.ibm.ws.classloader.ProtectionClassLoader@3b173b17
    Delegation Mode: PARENT_FIRST class loader did not start because the ap-plication is stopped.

    It is not really reproducible, but occurs from time to time. Is this problem also fixed by APAR JR39549 ?

    Thanks, Daniel
    Hi Daniel,
    The problem that you're seeing has the same signature as that fixed by JR39549, but I don't wish to advise applying a WPS fix to WESB. That's not at all likely to end well. Please would you be so kind as to raise a WESB PMR? It may well be that a port of APAR JR39549 to WESB is required.

    Regards,
    Mark